Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Operator » Configure Operator for Multifon
  •  
pdum

Messages: 8
Karma: 2
Send a private message to this user
Hello.

I need to configure the extension of the operator Megafon / Multifon.
The site Multifon recommended this settings:
[general]
register =>
792xxxxxxxx@multifon.ru:%20pasSWORD123:792xxxxxxxx@sbc.megafon.ru:5060/792xxxxxxxx">792xxxxxxxx@multifon.ru: pasSWORD123:792xxxxxxxx<_at_>sbc.megafon.ru:5060/792xxxxxxxx

[multifon-out]
dtmfmode = inband
username = 792xxxxxxxx
type = peer
secret = pasSWORD123
host = sbc.megafon.ru
fromuser = 792xxxxxxxx
fromdomain = multifon.ru
port = 5060
nat = yes
context = incoming
insecure = port, invite

That is, the user name must be 792xxxxxxxx<_at_>multifon.ru.

I configure Kerio Operator as:
external number = 792xxxxxxxx
host = sbc.megafon.ru
port = 5060
username = 792xxxxxxxx<_at_>megafon.ru
password = password
need register

and have this error when connecting:
[06/Apr/2012 14:15:51] Operator asterisk[1628]: WARNING[1646]: chan_sip.c:20047 in handle_response_register: Forbidden - wrong password on authentication for REGISTER for \'792XXXXXXXX\'

I understand the problem is that the user name does not contain the domain name.
How can I fix it?
Thank you.
  •  
silars

Messages: 429
Karma: 59
Send a private message to this user
Did you try setting "User ID differs from the telephone number"? Enable that and set it to 792xxxxxxxx<_at_>multifon.ru.
  •  
pdum

Messages: 8
Karma: 2
Send a private message to this user
Thank you! But when I typing "792xxxxxxxx<_at_>multifon.ru" in this field Operator say: Invalid field value.
  •  
Vladimir Toncar (Kerio)

Messages: 1696
Karma: 39
Send a private message to this user
I think you only need to set the field "User ID differs from the telephone number" to 792xxxxxxxx

One of the effects is that it will set the "fromuser" field in Asterisk configuration.
  •  
pdum

Messages: 8
Karma: 2
Send a private message to this user
Vladimir Toncar (Kerio) wrote on Fri, 06 April 2012 16:13
I think you only need to set the field "User ID differs from the telephone number" to 792xxxxxxxx

One of the effects is that it will set the "fromuser" field in Asterisk configuration.


tried to do so but the result is the same. I think the key here:

register =>
792xxxxxxxx@multifon.ru:%20pasSWORD123:792xxxxxxxx@sbc.megafon.ru:5060/792xxxxxxxx">792xxxxxxxx<_at_>multifon.ru: pasSWORD123:792xxxxxxxx<_at_>sbc.megafon.ru:5060/792xxxxxxxx
  •  
pdum

Messages: 8
Karma: 2
Send a private message to this user
Any other ideas?
ty
  •  
Vladimir Toncar (Kerio)

Messages: 1696
Karma: 39
Send a private message to this user
Would it be possible to obtain a test account from Multifon?
  •  
pdum

Messages: 8
Karma: 2
Send a private message to this user
I'm already found solution:

Settings for extension:
Extension number: 792XXXXXXXX
Hostname: multifon.ru
Port: 5060
Username: 792XXXXXXXX
Password: PassWor1d
* Need registration
That's all of need in web-interface. But need some tweak local filesystem:

1. Connect by ssh
2. # mount -o remount,rw /
3. # nano /etc/hosts
4. write to file:
193.201.229.35 multifon.ru
5. Save and exit
6. # mount -o remount,ro /

(193.201.229.35 - IP adress of Registration server sbc.multifon.ru)

With this settings all working fine. But this tweak need to repeat after you upgrade Operator to a newer version.
  •  
Vladimir Toncar (Kerio)

Messages: 1696
Karma: 39
Send a private message to this user
Why don't you just use sbc.multifon.ru as the hostname you enter in the configuration dialog?
  •  
pdum

Messages: 8
Karma: 2
Send a private message to this user
Quote:
Why don't you just use sbc.multifon.ru as the hostname you enter in the configuration dialog?


When I use sbc.multifon.ru as the hostname and 79XXXXXXXXX<_at_>multifon.ru as username registration string like this:
register => i-Megafon_SIP-outbound?79XXXXXXXXX:password:79XXXXXXXXX@multifon.ru<_at_>sbc.multifon.ru/79XXXXXXXXX
but for this provider need refister string as this:
register => i-Megafon_SIP-outbound?79XXXXXXXXX:password:79XXXXXXXXX<_at_ >multifon.ru/79XXXXXXXXX

and hostname for registration: sbc.multifon.ru
therefore, required the substitution of IP-adresses.
I understand that the problem is that in the Kerio Operator no equivalent directive fromdomain =.
  •  
Riddick

Messages: 44
Karma: 1
Send a private message to this user
Vladimir, I faced with the same problem on Multifon. Can you offer me a solution without editing of host file?
  •  
Vladimir Toncar (Kerio)

Messages: 1696
Karma: 39
Send a private message to this user
This thread is almost a year old. If you run a recent Operator version, it is possible to enter separate domain names for registering, inbound and outbound proxy.
Previous Topic: Upload Cisco languages language files
Next Topic: Call are being drops
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sat Nov 18 09:35:04 CET 2017

Total time taken to generate the page: 0.00535 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.