Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » 7.4.0 Stopping (7.4.0 mail server stopping on Windows 32 bit)
  •  
Dave Pooser

Messages: 1
Karma: 0
Send a private message to this user
kenwest wrote on Mon, 07 May 2012 21:17
Acknowledged as a bug by Kerio engineering. Lengthy HTML emails via ActiveSync will crash the server. To be fixed in 7.4.1.


Did they say whether the bug is exclusive to Windows servers, or if it's also present on Linux?
  •  
kenwest

Messages: 47
Karma: 2
Send a private message to this user
They didn't say and I didn't ask about Linux. We did have a discussion about how easy it is to build up to a "lengthy" HTML email though. It's not just what the original author writes. It's also all of the forwards and replys that come afterwards and get appended to the length of that original email. Before you know it you're at a length that will crash the Kerio email server.
  •  
freakinvibe

Messages: 1542
Karma: 62
Send a private message to this user
I have upgraded two servers to 7.4 and they both don't use Active Sync. They have been running very stable (on Windows) for two weeks. So looks really to be an Active Sync issue.

I will hold off upgrading any servers using ActiveSync until this bug is solved.

Dexion AG - The Blackberry Specialists in Switzerland
https://dexionag.ch
  •  
torque2k

Messages: 3
Karma: 0
Send a private message to this user
Thanks for the info, Kenwest. I'm going to contact Kerio support right now; I've got a client server that's gone offline three times this week. I'm on the same server, Win 2K3 32-bit, with ActiveSync users who like to put 17 GIFs in their signatures.
  •  
hbianchi

Messages: 121
Karma: 8
Send a private message to this user
I moved to 7.4 about 2 weeks ago (2 or 3 days after the release was available) and I had no such kind of "crashes". I'm running a 600 users installation over Red Hat Linux. I have some active sync users, but just a few. I don't know if the problem does not happens when using linux or it's just because of the few active sync I use.

On the other hand, since 7.4 I noted the server frequently become "frozen" for a while and then returns. This had happened in the past, but had disappeared when moving to release 7. "Frozen" isn't a big problem yet because it stands for just some seconds, but I'm afraid it can go worse.
  •  
torque2k

Messages: 3
Karma: 0
Send a private message to this user
Speaking with tech support today, they confirmed a bug in 7.4.0 with ActiveSync and long HTML emails, exactly what Kenwest had reported. Unfortunately they have no official (or even unofficial) timeframe for 7.4.1, so the only options are:
1) disable ActiveSync
2) Uninstall 7.4.0 and reinstall 7.3.3, taking care of the spamassassin DBs. If you need to do this option, I suggest using your tech support contract and calling them.

I'm off to roll back the server, wish me luck. Kerio's crashed six times today.
  •  
hbianchi

Messages: 121
Karma: 8
Send a private message to this user
I have just downgraded 7.4 to 7.3.3. I's strange because I had no major concerns since I went to 7.4 until now, and suddenly system badly crashed. In fact it did not chashed, it simply became completely stucked, frozen, unresponsive. I expect that now, as Kerio support is not freely attending customers any more and is not congested, would have time to deliver 7.4.1 a.s.a.p.
  •  
Waco1

Messages: 89
Karma: 0
Send a private message to this user
Can someone point me to the link for older releases, 7.3.3 for example?

Thanks

Nevermind. Firefox was still loading...

[Updated on: Fri, 18 May 2012 21:15]

  •  
torque2k

Messages: 3
Karma: 0
Send a private message to this user
download.kerio.com/archive/

Careful, I had no problems installing the 7.3.3 rollback, but I then had to go to each individual PC running Outlook, uninstall the offline connector, uninstall the Kerio updater app, install the 7.3.3 version (one machine required downloading the MSI version instead of the EXE), THEN go into the Mail control panel and clear the cache. Finally I could run Outlook, the offline connector install would "take", then the cache would resync.

Lots of hassles, but it's been stable for over 24 hours now.
  •  
Waco1

Messages: 89
Karma: 0
Send a private message to this user
Thanks for the warning!

I had intended to install 7.4.0, then I read about the ActiveSync issue.

I just installed 7.3.3 instead. So far, so good.

The tiny headaches, if there are any, will start Monday morning.

It seems that the handful of XP systems we have are the only systems that ever fail to upgrade correctly.

Is Kerio going to pull the 7.4.0 release? That would be the responsible thing to do at this point.

Sure, it's a political nightmare, but it's a subtle problem that normal QA would not catch. Admins usually understand those kinds of issues. But to leave a broken release as the default download? Not so much.
  •  
john.stone

Messages: 4
Karma: 0
Send a private message to this user
Kerio Connect just crashed three more times, rolling back isnt really an option since we have some many people on the road that a manual install of the older offline connector would take more than a day.

Does any one know how to disable just the ActiveSync function?
  •  
smb

Messages: 7
Karma: 0
Send a private message to this user
Has anyone running into the server crash issue tried the new v7.4.1 to see if the issue has been resolved?

I am holding off upgrading until they get this resolved.


Thanks

[Updated on: Tue, 29 May 2012 20:41]

  •  
kenwest

Messages: 47
Karma: 2
Send a private message to this user
Has anyone who experienced the ActiveSync crashing problem in 7.4.0 upgraded to 7.4.1? I'm concerned about upgrading without confirmation that the problem is fixed. Thanks!
  •  
hbianchi

Messages: 121
Karma: 8
Send a private message to this user
I'm waiting this confirmation too. I had to downgrade to 7.3.x and this was a real mess (because of KOC downgrade that is not as straight as you can think). I do not want to upgrade again and note problems are still there.
john.stone

Messages: 4
Karma: 0
Send a private message to this user
Yeah, after the downgrading fiasco we were forced to undergo since Kerio wouldn't release a fix, I am reluctant to try any upgrade.

Hopefully someone else who experienced the crashes has a boss who will tolerate it a bit better and let us know.
Previous Topic: AppleScript to sync public calendar?
Next Topic: Remove Blackberry phone from kerio
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sun Oct 22 21:14:00 CEST 2017

Total time taken to generate the page: 0.00505 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.