Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Operator » Snom "Not acceptable here" after beta upgrade
  •  
migsutu

Messages: 74
Karma: 0
Send a private message to this user
I updated our Operator 1.2.2 to the new 2.0 beta2 build. I am very excited about the parking ability. Upgrade went smooth, but I can't call out to any extensions or outbound with my snom sets since the upgrade. When I call out from any of our handsets, it says "Not Acceptable Here". Inbound calls to the handsets still work normally.

I have been reading up on this error with snom and it seems it has something to do with RTP encryption. Has anyone experienced this issue?
  •  
migsutu

Messages: 74
Karma: 0
Send a private message to this user
The fix is to turn off RTP encryption on the phones webpage. It is located under identity section of the phones. I hope this helps. I believe this only effect snom phones.
  •  
Filip Jenicek (Kerio)

Messages: 1094
Karma: 80
Send a private message to this user
Hi

Was your snom phone provisioned by Operator? If so, have you tried to reboot the phone? The phone should fetch new configuration while booting. RTP encryption is disabled in there.

Btw, you can also try to enable "Encrypted communication (sip tls + srtp)" for the snom's extension and test secure calling. It should work out of the box.

Best
Filip
  •  
migsutu

Messages: 74
Karma: 0
Send a private message to this user
I do have all the phones provisioned, however what I am curious about is whether they are actually receiving any settings from the provisioning. For example, when I tell all phones to restart from the Operator Admin Panel, the phones never actually restart.
  •  
Filip Jenicek (Kerio)

Messages: 1094
Karma: 80
Send a private message to this user
Some phones don't restart when their configuration had not changed. That's why the option is called "reload configuration" instead of "reboot". The best way how to verify that it works is to create a dummy extension and assign it to the phone. The phone should restart automatically. In case it doesn't, turn it off and on again. After that, there should be two or more lines registered.

Another way, which I usually use, is when a phone has an extension assigned to a user, I simply change the user's Full Name. This should also trigger a reboot.

I would be grateful if you provided me with the phone model(s) and firmware version, so I could reproduce the upgrade issues you're describing.

Thank you!
  •  
migsutu

Messages: 74
Karma: 0
Send a private message to this user
I am running a Snom 870s firmware 8.4.35. Changing full name or adding an extension does not cause the phones to reset. However the phone do receive the changes. For example, after chaning the full name of a user, a call from that users phone will show up as the new name with the caller ID. The restarting issue isn't a large cause of concern for me, since everything else seems to be working with a little tinkering.
  •  
jimdamico

Messages: 2
Karma: 0
Send a private message to this user
After upgrading 2 clients to Operator 2.0 this behavior has been present on every phone. An easy fix when only dealing with a few phones (as was the case for me) but I could see this being a huge pain for larger systems. RTP encryption is bumped on after upgrade. This needs to be addressed quickly, IMO, as it immediately makes the users phones unable to make outgoing calls, dial extensions, or check voicemail. All phones is both systems were SNOM 320's.

Hope this helps. Squash that bug!

Jim D.
  •  
Filip Jenicek (Kerio)

Messages: 1094
Karma: 80
Send a private message to this user
It's a bit more complicated than that.

Snom phones provisioned by Operator 1.2.X tried to use SRTP by default. Because there was no support for SRTP in 1.2.X the communication fell back to unencrypted audio and it worked, although there were some warnings in the warning log.

Operator 2.0.0 supports SRTP, but it is disabled by default. When a snom phone wants to make a call after the upgrade, it tries to use SRTP and the call fail.

An easy way how to fix it, is to restart the phone to obtain new configuration. This forces the phone not to request SRTP, but to use RTP instead.

Filip
  •  
jimdamico

Messages: 2
Karma: 0
Send a private message to this user
Filip,

I'm by no means an expert in VOIP so forgive my ignorance, but I did restart the phones. More than once.

Jim D.
  •  
fishtech

Messages: 628
Karma: 14
Send a private message to this user
Hi,

I am using snom phones and did not have this problem after upgrading to 2.

I have 300's and 870's.

In case it's relevant, my firmware is all 8.7.3.10. My phones are provisioned by typing tftp://operator.mycompany.com into Advanced > Update > Setting URL. My phones restart automatically if I change the extension allocated to the phone.

ft.

[Updated on: Wed, 01 August 2012 17:20]

Previous Topic: 888 numbers on a PRI
Next Topic: recorded calls
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Fri Nov 24 14:19:19 CET 2017

Total time taken to generate the page: 0.00444 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.