Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » [Solved] What does these error logs mean?
  •  
iamcj

Messages: 70
Karma: 1
Send a private message to this user
I want to use AD for authentication but failed.

Kerio always say the password is wrong.

I open the "directory service lookup" in debug log, and found these error repeated...

what does this mean? is it cause my problem for AD login?

thanks.

[15/Jun/2012 18:48:08][1412] {ldapdb} 7cbc66a3-6b4a-4e34-a86d-2de81d97e999: Looking up in cache...
[15/Jun/2012 18:48:08][1412] {ldapdb} 7cbc66a3-6b4a-4e34-a86d-2de81d97e999: found in cache me<_at_>iamcj.net
[15/Jun/2012 18:48:08][1412] {ldapdb} 7cbc66a3-6b4a-4e34-a86d-2de81d97e999: Looking up in cache...
[15/Jun/2012 18:48:08][1412] {ldapdb} 7cbc66a3-6b4a-4e34-a86d-2de81d97e999: found in cache me<_at_>iamcj.net
[15/Jun/2012 18:48:10][2712] {ldapdb} me<_at_>iamcj.net: Looking up in cache...
[15/Jun/2012 18:48:10][2712] {ldapdb} me<_at_>iamcj.net: found in cache
[15/Jun/2012 18:48:10][2712] {ldapdb} 7cbc66a3-6b4a-4e34-a86d-2de81d97e999

[Updated on: Mon, 18 June 2012 08:39]

  •  
garetjax

Messages: 38
Karma: 0
Send a private message to this user
Do you have the Kerio AD Extension installed?
  •  
iamcj

Messages: 70
Karma: 1
Send a private message to this user
sure, Kerio AD Extension installed
  •  
garetjax

Messages: 38
Karma: 0
Send a private message to this user
OK. Just checking.
  •  
iamcj

Messages: 70
Karma: 1
Send a private message to this user
which setting caused these error log?
  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
What error messages? I see only normal debug messages. You should enable Authentication module in debug log. I guess the Kerio Connect machine is not configured for correct Kerberos authentication against AD.
  •  
iamcj

Messages: 70
Karma: 1
Send a private message to this user
Pavel Dobry (Kerio) wrote on Sat, 16 June 2012 13:46
What error messages? I see only normal debug messages. You should enable Authentication module in debug log. I guess the Kerio Connect machine is not configured for correct Kerberos authentication against AD.


[17/Jun/2012 01:22:39][1496] {auth} Krb5: entering auth (user kerio<_at_>DOMAIN.LOCAL)
[17/Jun/2012 01:22:39][1496] {auth} Kerberos 5 auth: user kerio<_at_>DOMAIN.LOCAL not authenticated, error code c000018b
[17/Jun/2012 01:22:39][1496] {auth} c000018b (1787) 服务器上的安全数据库没有此工作站信任关系 的计算机帐户。

I have installed the AD extention, and create a test user "kerio" in AD, choose auto create the KC user.

then I try to login the user "kerio", get the error log as above...
  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
The error means that computer with Kerio Connect is not registered in Active Directory. Make sure the computer joined the AD domain and that correct SPN exists in Kerberos AD.
  •  
iamcj

Messages: 70
Karma: 1
Send a private message to this user
ok i will try as you suggested.

but in kerio admin it tells me the check passed...
  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
It does check only user mapping (via LDAP), not Kerberos authentication.
  •  
iamcj

Messages: 70
Karma: 1
Send a private message to this user
means the ways for check and login are diffirent
  •  
iamcj

Messages: 70
Karma: 1
Send a private message to this user
ok, after joining the AD, I can use AD user/pswd to login.

but the message still repeats, it cause the log file increasing very fast.

why kerio are keeping "looking up in cache", where can i modify to fix it?


[15/Jun/2012 18:48:08][1412] {ldapdb} 7cbc66a3-6b4a-4e34-a86d-2de81d97e999: Looking up in cache...
[15/Jun/2012 18:48:08][1412] {ldapdb} 7cbc66a3-6b4a-4e34-a86d-2de81d97e999: found in cache me<_at_>iamcj.net
[15/Jun/2012 18:48:08][1412] {ldapdb} 7cbc66a3-6b4a-4e34-a86d-2de81d97e999: Looking up in cache...
[15/Jun/2012 18:48:08][1412] {ldapdb} 7cbc66a3-6b4a-4e34-a86d-2de81d97e999: found in cache me<_at_>iamcj.net
[15/Jun/2012 18:48:10][2712] {ldapdb} me<_at_>iamcj.net: Looking up in cache...
[15/Jun/2012 18:48:10][2712] {ldapdb} me<_at_>iamcj.net: found in cache
[15/Jun/2012 18:48:10][2712] {ldapdb} 7cbc66a3-6b4a-4e34-a86d-2de81d97e999
  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
Because you've enabled these messages in the debug log.
Please read the manual to get basic knowledge of product settings. Thank you.
  •  
iamcj

Messages: 70
Karma: 1
Send a private message to this user
I do know it is because of the debug message enable in log.

Just wondering why it keeps looking for cache:)

Thanks I have no question.
Previous Topic: Get Groups/Members via API
Next Topic: Distribution Lists in client apps for Mac
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sat Nov 18 17:02:45 CET 2017

Total time taken to generate the page: 0.00550 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.