Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Operator » New Operator Install - Snom 300 not registering
  •  
FarVision

Messages: 10
Karma: 0
Send a private message to this user
New to to the Operator product and SIP phones. Used Control and Workspace with zero problems. Have IT background.


Can't for the life of me get my Snom 300 to register into my Operator NFR.

Not sure what I am missing.


Operator 2.0.0 RC1 build 588
Static IP.

Under Configuration > Provisioned Phones I have the MAC punched in, with the correct phone.

DHCP network is OK. Phone comes online. I took the phone from firmware 7.3.30 to 8.7.3.7 thinking that might fix the problem.

I can get to the Phone's HTTP page OK.

I keep getting the Welcome! Press a Key to Log in with the phone. I want to roll these out to users - I don't want to have to touch the phone manually.

On the Phone's HTTP page, I went into Identities and punched in my Registrar, which as I read it is my Operator machine, which is static at 192.168.15.254. The Password, which I read as the Master Password for Phones that's set up under Provisioning. It just won't register.


Not really sure of the missing piece of the puzzle.


  •  
fishtech

Messages: 627
Karma: 14
Send a private message to this user
This works for Snom 870:


1. Update to latest snom software on phone (8.7.3.7 right now)

2. Go to phone's web interface (you won't need a password if it's fresh-out-the-box)

3. Go Advanced > Update

4. Set Update Policy to 'Update automatically'. (not sure if this is required)

5. Set Setting URL to 'tftp://YourKerioOperatorAddress'

important... note the "tftp" prefix. Do not just use the http prefix which is pre-filled in the interface.

6. Confirm change & reboot phone.

7. After reboot you can allocate extension in Operator and reboot phone again.



hth,

ft

[Updated on: Tue, 03 July 2012 20:12]

  •  
FarVision

Messages: 10
Karma: 0
Send a private message to this user
Fantastic!

Oddly enough it reloaded the same firmware again, since I had previously upped the .bin through the Kerio interface before I did it through the phone interface.

But it does work and now register like you would expect. Thanks for this little gem.

  •  
Filip Jenicek (Kerio)

Messages: 1094
Karma: 80
Send a private message to this user
I suggest you to read:
http://manuals.kerio.com/operator/adminguide/en/chap-provisi oning
or
http://kb.kerio.com/article/configuring-automatic-phone-prov isioning-820.html

The key is to configure your DHCP server to send the option 66. Then you won't have to touch the phone nor type the mac addresses to Kerio Operator.

Best
Filip
  •  
fishtech

Messages: 627
Karma: 14
Send a private message to this user
Yes, option 66 is best practice.

But if you are using Mac OS X Server for DHCP you are out of luck with option 66 afaiaa. You will need to touch each phone to set the tftp address (but that's not a big deal imo).

I assumed the original poster was unable to use option 66.

Regards,

ft.
  •  
FarVision

Messages: 10
Karma: 0
Send a private message to this user
Yes, I was trying to dance around the TFTP broadcast issue. Some of our clients won't want to upgrade their routers, or buy Control. When I meant 'touch the phone' I meant fooling around with each phone physically. If I can see the IP address on it when it comes up, I can punch in the TFTP Url in the management page for the phone easily enough.
  •  
fishtech

Messages: 627
Karma: 14
Send a private message to this user
That's what I do. It's a one-time process when I first unbox new phones and hardly takes more than a moment or 2.

BTW, my Snom phones are coming with some old v7 firmware by default, and I am using static DHCP to map 'fixed' IP addresses to the phones.

But I found if I map a static DHCP address to the phone BEFORE upgrading firmware to the current version, the phone boots and immediately gives terrible feedback noises over the speaker. The interface is unreachable on the phone or via the web

If I delete the static DHCP mapping, and hard re-boot the phone, the phone picks up a normal IP Address on reboot and it's fine. This problem goes away once the firmware has been updated.

I do not think this is anything to do with Operator (I get this behavior before provisioning) but thought I'd share.

Cheers,

ft.
Previous Topic: Call Routing
Next Topic: Kerio Operator 2.0 RC 1 error
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sun Nov 19 06:16:30 CET 2017

Total time taken to generate the page: 0.00553 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.