Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Queue directory on mailserver
  •  
zebby

Messages: 240
Karma: 2
Send a private message to this user
On the mail server in the Mailserver\Store\Queue directory there are 45 folders (various names 01, 20, 0C, 2B, 34 etc.) all containing a handful of emf files (around 400 in total), all of which can be opened up in Notepad and appear to be emails dating back to December 2011. Oddly seemingly all in the period 15th to the 22nd.

Incidentally, some of these directories also contain eml and env files for messages that are currently stuck in the queue (messages with bad domains waiting to get bounced back to the sender) I can see they have a reason to be there but other mesages from 8 months ago?

It doesn't look as if it's causing any noticable trouble but it just doesn't seem right! Anyone else seen this?

  •  
etieseler

Messages: 132
Karma: 10
Send a private message to this user
Not seeing this on my system. Perhaps something happened that didn't allow those emails to be delivered, if your logs go back that far, you could examine them, particularly the 'Mail' log. That might clue you into what happened.
  •  
zebby

Messages: 240
Karma: 2
Send a private message to this user
Do you have the folders?
  •  
etieseler

Messages: 132
Karma: 10
Send a private message to this user
Yes I do. They are hexadecimal numbered folders and seem to just be for organizational purposes to keep some structure of the Queue folder so its not potentially many thousands of eml, emv, emf files scattered in one directory. Interestingly, I just went back to check them, and earlier today I had a few hundred files in the queue because the quota of one user was hit, but this was resolved, so now the emails have been delivered, so the files are no longer there, but the folders have remained.

I'm not sure how they were labeled, but I'm sure it is some mathematical function that comes up with the number to name the folder, maybe based on the message ID or queue ID or something.

-Ed
  •  
Charles B

Messages: 77
Karma: 3
Send a private message to this user
I have the folders too, but in my case they're all empty except for a couple that have messages currently in queue. Looks like you have some orphaned emails.

Mid 2015: Quit Kerio and moved to Exchange 2013 and Meraki.
Kerio Control 8.4.0--Used since it was WinRoute, many years ago
Kerio Connect 8.4.0 on Ubuntu. Bought Connect just in time for the switch to NO SUPPORT(aka pay for support). Not. Happy.
  •  
zebby

Messages: 240
Karma: 2
Send a private message to this user
I guess something must have gone a tad wrong over those few days last December. Moving the orphaned files out doesn't seem to have had any adverse effect so I think I'll call this a 'blip'
Previous Topic: Users email working but account stats show zero messages
Next Topic: Sender-Host-Name (in mail log)
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Thu Oct 19 07:28:44 CEST 2017

Total time taken to generate the page: 0.00419 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.