Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Webmail slow and single connection (slow webmail performance)
  •  
kgpj

Messages: 17
Karma: 0
Send a private message to this user
We have an issue with webmail where when a user downloads an attachment, it only downloads 50KB/s. Also when downloading, we cannot view any other emails until it completed the download.

This also happens when we performs any sorting of the files from in the webmail.

Our line is 20Mbps Up and down from our ISP provider. Anyone else having this throttling issue with webmail?

I'll be performing some disk defrag during low peak times in the evening and see if there's any performance increase with the download.

Server Spec
Intel Xeon e5410
4GB RAM
Win 2008 r2 sp1 64 bit
Raid 10 6xhdd 7500 RPM

UPDATE:
change the download speed from 200KB/s to 50KB/s

[Updated on: Fri, 24 August 2012 23:37]

  •  
tonyswu

Messages: 271
Karma: 5
Send a private message to this user
See if there is anything in the debug or error log. We have at least 50 webmail users on average, and no throttling issue like this at all.
  •  
kgpj

Messages: 17
Karma: 0
Send a private message to this user
I only see FolderIndexTraitsImpl.cpp, AsyncRequest.cpp, and SpamClient.cpp in the error logs and some php_utils.cpp session expired errors.

As for debug logs, in the past week, I only see the incremental backups being completed.

Could this be a disk error issue or a firewall issue? I'll do some testing and see if in my local LAN, I experience this weird throttling.
  •  
tonyswu

Messages: 271
Karma: 5
Send a private message to this user
Trying from LAN would be a good test.
  •  
kgpj

Messages: 17
Karma: 0
Send a private message to this user
Alright, I've tested both LAN and WAN connection with a 10MB attachment. In the LAN environment, the download was almost instantaneous.

In the WAN environment, my average download speed was 50KB/s and while downloading, I cannot view other emails especially with attachments.

The server it self doesn't have a firewall and I'm connecting webmail via HTTPS. Any other reasons why it's throttling in WAN connection not in LAN?
  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
What is the latency of the line? Ie. ping to the server?
  •  
tonyswu

Messages: 271
Karma: 5
Send a private message to this user
Quote:
What is your external bandwidth?


My apologies, you already mentioned that in your original post. Please also confirm whether your internet connection is synchronous or asynchronous.

[Updated on: Sat, 25 August 2012 16:20]

  •  
kgpj

Messages: 17
Karma: 0
Send a private message to this user
The connections is synchronous and my latency when I ping it at home was avg 30ms.
Previous Topic: Windows 8 ActiveSync support
Next Topic: SpamAssassin FROM_12LTRDOM filter
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Tue Aug 22 20:36:31 CEST 2017

Total time taken to generate the page: 0.00417 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.