Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Operator » SIP Register/SIP Invite fails.
  •  
afink

Messages: 10
Karma: -1
Send a private message to this user
I've set up Kerio 2.0.2 on a brand new server.
I have created two users and one extension mapped to each of those users.
I've set up two SIP phones (Aastra 6739i and BRIA on iPhone) and try to place a call between the phones.

What happens is simple. Both phone show an error.


Bria says "Registration Error: Forbidden (403) Reason: Forbidden (Bad auth)"
the Aastra phone simply says "No Service".

The Bria is behind NAT (WLAN). the Aastra is on public IP. The server is on public IP as well. So there's nothing which should get into the way whatsoever. This ist he most simple thing which is supposed to work and I can not figure out why the authentication is considered rejected.

A trace shows the SIP packets arrive correctly on the server and the server rejects them.

Any clues where to search for?
  •  
Jakub Viták (Kerio)

Messages: 37
Karma: 3
Send a private message to this user
Hi Andreas.

Have you configured NAT properly?
See http://kb.kerio.com/article/configuring-nat-821.html

Sincerely, Jakub Viták
  •  
afink

Messages: 10
Karma: -1
Send a private message to this user
As I said in my post before: there is no NAT on the Aastra phone.
On the other, there's a WLAN access point which can not be configured in any way but it does do things like UPNP and usually works well for SIP. At least with other SIP services it never gave problems.

And the trace clearly shows that this is not a NAT problem as the packets arrive correctly and contain the proper public IP's in them.

[Updated on: Fri, 21 September 2012 15:30]

  •  
Vladimir Toncar (Kerio)

Messages: 1696
Karma: 39
Send a private message to this user
afink wrote on Fri, 21 September 2012 15:06


The Bria is behind NAT (WLAN).



No NAT?
  •  
afink

Messages: 10
Karma: -1
Send a private message to this user
no NAT: the Aastra is on public IP
  •  
Vladimir Toncar (Kerio)

Messages: 1696
Karma: 39
Send a private message to this user
Did you set the credentials in Aastra an Bria correctly? Please see http://kb.kerio.com/article/aastra-6757i-phone-638.html

  •  
afink

Messages: 10
Karma: -1
Send a private message to this user
the URL is for another type of phone. but what I have in mine is like this:

Proxy Server: the ip of the Kerio Operator
Proxy Port 5060
Registrar server: the ip of the Kerio operator
Registrar port : 5060
Username: 777
Display Name: 777
Scree Name: <can not be set somehow>
Auth Name: 777
Password: 777
RTP Port Base: 3000


In Kerio Operator I have username 777, full name 777, password 777, extension 777



  •  
afink

Messages: 10
Karma: -1
Send a private message to this user
and the Bria running on iPhone is the same except all 777 is a 778 there. And I disabled NAT on the access point so the phone gets a public IP as well. Same problem
  •  
afink

Messages: 10
Karma: -1
Send a private message to this user
Solution: delete extension , recreate extension WITH THE EXACT SAME SETTINGS. WTF...
  •  
Vladimir Toncar (Kerio)

Messages: 1696
Karma: 39
Send a private message to this user
It could have been the security. If you had too many failed authentication attempts, maybe the IP address was blocked by Operator. Maybe you overlooked the notification in the administration GUI.
  •  
ICT and Me

Messages: 936

Karma: 53
Send a private message to this user
And have you enable "behind NAT" at the extensions?
But a Aastra must have a option to use NAT Keep Alive.
The softphone has also that option. But it isn't enable standard.

ICT and Me
Carlo Turk
The Netherlands
www.ictandme.nl
  •  
afink

Messages: 10
Karma: -1
Send a private message to this user
the problem solved itself by removing and re-adding the extension with exactly the same settings.
  •  
Vladimir Toncar (Kerio)

Messages: 1696
Karma: 39
Send a private message to this user
If you deleted the extension and created it anew, you also deleted the security counters for that extension. That's why I mentioned security above.

Vladimir
  •  
afink

Messages: 10
Karma: -1
Send a private message to this user
the security counters where not the problem. I did reset them a few times.
whaw

Messages: 9
Karma: 0
Send a private message to this user
I had the same problem.
You need to disable Encrypt communication (TLS and SRTP) in the extension.

Greets

Jef
Previous Topic: press the pound key for the directory
Next Topic: Dialing a 7 digit number
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Mon Aug 21 12:05:12 CEST 2017

Total time taken to generate the page: 0.00570 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.