Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Operator » Calls dropped after 1 hour. (Call Security/Restraints)
  •  
silars

Messages: 429
Karma: 59
Send a private message to this user
I originally had this problem with Operator when we first deployed. However, I was able to quickly identify it was an issue with Outgoing Call Restraints. Simply set the call duration to 2 hours and didn't see that problem again.

At least, that was until some of the recent upgrades. Somehow, this problem has shown back up, but I can't appear to determine the root cause.

It appears to only effect certain extensions. It also appears to only be outgoing calls, so it still appears to be an Outgoing Call Restraint issue. However, I've pretty much opened up the flood gates (deleted all restraints, and set duration to 1 day).

My only guess is that somewhere a hidden call restraint is getting applied to those extensions.

Anything else I should be looking into?
  •  
Vladimir Toncar (Kerio)

Messages: 1696
Karma: 39
Send a private message to this user
Maybe it's because of the numbers you call. Their carrier could be enforcing the limit. Some telcos have a call limit slightly above one hour (we encoutered one whose limit was 1 hour 11 minutes).

I recommend that you set at least some constraints, like the number of calls per day or the total call time per day.

[Updated on: Mon, 24 September 2012 14:55]

  •  
silars

Messages: 429
Karma: 59
Send a private message to this user
This shows up in the log for each dropped call:

"[*date* *time*] asterisk[1351]: WARNING[1420]: chan_sip.c:25967 in proc_session_timer: Session-Timer expired - xxxxxxxxxxxxxxxxxx<_at_>xxx.xxx.xxx.xxx"

I don't have packet captures, but my assumption was this Session-Timer is being applied internally. I'll dig into some packet captures. Is this how Operator reports call constraints being applied?



  •  
silars

Messages: 429
Karma: 59
Send a private message to this user
After calling my SIP provider, they said they have a 5 hour timer by default. Customers have to ask to go beyond that.

They are unaware of a 1 hour timer.

Of course, I could call back in and get a different answer.
  •  
ICT and Me

Messages: 940

Karma: 53
Send a private message to this user
Silars, I must be the call limiter of Operator. I think it's standard enabled and one hour only after update.
Look at Configuration -> Advanced Options -> [TAB] Security.
I had this also one time. Put it standaard on higher time but after update it was back to one hour.

[Updated on: Tue, 25 September 2012 09:14]


ICT and Me
Carlo Turk
The Netherlands
www.ictandme.nl
  •  
Vladimir Toncar (Kerio)

Messages: 1696
Karma: 39
Send a private message to this user
@Silars,

This could be the SIP session timer (RFC 4028). Check the SIP conversation at the beginning of the call using packet sniffer. I guess you will find that the SIP provider's proxy sets the session timer to 3600 seconds. If they do that, they should refresh the timer before it expires which they probably don't do.

Vladimir
  •  
silars

Messages: 429
Karma: 59
Send a private message to this user
ICT and Me wrote on Tue, 25 September 2012 03:11
Silars, I must be the call limiter of Operator. I think it's standard enabled and one hour only after update.
Look at Configuration -> Advanced Options -> [TAB] Security.
I had this also one time. Put it standaard on higher time but after update it was back to one hour.



It is a default of one hour. This was one of my initial problems. However, I have it set to 1 day now. I also deleted all call constraints, as a test.
  •  
silars

Messages: 429
Karma: 59
Send a private message to this user
Vladimir Toncar (Kerio) wrote on Tue, 25 September 2012 03:49
@Silars,

This could be the SIP session timer (RFC 4028). Check the SIP conversation at the beginning of the call using packet sniffer. I guess you will find that the SIP provider's proxy sets the session timer to 3600 seconds. If they do that, they should refresh the timer before it expires which they probably don't do.

Vladimir


I did try to check this yesterday. I didn't see any timers being set. In a Wireshark display, do you happen to know which packet and where in the packet this would be set?

I'll take a harder look today. Troubleshooting a few problems here.

Thanks for the responses, everyone.
  •  
silars

Messages: 429
Karma: 59
Send a private message to this user
Ok, found it. It is the Session-Expires field in the "Status: 200 OK" packet from the provider. For those who also need to look, it is "SIP" -> "Message Header" -> "Contact" -> "Session-Expires" using Wireshark.

Guess I get to call my provider again Smile.
  •  
silars

Messages: 429
Karma: 59
Send a private message to this user
@Vladimir

This is pretty much as you described. They are setting the Session-Expires to 3600 and the refresher to "uas". However, they are expecting the IP PBX to ignore Session Timers. For Asterisk implementations, that is the "session-timers=refuse" command.

My understanding is that I could attempt to manually configure this, but your configuration management would overwrite that on reboot. Or, will this just not work properly until you've enabled the ability to configure the session-timer field?
  •  
Vladimir Toncar (Kerio)

Messages: 1696
Karma: 39
Send a private message to this user
Hi,

You are right the configuration files are overwritten quite often. However, we've added something we call "configuration hooks" in version 2.0. It's a shell script that is invoked after each configuration change. It should be possible to insert session-timers=refuse into the right place in the file.

If you are interested, contact me directly at vtoncar at kerio dot com and someone from my team will prepare that script for you.

Vladimir
  •  
Filip Jenicek (Kerio)

Messages: 1094
Karma: 80
Send a private message to this user
silars wrote on Thu, 27 September 2012 00:00
However, they are expecting the IP PBX to ignore Session Timers. For Asterisk implementations, that is the "session-timers=refuse" command.


Wouldn't a better solution be querying your provider to fix the session timers on their end? I believe Operator (asterisk) behaves according to the RFC 4028.

Best
Filip
  •  
silars

Messages: 429
Karma: 59
Send a private message to this user
Yes, that would be a better solution.

I have queried them about changing it, but they weren't terribly receptive to the idea. I also ran out of energy fighting them on the issue. And, to be honest, I have better things to do, if this fixes my issue (testing it now).

As long as they have this band-aid from Asterisk, I don't see them changing their configuration. Eventually, this will bite them in the ass, and they'll fix it.
  •  
silars

Messages: 429
Karma: 59
Send a private message to this user
Quick update for those who care or are monitoring:

The script appears to have solved the problem. Currently, applying a joint script that fixes the session-timers and voicemail settings (another thread).

Appreciate everyone's efforts to solve this.
Previous Topic: Maximum length of voicemail
Next Topic: Caller ID for outgoing calls
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sun Oct 22 06:44:42 CEST 2017

Total time taken to generate the page: 0.00471 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.