Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Issue with an Alias
  •  
Aeonium

Messages: 17
Karma: 0
Send a private message to this user
Hi all,

So I am having a bit of an issue with using an alias and I can't see where I have gone wrong...

The idea is simple, anything that goes to banana@domain.com should be forwarded to external<_at_>gmail.com.

Now, when I send an email from an address internal to our domain it will make it to the end point and the external gmail account will receive the email as expected, however if I send an email from an email address external to our system I get the output below... which leads me to believe it was sent but it never arrives.

So can anyone see where I have gone wrong on this?

Debug output (SMTP client, Queue processing, Alias expansion, Sieve filters):

[24/Oct/2012 11:09:39][3002839040] {qproc} Queue injection started, id=5087be63-000003fc
[24/Oct/2012 11:09:39][3002839040] {qproc} Queue injection finished, id=5087be63-000003fc
[24/Oct/2012 11:09:41][2980474880] {alias} Alias processing begin, recipient=banana<_at_>domain.com
[24/Oct/2012 11:09:41][2980474880] {alias} Searching for match to banana<_at_>domain.com at level 0
[24/Oct/2012 11:09:41][2980474880] {alias} Found matching alias at level 0: banana@domain.com -> external<_at_>gmail.com
[24/Oct/2012 11:09:41][2980474880] {alias} Searching for match to external<_at_>gmail.com at level 0
[24/Oct/2012 11:09:41][2980474880] {alias} Address banana@domain.com expanded to remote address external<_at_>gmail.com
[24/Oct/2012 11:09:41][2980474880] {alias} Alias expansion finished in 0.00 s
[24/Oct/2012 11:09:41][2980474880] {qproc} Queue ID 5087be63-000003fc: Footer inserting is disabled because sender domain gmail.com cannot be found.
[24/Oct/2012 11:09:41][2980474880] {qproc} Queue ID 5087be63-000003fc: Message is going to be rewritten.
[24/Oct/2012 11:09:41][2980474880] {qproc} Queue ID 5087be63-000003fc: Inserting footer is disabled.
[24/Oct/2012 11:09:41][2980474880] {qproc} Queue ID 5087be63-000003fc: Failed to encode X-Footer header for domain .
[24/Oct/2012 11:09:41][2980474880] {qproc} Queue ID 5087be63-000003fc: Rewriting finished.
[24/Oct/2012 11:09:41][2980474880] {smtpc} Connecting to relay server pinkdylan7.net (89.200.138.142:25)...
[24/Oct/2012 11:09:41][2980474880] {smtpc} Connected to relay server pinkdylan7.net
[24/Oct/2012 11:09:41][2980474880] {smtpc} Received greeting: 220-hurricane.pinkdylan.co.uk ESMTP Exim 4.80 #2 Wed, 24 Oct 2012 11:09:41 +0100
[24/Oct/2012 11:09:41][2980474880] 220-We do not authorize the use of this system to transport unsolicited,
[24/Oct/2012 11:09:41][2980474880] 220 and/or bulk e-mail.
[24/Oct/2012 11:09:41][2980474880] {smtpc} Sending EHLO
[24/Oct/2012 11:09:41][2980474880] {smtpc} Switching connection to TLS
[24/Oct/2012 11:09:41][2980474880] {smtpc} Sending EHLO
[24/Oct/2012 11:09:41][2980474880] {smtpc} Starting AUTH LOGIN authentication
[24/Oct/2012 11:09:41][2980474880] {smtpc} Successfully authenticated to SMTP server pinkdylan7.net
[24/Oct/2012 11:09:41][2980474880] {smtpc} Sent MAIL command
[24/Oct/2012 11:09:42][2980474880] {smtpc} Got reply: 250 OK
[24/Oct/2012 11:09:42][2980474880] {smtpc} Sent RCPT TO: <external<_at_>gmail.com>
[24/Oct/2012 11:09:42][2980474880] {smtpc} Got reply: 250 Accepted
[24/Oct/2012 11:09:42][2980474880] {smtpc} Sent DATA command
[24/Oct/2012 11:09:42][2980474880] {smtpc} Got reply: 354 Enter message, ending with "." on a line by itself
[24/Oct/2012 11:09:42][2980474880] {smtpc} Sending message body...
[24/Oct/2012 11:09:42][2980474880] {smtpc} Data sent, got reply: 250 OK id=1RQxuB-0000RM-1C
[24/Oct/2012 11:09:42][2980474880] {qproc} SEND_RELAY: Result for recipient external<_at_>gmail.com: relayed, Status: 2.0.0
[24/Oct/2012 11:09:42][2980474880] {smtpc} QUIT sent, got reply: 221 hurricane.pinkdylan.co.uk closing connection
  •  
freakinvibe

Messages: 1540
Karma: 62
Send a private message to this user
From the log, it looks like the message was sent to GMail, but it could be that GMail classifies it as Spam. Have you checked the Spam folder in GMail?

Problem might be that the external domain you are sending the mail from does not permit your server (or your relay hurricane.pinkdylan.co.uk) as sender.

Dexion AG - The Blackberry Specialists in Switzerland
https://dexionag.ch
  •  
Gregg Hatchell

Messages: 14
Karma: 3
Send a private message to this user
Hi,

You can also take the Queue ID '5087be63-000003fc' and search for this in the mail log, you should see an SMTP delivery code.
If this is 2.0.0 the message was delivered correctly, or passed to the relay server correctly.
If it is 2.1.0, then the message was delivered to the mailbox, but a filter or rule moved the email out of the Inbox to another folder.

  •  
Petr Dobry (Kerio)

Messages: 782
Karma: 61
Send a private message to this user
Aeonium wrote on Wed, 24 October 2012 12:17
[24/Oct/2012 11:09:42][2980474880] {qproc} SEND_RELAY: Result for recipient external<_at_>gmail.com: relayed, Status: 2.0.0


DSN is 2.0.0 which means it was successfully delivered to Gmail. Probably in spam folder.

Petr Dobry
Product Development Manager | Kerio
  •  
Aeonium

Messages: 17
Karma: 0
Send a private message to this user
Thanks for the replies,

As I mentioned in the original post, an email sent from an internal address, say user<_at_>domain.com it will arrive at the gmail account as expected.

Its only when an email is sent from an address that is not part of our domain that the email gets lost in transit.


So once more:

Internal - User<_at_>domain.com -> Alias -> Gmail = Success
External - User<_at_>external.com -> Alias -> Gmail = Failure
  •  
freakinvibe

Messages: 1540
Karma: 62
Send a private message to this user
Again:

From the log, it looks like the message was sent to GMail, but it could be that GMail classifies it as Spam. Have you checked the Spam folder in GMail?

Problem might be that the external domain you are sending the mail from does not permit your server (or your relay hurricane.pinkdylan.co.uk) as sender.

Dexion AG - The Blackberry Specialists in Switzerland
https://dexionag.ch
  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
Aeonium wrote on Thu, 25 October 2012 13:11
Thanks for the replies,

As I mentioned in the original post, an email sent from an internal address, say user<_at_>domain.com it will arrive at the gmail account as expected.

Its only when an email is sent from an address that is not part of our domain that the email gets lost in transit.


So once more:

Internal - User<_at_>domain.com -> Alias -> Gmail = Success
External - User<_at_>external.com -> Alias -> Gmail = Failure


That is probably because your server (or the SMTP relay you use) is not allowed to send emails from domain external.com. If you use any other server than the one who host the domain then other servers may consider the email as forged. If you want to send email with address <_at_>gmail.com, you must use Gmail servers for this. This is valid for most of email domains.
Previous Topic: Changing public folders location
Next Topic: Read mails via JSON from Folder
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Tue Oct 17 16:56:10 CEST 2017

Total time taken to generate the page: 0.00439 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.