Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » KOC setup "The requested operation failed" (KOC Setup, error kerio connect, outlook connector, the requested operation failed)
  •  
gregorys

Messages: 2
Karma: 0
Send a private message to this user
I've got an older KC system and the client KOC got munged.

I didn't hear about it for months, but went in to fix it last week.

However, I run into this problem on two stations and it's impossible to correct.

You can reproduce the problem by:
Install the KOC.
Go to configure the KOC.
Put in user credentials and then before saving them, press the Cancel button.
Exit the KOC setup.

Now try to get back in and setup the KOC user correctly.
Trying to configure the KOC now produces a "The requested operation failed" - and nothing will resolve it.

Uninstalling the KOC and re-installing won't resolve it either.

I'd guess there's some registry keys somewhere that can be deleted and KOC will think it's a new setup. But I'm not sure.

Clearly it's a bug in KOC, since if there's no account setup, the KOC should not bomb - but it must assume that if any KOC config was started, then there MUST be user credentials etc, and if there aren't it croaks.

So, how to clear the KOC setup so we can start over.

-Greg
  •  
Ernesto (Kerio)

Messages: 90
Karma: 7
Send a private message to this user
I would recommend to do a manual cleanup and re-install of KOC.

1. Using the Mail application in Control Panel remove all profiles and accounts, then use Add/Remove Programs to uninstall KOC.

2. Remove the KOC folders under PROGRAM_FILES\Kerio and under C:\Documents and Settings\<user>\Local settings\Application Data\Kerio\Outlook Connector\

3. Open MS Outlook but don't create a profile yet. Close it right after.

4. Re-install the correct version of KOC to match your Kerio Connect server and configure a new profile and account making sure to complete all the steps without cancelling this time.

Let us know if the problem persist after the above.

Sales Engineer | Kerio
Stay Connected Anytime, Anywhere. Discover Kerio Cloud!
  •  
gregorys

Messages: 2
Karma: 0
Send a private message to this user
That is a horrific set of steps to contemplate with a user who already has a lot of mail and a huge PST.

I suspect a registry entry that removes the configuration of the KOC would be a 30 second fix.

Then one could simply go back in and reconfigure the KOC with the server/user credentials etc.

It's astounding to me that there are numerous threads here with the exact same problem and there's not one reasonable response to their needs. [And the above isn't a reasonable response either, IMO.]

The problem is clearly a bug in the KOC product. [I've reproduced it on two machines - somewhat accidentally, but it's not a faulty profile or anything else.]

So, can someone point me at the relevant sections of the registry please? I'll simply start ripping stuff out until I get some results. It can't be any worse than it is now.

-Greg
Previous Topic: What happen if a backup can not written?
Next Topic: Unable to synchronize
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Mon Aug 21 23:40:03 CEST 2017

Total time taken to generate the page: 0.00420 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.