Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Operator » Office network with Operator, Home network with phone (How to configure)
  •  
Mars

Messages: 16
Karma: 0
Send a private message to this user
In our Office network we use a Kerio Operator Box
In our Home network we want to connect SPA509G to Kerio Operator Box in Office network.

Phones in Office network are working properly

I added Home SPA509G in Office network, changed IP adress of SPA509G to public IP address of Office network and connected phone to Home network.

Unfortunately, the phone does not connect in Home network.

Please explain to me what settings (port forwards) have to be changed in router and/or Operator box to let Phone ring in Home network.
  •  
Vladimir Toncar (Kerio)

Messages: 1696
Karma: 39
Send a private message to this user
  •  
Mars

Messages: 16
Karma: 0
Send a private message to this user
Hi Vladimir,

I checked this article.

For Office network, it's clear for me what to do.

What is not clear to me is which ports in router of Home network have to be openened to get connected.

Is that only port UDP/TCP 5050 and TCP 5061 and RTP ports 10000-19999?

By the way... my Vigor 2710N router has no RTP ports, so I opened TCP/UDP ports 10000-19999. Is that correct?

Kind regards,
Mars
  •  
Mars

Messages: 16
Karma: 0
Send a private message to this user
Hi,

I have a setup like described

[Office]<---NAT N:1--->[Internet]<------------->[Mobile public]
<---NAT 1:N--->[Mobile]
<---NAT 1:N--->[Home]

Operator in Office network (behind NAT)

I have a problem with my [HOME] phones

With the HOME phones I can call public phone numbers and local phone numbers (in OFFICE network) but I can not make phonecalls between HOME network phones. When getting connected from HOME phone to OFFICE phone, I can hear OFFICE, but OFFICE can not hear HOME phone (as if call is muted).

Dialing from OFFICE to HOME phone is not possible (immediately get voicemail).

Settings:
Firewall OFFICE
TCP/UDP 5060
TCP 5061
UDP 10000-20000

HOME phones are NAT enabled (behind NAT)

Kerio Operator Box 3210 (2.1.0 beta 2 build 1081)

Any idea what I am doing wrong? Are there settings necessary in HOME router?
  •  
Filip Jenicek (Kerio)

Messages: 1094
Karma: 80
Send a private message to this user
Hi,

I have two ideas what might be wrong.

Since you have three private networks (OFFICE,MOBILE,HOME), my question is, are they all in different subnets? If not, than you're probably troubled. If they are in different subnets, have you excluded them from the Local IP Addresses in Kerio Operator? See the "Local IP Addresses" field on the Network screen in Kerio Operator. The configured IP Address group should contain only a subnet where Operator is in, probably the OFFICE.

Secondly, you said that you can not dial from OFFICE to HOME and that the target phone doesn't even ring. It seams like the HOME phone is not registered. Can you check, that it is? Look for an IP address on the Extensions screen.

Your firewall settings seem correct, unless you changed the RTP port range. Again, check it at the Network screen. Basically, it should be sufficient to forward a smaller number of ports, e.g. 100. You need at most four ports per a call, so a range of 10000-20000 gives you more than 2500 simultaneous calls.

Best
Filip
  •  
Mars

Messages: 16
Karma: 0
Send a private message to this user
Hi Filip,

Thank you for your help.

Operator is in office network behind NAT

For Office network I use 192.168.1.XXX IP addresses and subnet 255.255.255.0
For Home networl I use 192.168.2.XXX IP addresses and subnet 255.255.255.0

So because subnet is the same, it could be the reason for problems?

Office and Home phones are all registered and show IP adresses in Extensions TAB

Can you show me a screendump of correct IP addresses Groups screen?

My local client group only shows IP addresses of Office network (192.168.1.1 - 192.168.1.255)

I will change home network subnetmask and check things out.

Kind regards,
Marcel
  •  
Filip Jenicek (Kerio)

Messages: 1094
Karma: 80
Send a private message to this user
Hi,

it looks perfectly fine, please do not change anything. A subnet is made from a network address and a network mask. In your case 192.168.1.0/255.255.255.0 and 192.168.2.0/255.255.255.0.

Please update your ip address group "Local clients" to be of type "Network/Mask" with "192.168.1.0" as IP Address and "255.255.255.0" as mask.

After that, if it still doesn't work, please create a packet dump (Network->Packet sniffer) with a failed call and email it together with a support info file (System Health->Support info) to fjenicek<_at_>kerio.com.

Best
Filip
  •  
germanr

Messages: 293

Karma: 7
Send a private message to this user
Are you running on a fixed public ip on the office? If the ip changes you won´t hear nothing when the ip changes to something different of what Operator has on the settings. If your are running on a fixed ip check that operator is properly configured (in Network settings) and that on the firewall the communication is done over that IP.

Best regards

German Ruiz
Home & Office
Kerio Prefered Partner
Uruguay
Previous Topic: Kerio Operator 2.1.0 Release Candidate 1
Next Topic: No incoming
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sat Oct 21 06:43:09 CEST 2017

Total time taken to generate the page: 0.00478 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.