Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Operator » Incoming Calls are Muted (When an outbound incoming call rings, I cant hear them, but they can hear me.)
  •  
migsutu

Messages: 74
Karma: 0
Send a private message to this user
I am running the 2.1 RC1. I have just started getting back to work on getting our Operator system up to 100%. Paging is GREAT btw!

The only issue I am having is when someone calls the office, it rings however I can't hear anything from them. They can hear me just fine. I can dial out, conversations work great both ways. Extension to Extension calls work great. Only issue is the inbound calls. The extension rings, and Caller ID works perfectly. I have tried capturing packets, trying to compare an outbound call vs an inbound call, however nothing jumps out at me. I am using SNOM 870 phones running 8.4.35.

I can include packet details if that will help. Not sure if I am not forwarding a port on the my router(server and phones all behind the same router), or if it is a setting in Operator or even the Snom phones. I am open to any thoughts/ideas.

Thanks a bunch.
  •  
Filip Jenicek (Kerio)

Messages: 1094
Karma: 80
Send a private message to this user
Hi,

I suppose your Operator is behind a router doing nat. Can you double check that
a) you checked "Nat enabled" on the network screen
b) the public IP is correct
c) the local ip address group contains the correct local addresses

If the above doesn't help, please email a packet dump and a support info file (click Support Info on the System Health screen) to fjenicek<at>kerio.com

Best
Filip
  •  
migsutu

Messages: 74
Karma: 0
Send a private message to this user
In answer to your questions:

a) Yes "Nat enabled" is checked on the network screen.
b) the public ip is correct.
c) yes the range of ip address contains the ip of the snom phones. (To further experiment with this, I have entered in the specific ip address of the phone which rings when we receive an outbound call. No difference.)

I will collect a brief packet dump during one of the calls where the incoming caller is muted and get the support info file. Thank you for your help Filip.
  •  
migsutu

Messages: 74
Karma: 0
Send a private message to this user
Some more investigation on my end.

a) I have put a Polycom IP650 with the rest of my network, to check and make sure it wasn't something specific to Snom. I am having the same issue with Polycom.

b) Watching the Status/Calls, I can see any internal calls use the G722 code. Outbound calls show G722/G711u. Inbound calls(where the problems are) only show G711u.

  •  
Filip Jenicek (Kerio)

Messages: 1094
Karma: 80
Send a private message to this user
I've replied via email.
  •  
migsutu

Messages: 74
Karma: 0
Send a private message to this user
Solution found! Razz

Going with the idea that the firewall was blocking ports. I tested this scenario by putting Operator on 1to1 NAT in my firewall, passing all ports to Operator. Inbound calls started working fine when this was done. However since I still wanted the firewall to block most ports to Operator, I had to dig deeper.

I started looking at packet dumps from my router(pfsense) and Operator when it was working and not working. The thing that I noticed was it was redirecting ports inside the NAT. So doing some more google searching led me to this pfsense doc.

"1. Disable source port rewriting - by default, pfSense rewrites the source port on all outbound traffic. This is necessary for proper NAT in some circumstances such as having multiple SIP phones behind a single public IP registering to a single external PBX. With a minority of providers, rewriting the source port of RTP can cause one way audio. In that case, you want to use manual outbound NAT and Static Port on all UDP traffic potentially with the exclusion of UDP 5060."

Granted Operator and all my phones are on the same subnet behind the same router, however the symptoms matched perfectly.

Forcing static ports for the RTP traffic allowed everything to work normally, and this apparently had been the case all along.

I don't know if this info pertains just to pfsense based routers or if other routers/software can have similar behavior. Regardless I hope this information can help someone avoid a headache.
  •  
vkazantsev

Messages: 5

Karma: 1
Send a private message to this user
Hi! Maybe offtop message.
The described problem may appear, when codecs between kerio operator and phones, or kerio operator and sip provider are different. I had a similar problem - when I changed codecs - everything work fine.
Previous Topic: Certain outbound numbers don't connect
Next Topic: G.729 and auto attendant music
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Tue Oct 17 22:16:09 CEST 2017

Total time taken to generate the page: 0.00497 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.