Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Operator » [SOLVED] Losing Registration
  •  
88fingerslukee

Messages: 177
Karma: 0
Send a private message to this user
With this new provider I have added, incoming calls are failing. It seems to have to do with the interface losing its registration. If I open up the interface setup dialog and then close it again, incoming calls work. If I make an outgoing call and then make an incoming call, it works. If I let it sit for a couple of minutes and then try and incoming call, it fails.

Why would this happen and how can I fix it?

[Updated on: Thu, 21 March 2013 02:41]

  •  
88fingerslukee

Messages: 177
Karma: 0
Send a private message to this user
I have tried every setting on both the provider site as well as on the PBX without any success. I have tried setting the Registration Timeout setting on the Provider to 3200 seconds(!!!!). This is almost on hour. I still lose registration. It seems to be random how long it takes. Sometimes it's a couple of minutes sometimes it's 10, but it doesn't go much longer than that.

What can be causing this?

UPDATE: I adjusted my firewall to less aggressively kill connections. This helped as the server stayed connected for about 25 minutes. It then lost connection and registration. I have KO 2.1.0 hooked up to two separate providers and I haven't had these problems with the other provider.

UPDATE 2: I think I fixed it. I noticed that my other provider has a registration timeout of 120s. The default timeout for the other provider was 500s. I had tried to adjust it up but never DOWN. I changed it to 120 just like the other, working provider and it seems to be re-registering properly. It appears that my firewall (pfSense 2.0.2) kills UDP connections pretty viciously and that was knocking out the connection before it had time to re-register.

We have been having some non-connecting call issues with our other provider and I'm wondering if the 120s is still not enough to keep the connection alive. At least with this new provider we are able to adjust that.

You'd think I'd learn to stop using the Kerio Forums as a blog for my troubleshooting. Rolling Eyes Hope somebody finds this helpful

[Updated on: Thu, 21 March 2013 02:42]

Previous Topic: [SOLVED] Simultaneous call to mobile phone
Next Topic: SOLVED! Problem call queue
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sun Aug 20 04:06:56 CEST 2017

Total time taken to generate the page: 0.00406 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.