Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Control » KC 8.0 - unstable networking under Hyper-V (Network Connection problems under Winsrv 2008 Hyper-V)
  •  
bitwalker

Messages: 9
Karma: 1
Send a private message to this user
I installed Kerio Control Hyper-V Virtual Appliance under Windows Server 2008 Hyper-V, on the same machine where my current KC 7.4 is running under a WS08 RODC virtual machine(since 3 years now). So I think HW problem is out of question.
When I tested the new KC 8.0 in my network environment, it worked just fine for about 2 minutes. First it had lost connection to my Domain Controllers (as a consequence domain users could not log on the firewall), and I could get a ping reply for another two minutes or so, then after that no echo reply, and KC 8.0 disappeared from the network.
For the time I tested the 8.0, I disconnected the current, older 7.4 from the network.
I tried to use the same virtual adapters, and others as well, but the 8.0 did the same, as written above. I reconnected the 7.4 to the network after I gave up trying with the 8.0, and the 7.4 works just fine.

And idea, what could be the problem? Or the 8.0 is not without bugs just yet?
  •  
ajamali

Messages: 100
Karma: 1
Send a private message to this user
did you solve this problem??
because I want to install Kerio Control Appliance hyper-v.

  •  
bitwalker

Messages: 9
Karma: 1
Send a private message to this user
Not yet, I wrote a ticket to the support, I'm waiting for the answer. But if you do try it, please share your experience, how it works.

cheers!
  •  
ajamali

Messages: 100
Karma: 1
Send a private message to this user
Try to disable Anti-Spoofing
  •  
bravo_prochu

Messages: 18
Karma: 0
Send a private message to this user
Does the 'disable anti-spoofing' worked ??

I have similar problem, i wrote few days ago;
'8.0.0.551 vmware appliance - unable to complete pppoe discovery'
  •  
ajamali

Messages: 100
Karma: 1
Send a private message to this user
no, it's doesn't help!!

back to windows plathform again till Kerio fix this problem
  •  
bravo_prochu

Messages: 18
Karma: 0
Send a private message to this user
I tried it too; doesnt help..
  •  
bitwalker

Messages: 9
Karma: 1
Send a private message to this user
There is a new release of KC8, I will test it, maybe it will solve the problem.
  •  
NuStiu

Messages: 20
Karma: -1
Send a private message to this user
try disabling kerio web filter.
i noticed a significant drop in network speed when activated.
  •  
moos

Messages: 6
Karma: 0
Send a private message to this user
i have kc8.0 in production under hyperv 2008r2 core on a hp dl380g8 and running smoothly.
  •  
ajamali

Messages: 100
Karma: 1
Send a private message to this user
Finally after 3 weeks this problem solved!!!!

The problem is Anti-spoofing is dropping packet which make Kerio Control network unstable

I tried to disable Anti-spoofing feature but no luck even no error in Security Log

I tried to enable Packets Dropped for Some Reason in Debug Log and I found that the default Traffic Policy Rule is dropping same packet to Kerio Control LAN Interface.

This is the problem:

My Router, Kerio Control WAN & LAN interfaces are connected from the same core switch.
this makes lot of security holes and that's why Anti-spoofing is dropping the packet.

The solution is

Solution 1:
Connect your Control WAN Interface direct to the Router

Solution 2:
Create VLAN Between Control WAN Interface and the Router

I want to share this information with you guys you properly save time now to solve this issue.

and sorry for blaming Kerio Control cause this problem from my mistake Smile
  •  
bitwalker

Messages: 9
Karma: 1
Send a private message to this user
hi, thanks for sharing the info!
I experienced the anti-spoofing in the log, too, but looks like my issue was caused because of a hyper-v malfunction and / or network card hardware malfunction. It did not occure to me, until after another VM's reset: after a system restart the networking did just the same as on the KC8.0 test machine. Now it's running on a different hyperV host for a day now and no problem.
  •  
bitwalker

Messages: 9
Karma: 1
Send a private message to this user
Finally, I got error messages in the VM host's Evet log:

"NIC driver on 'Kerio Server' cannot load because it is incompatible with the server virtualization stack. Server version 2 Client version 196610"
and:

"A storage device in 'Kerio Server' cannot load because it is incompatible with the server virtualization stack. Server version 2.0 Client version 4.2"

I'm using the latest network card driver. It looks like it will be driver problem after all. (I'm waiting for the Support's reply)
Anyone else experienced this?

  •  
UnifiedTechs-Brian

Messages: 172
Karma: 15
Send a private message to this user
Haven't done it with Connect yet, but with Operator we saw if we set the Hyper-V NIC to legacy it worked much better.

Shut down the VM, go into its Hyper-V Manager on the host server and make sure the NIC is a Legacy Network Adapter. If it is currently a Virtual Network you will want to add a device and choose Network Adapter >Legacy Network Adapter, then remove the old NIC from the VM. On reboot you may have to reconfigure the network through the Hyper-V Manager Connect first before you can access it via network.

- Brian
Kerio Preferred Partner, Reseller & Hosting Provider
Unified Technology Solutions
Farhad

Messages: 2

Karma: 0
Send a private message to this user
I have a network with 8000 user and a kerio control 8.2.1 with unlimited user . after 10 min , ethernet wan card trouble ahead
my HW is quad xeon g8
Previous Topic: Authentication problem in kerio control
Next Topic: Downloads stop a quarter or half way through....
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Wed Oct 18 07:41:16 CEST 2017

Total time taken to generate the page: 0.00564 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.