Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Apple Mail gets SMTP error if not on same network as Kerio server
  •  
terzinator

Messages: 10
Karma: 0
Send a private message to this user
If we use Apple's Mail program, we can't seem to send mail unless we're in the office (on the same network as the Kerio server). If we're away, either at home or elsewhere, mail arrives just fine, but if we try to send messages, we get an SMTP error saying that the SMTP server is offline. If we connect to our office via VPN, then messages are sent, no problem.

This only happens with Apple Mail. It doesn't happen with MS outlook or with our IOS devices. Only Apple Mail.

We always use the Kerio "integrate with mac" link to configure the settings, so not sure what might be up. This seems to be true for multiple machines who use Apple Mail.) It didn't always happen; it seems like this is new, in the past few weeks or so.

I thought it could be a firewall setting, like needing to configure a port, but why would it only affect Apple Mail? (And why would it just start happening out of the blue?)

Any ideas?
  •  
terzinator

Messages: 10
Karma: 0
Send a private message to this user
FYI... tried stopping and restarting the Kerio service, as well as restarted the server on which Kerio is installed.

No go.

(Just in case that might have been a suggestion!)
  •  
tonyswu

Messages: 271
Karma: 5
Send a private message to this user
Might want to take a look at how SMTP is configured on Apple Mail.
  •  
terzinator

Messages: 10
Karma: 0
Send a private message to this user
tonyswu wrote on Mon, 08 April 2013 19:46
Might want to take a look at how SMTP is configured on Apple Mail.
Yep, checked that. Nothing seems amiss, and the oddity is that it worked before, and now it doesn't. On separate machines/accounts. (So it's not like it got changed on one account and not the other.)

SMTP uses default ports, SSL and MD5 challenge-response. I've tried changing to several of the custom ports people have suggested for other issues (2525, for one), but that immediately changes the SMTP mailserver dropdown to show "(Offline").

If I'm out of the office and am not VPN'd in, the SMTP mailserver drop down shows "(Offline)" as well. If I VPN in, that message goes away.

Just a hunch, it seems like a firewall port issue. (But again, not sure why it affects Apple Mail and not MS Outlook.)

[Updated on: Wed, 10 April 2013 21:37]

  •  
terzinator

Messages: 10
Karma: 0
Send a private message to this user
Well, I did an experiment. I thought I might open the Kerio web interface, click the "Integration with Mac" link, and see if I could create a separate account on Apple Mail and see what the default settings are...

Immediately the password dialog came up to enter username/pw info... connecting to our mailserver:443... 443 isn't one of the default ports listed in the SMTP settings.

So I changed the SMTP settings in Apple Mail to use the custom port of 443, and then got off our network (tethering to my phone's 4G connection) and it worked. The SMTP dropdown didn't show the offline message, and I tested and was able to send a mail.

I'll test this again at home, but hopefully this fixed it.

So... not sure why it changed on separate accounts, and separate instances of Apple mail on separate machines. I'll google around and see what I can see.

[Updated on: Wed, 10 April 2013 21:49]

  •  
tonyswu

Messages: 271
Karma: 5
Send a private message to this user
I can think of three scenarios. Port forwarding is not done correctly, your Mac client is configured to use port 25 only and it's blocked by your ISP, or you use split DNS and the external DNS is not configured correctly. Check your firewall config and logs, and do a DNS lookup against your mail hostname inside and outside of your network.

Kerio listens on port 443 for it's HTTPS service. While you can force SMTP to use port 443 and it'll tell the server is up, which it is, sending email through that probably won't work.
  •  
terzinator

Messages: 10
Karma: 0
Send a private message to this user
well, you were right... no go. Not sure why it worked when I was trying it before (using my phone to tether)...

My sonicwall shows port 25 is open for mail. It doesn't show the other ports as available, though. (Doesn't even list them.)

I did a DNS lookup outside of my network (at home, not VPN'd in) and a port scan:

Port 25 - smtp - Success - 62ms
  •  
Michael Ruffin

Messages: 172
Karma: 4
Send a private message to this user
Sorry, I'll tell you know I don't know anything about Mac's, but..

Apple Mail isn't trying to POP before SMTP is it? If so, you'll need to open port 110 as well?
  •  
j.a.duke

Messages: 351
Karma: 11
Send a private message to this user
Just as an FYI, the default ports for SMTP are:

25 (which is usually used for server to server, but can be used for client to server)

465 (Secure SMTP-SSL or TLS encrypted)

587 (Submission only-client to server)

Many (most?) ISPs block port 25 traffic to systems on their networks unless you have a "business" account.

Some ISPs redirect port 25 traffic from systems on their networks to their own SMTP server (I believe Verizon still does this). Often a hotel network will do the same thing.

In Apple Mail, I always explicitly specify the port (Use Custom Ports in the Advanced tab of the SMTP server dialog), rather than having Apple Mail try to guess. Works a bit more smoothly this way.

Cheers,
Jon
Previous Topic: Had to enable LOGIN auth (with TLS), will I have security issues?
Next Topic: Introducing Kerio Connect 8.1.0 beta
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Thu Aug 24 01:10:51 CEST 2017

Total time taken to generate the page: 0.00523 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.