Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Operator » Upgrade to 2.1 crashes
  •  
aristo_eef

Messages: 9
Karma: 0
Send a private message to this user
I tried several ways to upgrade to 2.1 (coming from 2.03)
We run Kerio operator in a VM on XenServer enviroment.

Upgrade goes just fine, but hangs on reboot. Last message on console is about kernel_thread_helper. Seems it crashes in first stages of reboot.

I also tried to install a fresh server from the ISO I downloaded. Same results.

Any ideas to get this fixed (or do I stay with 2.03 for ever Wink

Regards, Eef
  •  
Vladimir Toncar (Kerio)

Messages: 1696
Karma: 39
Send a private message to this user
Hi,

We were able to install on a XenServer from the ISO image without a problem. Would you be able to provide a screenshot with the crash message?

Thanks,
Vladimir
  •  
aristo_eef

Messages: 9
Karma: 0
Send a private message to this user
No luck with this uptill now.
What vm-basic did you use to install the ISO to?
  •  
Filip Jenicek (Kerio)

Messages: 1094
Karma: 80
Send a private message to this user
Hi Eef,

Please try to deploy a new machine from the Operator OVF file. I believe this error is somehow related to the xen machine configuration and that installation from OVF will create a working configuration.

Best
Filip
  •  
ESP Projects

Messages: 115
Karma: 5
Send a private message to this user
Just to confirm. We use a physical box for Kerio Operator (custom build) and have tried to upgrade 4 different versions. It has NEVER worked, we have had to fully reinstall using the latest image. The upgrade process is poor to say the least.
  •  
pvakh

Messages: 7
Karma: 0
Send a private message to this user
For the record, I had completely flawless experience with upgrades. The only problem was at the very beginning when I got the box. It was shipped with version 1 and it was not straightforward to upgrade to 2.0. But with help from support it was done. After that all upgrades were smooth and easy.
Peter
  •  
Vladimir Toncar (Kerio)

Messages: 1696
Karma: 39
Send a private message to this user
Hi,

It is quite rare to see such a frequent issues with upgrades. Would you be willing to send your configuration backup to us? (vtoncar at kerio dot com)

Vladimir
  •  
aristo_eef

Messages: 9
Karma: 0
Send a private message to this user
My system engineer did experiments installing the latest ISO.
He tried installing full and half virtulisation on xenserver 5.2 enviroment.
Nothing succeeded. Every try gives an kernel issue. And we need to reboot.
So we still run the old version. Hoping a solution is found in not to long a time.
Regards, Eef
  •  
aristo_eef

Messages: 9
Karma: 0
Send a private message to this user
Also tried to import the vdmk. No luck : "Import failed".
You say you have it succesfully running on xenserver.
Please do an export and let me import the xva file

Who knows, that will work.

Eef
  •  
Vladimir Toncar (Kerio)

Messages: 1696
Karma: 39
Send a private message to this user
We had it running on a Xen server but the machine has been re-purposed meanwhile. You would have to wait till we install again.

If your administration GUI reports some crashes, please send them to us for analysis. Also, if you could share that configuration backup, it would be really great.

Vladimir
  •  
aristo_eef

Messages: 9
Karma: 0
Send a private message to this user
./fa/3026/0/Hello Vladimir,

What configuration backup do you want?
This is about installing fresh from ISO and/or vdmk.

And start with "install with other media".

And this is the last screen after boot, and it never gets past this point

Regards, Eef

  • Attachment: kerio2-2.png
    (Size: 35.35KB, Downloaded 411 times)
  •  
Vladimir Toncar (Kerio)

Messages: 1696
Karma: 39
Send a private message to this user
Hi again,

If this happens when installing, then we know where to start.

What is your virtual machine configuration (memory, disk size, etc.)?

Vladimir
  •  
aristo_eef

Messages: 9
Karma: 0
Send a private message to this user
Hello Vladimir,

I start with:
- 1 core 256 RAM and 20 GB harddisk
- Install other media, (we tried full and half virtualisation)

BTW: When I do upgrade from runninng Kerio server, It reboots as part of the procedure and hangs on same spot.

Eef
  •  
ICT and Me

Messages: 936

Karma: 53
Send a private message to this user
256 RAM???
That is too low. Memory should be at least 512Mb. Better is just 1024Mb.
http://www.kerio.com/operator/technical-specifications

[Updated on: Mon, 20 May 2013 13:07]


ICT and Me
Carlo Turk
The Netherlands
www.ictandme.nl
aristo_eef

Messages: 9
Karma: 0
Send a private message to this user
Now running on 2048 MB
Same results, see picture of console, I have sent before.

Regards, Eef

[Updated on: Mon, 20 May 2013 13:46]

Previous Topic: Kerio Operator 2.2.0 Beta 1
Next Topic: Implementing dynamic host for SIP
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Wed Aug 23 08:11:33 CEST 2017

Total time taken to generate the page: 0.00553 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.