Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » SPAM issue (Lost "messages learned as spam" in upgrade)
  •  
BeeOnLion

Messages: 83
Karma: 3
Send a private message to this user
Hi All

I was wondering if anyone had run into this issue when upgrading / moving Kerio.

We have just update & moved our Kerio connect over to a new server & it looks like SpamAssassin is relearning what is spam again

In Configuration -> Content Filter -> Spam Filter & the SpamAssassin Tab under Bayesian filter statistics

It indicates "Messages learned as spam:" 43 which is very low I would have expected this to have been in the 100's

To test if this is working I waited for SPAM to build up in a mailbox logged into webmail selected 23 message & marked as SPAM.
I would have expected that the Messages learned as spam would have gone up to 66 would this be correct should SpamAssassin have learned these messages?

Also if this is the case can anyone suggest a method of how to move the old "learned spam" list form the old server to the new one or do we have to start all over again?

Thanks a million
  •  
Lisa Lyons (Kerio)

Messages: 175
Karma: 8
Send a private message to this user
Hi, BeeOnLion

Sometimes this can happen if the OS is different. For example, you can't migrate the spam db from a power pc to an intel based mac.

What were the operating systems of the two servers, please?

Kerio Technical Support
Log Support Incidents here: http://www.kerio.com/support
Also, please use our KB: http://kb.kerio.com
  •  
BeeOnLion

Messages: 83
Karma: 3
Send a private message to this user
Hi Lisa

Thanks for getting back to me on this so quickly.

Old server was 10.5.8
New server 2 is 10.8.3

Is there a way to export the old database to a csv file or something simular & import onto the new server?

Its a bit of a pain having to start all over again as we are not getting multipal spam messages coming in again.
The strange thing about this is that the Custom SPAM rules I created have transfered to the new server so I would have expected the SpamAssassin db to come too..

Also would there be a reason why when I marked 23 messages as spam in webmail that the SpamAssassin count of "learned messages as spam" would not have gone up?

Just checked it there & it went from 43 to 44 not the expected 66

Thanks a million

  •  
Lisa Lyons (Kerio)

Messages: 175
Karma: 8
Send a private message to this user
Hello again!

OK, so the symptoms you describe are very unfortunate, as it indicates that the Bayes database itself is corrupt. Re-importing it is not recommended at this point given your symptoms, but you could theoretically just restore the Spam Assassin database from a backup:

http://kb.kerio.com/product/kerio-connect/server-configurati on-kerio-connect/data-recovery-in-kerio-connect-1142.html

I think, however, that your best solution is actually to delete the whole spam database and start afresh, if you can. This should fix the problems with the spam count, as well as the lack of information and may provide you with a more reliable experience moving forward.

If you wish to do that, you can find instructions here:

http://kb.kerio.com/product/kerio-connect/antispam/how-to-re set-the-spam-assassin-plugin-and-bayes-database-1200.html

Kerio Technical Support
Log Support Incidents here: http://www.kerio.com/support
Also, please use our KB: http://kb.kerio.com
  •  
BeeOnLion

Messages: 83
Karma: 3
Send a private message to this user
Hi Lisa

Thanks for getting back to me again on this. I will give it a go & hopefully this will resolve the issues.
Is there a known reason for why this would have happened & how best to prevent this from happening again?

I presume that its not a recurring issue as if it happens again I dont want to have to delete & recreate the db & the users getting flooded with SPAM while SpamAssassin is learning again

Thanks a million
  •  
Lisa Lyons (Kerio)

Messages: 175
Karma: 8
Send a private message to this user
I think you'll find that once stabilised, the system will remember everything.

It would have been caused by the migration, which is a difficult time for any spam filter, and the remedial steps above should mean it won't happen again.

Of course, Support is always here if you need any further advice.

Kerio Technical Support
Log Support Incidents here: http://www.kerio.com/support
Also, please use our KB: http://kb.kerio.com
  •  
BeeOnLion

Messages: 83
Karma: 3
Send a private message to this user
Cheers Lisa appreciate the feedback & help
  •  
Lisa Lyons (Kerio)

Messages: 175
Karma: 8
Send a private message to this user
You're always welcome!

Kerio Technical Support
Log Support Incidents here: http://www.kerio.com/support
Also, please use our KB: http://kb.kerio.com
  •  
yukiomishima

Messages: 185
Karma: -2
Send a private message to this user
howdy

i appear to be having the same issues after upgrading from 7.4.3 to 8.1

the spamassassin says that it is "learning".. and has been for the past few days

also.. i am getting the following in the log: "{spamassassin} Perl_stderr: bayes: database version 0 is different than we understand (3), aborting! at /usr/local/kerio/mailserver/plugins/spamserver/spamassassin/ site/lib/Mail/SpamAssassin/BayesStore/SQLite.pm line 155"

i have had a quick look at the instructions for fixing.. however.. inside the plugins folder i have 2 folders.. 1 is called: spamassassin.. and is empty.. the other is spamserver.. and has a number of files inside.. as well as a spamassassin folder

any help with this would be greatly appreciated

also

if you can point me to the installer that i need to download.. and.. let me know how i go a bout doing a "repair install"

huge thanks in advance

yukioMishima
  •  
yukiomishima

Messages: 185
Karma: -2
Send a private message to this user
anyone?

thanks

yukioMishima
  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
The Bayes filter and Spamassassin database is obviously corrupted. As a quick solution, remove the files in store/spamassassin directory.
  •  
yukiomishima

Messages: 185
Karma: -2
Send a private message to this user
thanks for the reply

so.. i deleted the following: kerioMailstore/spamassassin/bayes and all of the files within

it now appears to be learning.. and the count of learned messages is increasing (before it was stuck on zero)

thanks for you help in resolving this

yukioMishima

Previous Topic: Forward to a external email adress
Next Topic: iCal asks for password
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Wed Oct 18 18:32:01 CEST 2017

Total time taken to generate the page: 0.00531 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.