Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Support for kmsrecover utility (Problem restoring backup on migration)
  •  
maurice

Messages: 47
Karma: 2
Send a private message to this user
Hi,
just spent a very busy weekend migration Kerio to a new server (before the old one dies!)

Moving from 2003R2 to Windows 2008R2 across the Gb LAN I didn't expect too many problems on a 30 User system - and planned a 4 / 5 hour slot on Friday P.M.

Then the Gremlins intervened. kmsrecover failed 'error 14: could not write xx' where xx are two non displayable chars. The error log indicates that it had nearly completed restore on the Mailstore User data. Wasted an hour or so trying to sort it out before resorting to Method 2 in the KB Article copying the Mailstore manually and using kmsrecover using the -m parameter to recover the other bits and pieces. A much slower process, but largely successful - an exception being a failure to correctly recover 'access rights' on some Public Calendars we run. No big deal.

Once the process was underway, I dug a little deeper into the diagnostic data I had with this result:
- kmsrecover always failed at the same point in the same User
- This User had folders nested 4 and 5 deep

My best guess is that when attempting to rewrite the data, the pathlength of the nested data is greater than the limit supported by the OS?
If this is true, then Kerio Connect should have trapped the problem during file creation.

I'd like to follow this through to a conclusion, but how do I progress? My reseller in the UK only normally offers 90 days of support.

Maurice
  •  
Lisa Lyons (Kerio)

Messages: 175
Karma: 8
Send a private message to this user
Hi, Maurice

I think this needs to be addressed as a bug:

http://www.kerio.com/support/submit-bug-report

These reports are free, and our engineers will look at the information you provide.

Please be aware, however, that we don't offer an SLA time on response to these tickets.

Kerio Technical Support
Log Support Incidents here: http://www.kerio.com/support
Also, please use our KB: http://kb.kerio.com
  •  
maurice

Messages: 47
Karma: 2
Send a private message to this user
Thanks Lisa,

I'm less focussed on the SLA than actually helping in getting a potential bug resolved.

I still have the backup file retained, but at 1.5 Gbytes hard to xfer. The 'Error log' shows much of the detail, but is there anything else I can sensibly submit with the bug report?

Maurice
  •  
Yohann94

Messages: 49

Karma: 1
Send a private message to this user
We hade a similar bug but with a different configuration. We were migrating from Mac OS X to Windows and we also tried the kmsrecover method. But we had the same error 14 always at the same point.
In our case, the failure was coming from a strange file with a tilde (~) in the name in one of the mailbox folder (TP67A9~2). In fact there were many others on other users folder with different name but always with the ~. I don't know where those files come from.
So we finished to copy the files with SuperCopieur.

I don't know if this is the same situation here.

[Updated on: Thu, 02 May 2013 17:08]

Previous Topic: How to export mobile device info?
Next Topic: CalDAV Connectivity for iQTell
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Fri Aug 18 22:01:47 CEST 2017

Total time taken to generate the page: 0.00410 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.