Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Operator » Snom phones exhibiting strange behavior (Results do not match the dial plan.)
  •  
blswjames

Messages: 77
Karma: 0
Send a private message to this user
According to the dial plan, the 'extension' I dial should be getting the automated attendant script. Instead, it keeps ringing whichever extension is set as the "default action" in the script. Strangely enough, the call log shows the call going to the correct number. What seems to actually be happening is that an extra character is getting inserted after the end of the dialing string. The main number ends in 0 (zero), and the default action in the script is also set to run when 0 is pressed. So what appears to be happening is that the last '0' in the main number is triggering the '0' in the menu script.

However, if I use the web interface to dial the number it works correctly. (As in either the phone's built-in web interface or the one provided by Kerio Operator.) It seems to only be an issue when dialing directly from the phone itself, and all of our Snom 821 phones are now exhibiting this behavior.

The phones are all Snom 821 with Firmware version 8.7.3.19, which is the most recent version at the time of this writing. I downgraded Kerio Operator back to v2.1.1 just to see if it had anything to do with the escaped asterisk fix. Same behavior.

So at this point, I'm not sure if this is a Kerio problem, a Snom problem, or my problem. Seems like it could be all three...

[Updated on: Fri, 07 June 2013 01:04]

  •  
Filip Jenicek (Kerio)

Messages: 1094
Karma: 80
Send a private message to this user
Hi,

I've experienced the same thing, just hadn't had time to report it to snom. I think this could have been causing the strange voicemail issues discussed in the other forum threads. You can experience it even when picking up voicemails. When dialing for example 50, the last 0 is sent also as a DTMF digit and Operator picks it up as a first digit of the password. Apparently, the same thing happens with IVR.

Can I suggest you to open a topic in the snom forums?

Best
Filip

  •  
blswjames

Messages: 77
Karma: 0
Send a private message to this user
Ok, here is the link for the topic opened on Snom forums. Please add any supporting evidence that you may think is relevant, and any forum links to these other problems you believe to be related.

https://forum.snom.com/index.php?showtopic=11442

Thanks!

  •  
blswjames

Messages: 77
Karma: 0
Send a private message to this user
I opened a support request with Snom also. I sent them a copy of the settings file and performed a PCAP trace. They tested it for a bit and here is the response I got:

Quote:
I changed it to a test Auto-Attendant starting with "63" and the phone sends the last digit twice, as you indicated. However, the issue seems to be in the snom firmware. Please update your snom 821 with the BETA 8.7.4.7 found here:
http://wiki.snom.com/Firmware/V8/Beta

Simply copy the link and paste it into the "Software Update" section of the snom Web Interface.

I performed some tests and this build does not send the additional digit.

Thank you,
The Snom Support Team

So it would appear that this issue will hopefully be resolved in the forthcoming 8.7.4.x firmware, whenever that gets released. So I guess our deployment is on pause until then...

UPDATE: I installed the beta firmware and verified that it indeed does address the issue.

[Updated on: Fri, 07 June 2013 23:35]

  •  
Filip Jenicek (Kerio)

Messages: 1094
Karma: 80
Send a private message to this user
Great job! Thank you.

Previous Topic: Route of outgoing calls
Next Topic: Softphones not working
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Mon Oct 23 04:18:50 CEST 2017

Total time taken to generate the page: 0.00486 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.