Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Reading of users from Microsoft Exchange failed (Migration tool cannot read Exchange 2010 users)
  •  
asagohan992

Messages: 14
Karma: 1
Send a private message to this user
I am trying to test Kerio to see if it would be a suitable replacement for our Exchange 2010 server. When running the Exchange Migration Tool, it gives me the error message: "Reading of users from Microsoft Exchange failed"


Looking at the Migration logs I see the following in debug.log:

[4676] In engine\MapiHelper.cpp:53 (MapiSessionHolder::mapiInitialize)
MAPI system initialized
[4676] In engine\MapiHelper.cpp:161 (MapiHelper::createProfile)
Profile created: {F36D7B5D-E6C7-4AB9-B1D7-5513FB11D71D}
[4676] In engine\MapiHelper.cpp:190 (MapiHelper::createProfile)
Profile was configured.
[7660] In engine\MeAPI.cpp:214 (kemt::testKms)
TinyDB test passed.
[7660] In engine\MeAPI.cpp:215 (kemt::testKms)

[7660] In engine\MeAPI.cpp:219 (kemt::testKms)
Kerio Connect 8.1.1 build 1374(Mac OS X (10.8.4), x86_64)
[8568] In engine\MapiHelper.cpp:338 (MapiHelper::getServerDN)
Getting server DN
[8568] In engine\MapiHelper.cpp:374 (MapiHelper::getServerDN)
Server DN: /o=NT5/ou=00000000000000000000000000000000/cn=BAEFDE62AC6F91 4B847E872BD7BEEB45
[8568] In engine\MapiHelper.cpp:397 (MapiHelper::getServerDN)
Fixed server DN: /o=NT5/ou=00000000000000000000000000000000
[8568] In engine\MapiHelper.cpp:398 (MapiHelper::getServerDN)
Server admin domain: xxxx.com
[8568] In engine\MapiHelper.cpp:691 (MapiHelper::loadUsersInfo)
Exception of class HResultException: engine\MapiHelper.cpp(517), MapiHelper::readUserInfo:
0x80070057 E_INVALIDARG: CreateStoreEntryID failed
HRESULT: 0x80070057 E_INVALIDARG
[8568] In engine\Migrator.cpp:87 (kemt::Migrator::loadUsers)
Users loading failed
HRESULT: 0x80070057 E_INVALIDARG


I am running Kerio on a Mac. Please let me know if any further info is required to solve this problem.

I hope somebody knows what is causing this and how to fix it.

[Updated on: Wed, 12 June 2013 08:49]

  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
Please make sure your configuration meets the requirements. Particularly, KEMT must run with Outlook 2003 SP3 or 2007 and it must not run on Exchange server itself.
  •  
asagohan992

Messages: 14
Karma: 1
Send a private message to this user
Yes I am using Outlook 2003 SP3 and I am not running it on the Exchange server.
I have tried it from a Windows Server 2008 R2 server and a Windows Vista client and it has not worked on either of them.
Is it possibly something to do with permissions to the Exchange users? I am using the domain administrator account to do this so it should have the necessary permissions to do what it wants.

I have also tried disabling the firewall on the KEMT computer and on Exchange with no luck.

[Updated on: Thu, 13 June 2013 03:14]

  •  
Lucian Maly (Kerio)

Messages: 136
Karma: 8
Send a private message to this user
What Exchange server are you trying to migrate from?

Supported Microsoft Exchange versions are only:
Microsoft Exchange Server 5.5 (SP4)
Microsoft Exchange Server 2000 (SP3)
Microsoft Exchange Server 2003 (SP2)
Microsoft Exchange Server 2007 (SP1)
Microsoft Exchange Server 2010 (SP2)

Kerio Technologies AU Pty Ltd.
  •  
asagohan992

Messages: 14
Karma: 1
Send a private message to this user
My version is 14.03.0123.004
Which is Exchange2010 SP3 according to this: microsoft.com/en-au/download/details.aspx?id=36768

Do I have to downgrade it to SP2?

[Updated on: Thu, 13 June 2013 07:37]

  •  
Pavel Špalek (Kerio)

Messages: 287
Karma: 37
Send a private message to this user
There is a MS Exchange misconfiguration, the homtMTA property is set incorrectly. See details here:

http://tech.groups.yahoo.com/group/Outlook-Redemption/messag e/4891

Pavel Špalek
developer - Kerio Connect
  •  
asagohan992

Messages: 14
Karma: 1
Send a private message to this user
Thankyou so much. That was it.

I ran the following command in Exchange Powershell:

get-mailbox | Update-Recipient

And now I can see the mailboxes in KEMT.
  •  
Pavel Špalek (Kerio)

Messages: 287
Karma: 37
Send a private message to this user
Thank you for feedback, it's good to know that it helped.

Pavel Špalek
developer - Kerio Connect
Previous Topic: 554 5.0.0 Too many hops
Next Topic: KOFF and mobile users
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sat Oct 21 01:24:25 CEST 2017

Total time taken to generate the page: 0.00482 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.