Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Kerio out of memory?! (Strange errors in server logs and random crashes)
  •  
jsosic

Messages: 4

Karma: 1
Send a private message to this user
Hi,

this morning server crashed, only restart helped.

I'm using version 8.1.0 on CentOS 5 x86_64 on a Xen domU with 10GB RAM.

There are the messages I found in error.log:

[17/Jun/2013 18:30:05] file_mmap.cpp: Unable to map file /opt/kerio/mailserver/store/mail/example.com/user.name/Sent Items/sort.fld to memory. Error: (12) Unknown error 12
[17/Jun/2013 19:48:58] KmsWebCallback.cpp: PHP Fatal error:  Out of memory (allocated 46661632) (tried to allocate 7472863 bytes) in /opt/kerio/mailserver/web/webmail/linker/initFolderTreeSilent.inc on line 249
[17/Jun/2013 21:52:36] KmsWebCallback.cpp: PHP Fatal error:  Out of memory (allocated 27262976) (tried to allocate 4505616 bytes) in /opt/kerio/mailserver/web/webmail/linker/initFolderTreeSilent.inc on line 242
[18/Jun/2013 01:32:11] MessageIndexCache.cpp: Not enough memory to allocate message index of folder #public<_at_>example.com/Fax/Arhiva.
[18/Jun/2013 01:32:13] MessageIndexCache.cpp: Not enough memory to allocate message index of folder #public<_at_>example.com/Fax/Arhiva.
[18/Jun/2013 01:32:15] MessageIndexCache.cpp: Not enough memory to allocate message index of folder #public<_at_>example.com/Fax/Arhiva/Dir1.
[18/Jun/2013 01:32:15] MessageIndexCache.cpp: Not enough memory to allocate message index of folder #public<_at_>example.com/Fax/Arhiva/Dir1.


After restart, Kerio works OK. Memory consumption is ~5GB out of 10GB availabe, and the rest is used by OS as the disk cache.

Any ideas?


Also, after upgrading from 7.x to 8.x series, our disk I/O i heavily thrashed, and load on the machine is significantly higher. When I analyze which processes thrash disk, it's always 'mailserver' and '<bdbchecker>'.


Any ideas about increasing performance, decreasing load or fixing this low memory issue are welcome. Thank you guys.
  •  
Lisa Lyons (Kerio)

Messages: 175
Karma: 8
Send a private message to this user
As far as I can tell, this topic has been raised as a ticket with Support.

However, Citrix Xen is an unsupported environment for Kerio virtualised servers, so I welcome any input from partners or others here who have successfully implemented Xen with no issues.

Kerio Technical Support
Log Support Incidents here: http://www.kerio.com/support
Also, please use our KB: http://kb.kerio.com
Previous Topic: Increased CPU on 8.1.1
Next Topic: KOC & Outlook 2013
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sun Sep 24 16:08:29 CEST 2017

Total time taken to generate the page: 0.00428 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.