Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Moving KC to a new server
  •  
McIrish

Messages: 236
Karma: 8
Send a private message to this user
I've read the few articles that are available on moving KC to a new server. My situation is a little different as KC is running on a WS2008 server inside XenServer, so it's virtual. I'd like to move up to the 64bit version of KC, but it requires WS2008R2 and I am only running WS2008. A few weeks back, I stopped the mail store and tried to run the Windows upgrade to get to R2. That did not go well and I was not able to do an in-place upgrade. So, I figured I would try this. Please tell me if this won't work.

1) build new server VM and install Kerio in the same way as the previous machine
2) stop mail services on both servers and copy all the kerio directories over to the new server
3) Detach the mail store drive from the old VM and attach it to the new VM
4) start mail services

I'd have to make sure both servers were named the same with all the same network settings before I start the mail services again.

Will this work or am I jumping in to a mess? The mail store drive is 1.1TB and is 66% full, so I'd rather not try to restore from a backup. Reattaching the mail store drive to the new machine would preserve all time stamps etc.

Anyone have any thoughts before I do this?
  •  
Tomislav

Messages: 61
Karma: 1
Send a private message to this user
This is the same thing we did last night and for the same reason (only we are running Connect on CentOS on XenServer).
It worked pretty much without a hitch, now if the server would only finish reindexing everything and start working normaly (current load jumps from 20 to 40 - insane).

For the record, Kerio does not support Xen. Tech support suggested I migrate to a supported OS when I complained about load issues...

Good luck with the move.
  •  
maurice

Messages: 47
Karma: 2
Send a private message to this user
We did something similar a month back when kmsrecover failed to do its job! Should work fine!
Win2003R2 --> Win2008R2 on Xen
Maurice
  •  
McIrish

Messages: 236
Karma: 8
Send a private message to this user
Thanks for the replies. I really appreciate it. It will give me a little more comfort knowing others have taken this route before.
  •  
Tomislav

Messages: 61
Karma: 1
Send a private message to this user
Just an update on my earlier comment, our server finally finished reindexing everything after 56 hours (~200GB of mailboxes) and the load dropped down to 1-2 and is now working just like before.
Previous Topic: No logs on our KC server or bounce messages to sender for incoming SMTP size limits?
Next Topic: insert events into users Calendar
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Tue Sep 19 21:03:18 CEST 2017

Total time taken to generate the page: 0.00441 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.