Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » No S/MIME avail. on iPhone after installing profile
  •  
mroesch

Messages: 7
Karma: 0
Send a private message to this user
Hello,
I want to use S/MIME with personal certificates on iPhones (one iPhone 5 with iOS 6.1.4 and several iPhone 4 with iOS 6.1.3) with Kerio email accounts.
I installed the personal and CA certificates on the phones, but for every account which was configured using the mobile configuration option of the kerio web interface (which installs a profile with a certificate and account settings) the S/MIME option in the mail settings menu is greyed out.
I don't want to add all necessary account setting for personal and public mail, calendar and contact accounts manually on a couple of iPhones!
So how could I install Kerio's profiles with the S/MIME option enabled?

Best regards,
Michael
  •  
camisy

Messages: 114
Karma: 12
Send a private message to this user
I believe you need to set up your account using the exchange account with EAS manually. Maybe an IMAP account, set up manually, works.
  •  
mroesch

Messages: 7
Karma: 0
Send a private message to this user
I'm not able to remove the email account only, I could only remove the complete profile, which then deletes also all settings for contacts, calendars and all public folders.
So I should add all these accounts manually in order to use S/MIME?

I have to do this on about 10 phones!

EDIT: I tried this also with the Exchange ActiveSync-setup, but that does not work either.

[Updated on: Wed, 21 August 2013 16:32]

  •  
camisy

Messages: 114
Karma: 12
Send a private message to this user
I have set up several iPhones and iPads as exchange account and using S/MIME without problems, You have to do this on 10 iPhones, that's not too mich time I believe.

Maybe you can describe what does not work?
  •  
mroesch

Messages: 7
Karma: 0
Send a private message to this user
What does not work:

After installing the kerio profile on the iPhone, I go to

"Preferences -> Mail, Contacts, Calendar -> $accountname -> Account"
(if configured as Exchange account) or

"Preferences -> Mail, Contacts, Calendar -> $accountname -> Account -> Advanced"
(if configured using carddav, caldav)

At the end of these pages, there is the switch to turn on S/MIME. For all accounts configured via a kerio profile, this switch is greyed out in the off position, so I can't turn S/MIME on. (All necessary S/MIME certificates are already installed on the phone).
  •  
skohls

Messages: 2
Karma: 1
Send a private message to this user
You must do this without the Kerio profile and without the automatic setup script from webmail. Just set up new Mail Account using Exchange and you will be able to install an S/MIME (.p12) certificate and enable digital signing/encryption.
  •  
mroesch

Messages: 7
Karma: 0
Send a private message to this user
Yes, that worked and it is not too much work. Thanks.
Previous Topic: 2 Domain names 1 User Account
Next Topic: Problem with test environment and Directory users
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Mon Oct 16 23:54:18 CEST 2017

Total time taken to generate the page: 0.00414 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.