Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Operator » address book via LDAP: public contacts?
  •  
Silverstar

Messages: 157
Karma: 0
Send a private message to this user
Testing KO 2.2.0 B2
Managed to get LDAP address book provisioned on Snom 760.
But: Contacts in public folder don't show up on the phone.
Any advice?
  •  
Filip Jenicek (Kerio)

Messages: 1094
Karma: 80
Send a private message to this user
Hi

Which LDAP server did you use?
Does the phone show something, or nothing at all?

To debug the settings one might have to log on to the phone's web interface and consult the snom manuals.

Filip
  •  
Silverstar

Messages: 157
Karma: 0
Send a private message to this user
Hi Filip,

sorry I forgot to mention that: We have Kerio Connect as LDAP Server.
All contacts are stored in the public folders so we would like to see those on our phones.
The user given in the provisioning config has proper acces rights for the public folders.

As I'm writing this, I see, that also a contact stored directly in the users contact folder ist not shown on the phone. The only thing the dierctory shows (pressing the directory key on the phone) is an asterisk...

We've a Apple Mac Environment using Macs an iOS devices only.
--> Address book is edited via Apple Address Book.

We're in Germany with german language settings for Kerio Operator, Kerio Connect and the phones. Do we have to edit the LDAP config therefore?

./fa/3110/0/

Silverstar

  •  
Filip Jenicek (Kerio)

Messages: 1094
Karma: 80
Send a private message to this user
I don't think the phones can handle Secure LDAP, please use regular LDAP instead (port 389).

Filip
  •  
Silverstar

Messages: 157
Karma: 0
Send a private message to this user
Hi Filip,

switched to non-https and the directory comes up Smile
But: the phone shows digits like
259.34
259.35
259.36
259.37
...

when pressing the dierctory key.
Search dellivers a result but it seems to be empty and the phone restarts/reprovisions suddenly like it crashed...
  •  
Filip Jenicek (Kerio)

Messages: 1094
Karma: 80
Send a private message to this user
I haven't experienced that. My snom is running fw 8.7.3.19 and works fine.
  •  
Silverstar

Messages: 157
Karma: 0
Send a private message to this user
Updated my testing phones to 8.7.3.19.

Directory now seems to be more stable but I still have the strange digits.
I can perform a search and it finds the entry but I can't get the details from the entry (server error 400).
  •  
Filip Jenicek (Kerio)

Messages: 1094
Karma: 80
Send a private message to this user
What version of Connect do you use?

When you view contacts within Connect's webmail how do they look? Do they contain a valid phone number?
  •  
Silverstar

Messages: 157
Karma: 0
Send a private message to this user
KC Version is 8.1.3 (1711)

Contacts in Webmail look "normal" many contain a phone number some do not.
I've also tried the option "Filter users with no phone number" in KO but then the whole directory is gone...
  •  
fishtech

Messages: 617
Karma: 13
Send a private message to this user
Hi,

Sorry to jump in , but you can capture a screenshot of your snom phone as follows:

http://[phoneIP]/screen.bmp

Some screenshots might help in the thread Smile

ft.
  •  
  •  
Silverstar

Messages: 157
Karma: 0
Send a private message to this user
OK here some sreenshots (nice feature btw!).
./fa/3112/0/

After search for "*" (all contacts) the screens 1 appears.
Scrolling down reveals screens 2-3.

Trying to show details of a contact shows screen 5.

  •  
Filip Jenicek (Kerio)

Messages: 1094
Karma: 80
Send a private message to this user
That is really strange.

Could you start a packet dump via the phone web interface ("PCAP Trace"), reproduce the issue and email the dump along with the phone "Settings" back to me (fjenicek<_at_>kerio.com)?

Filip
  •  
Silverstar

Messages: 157
Karma: 0
Send a private message to this user
Hi Filip,

sent the PCAP trace and the settings file via email.

Silverstar
Filip Jenicek (Kerio)

Messages: 1094
Karma: 80
Send a private message to this user
Hi Silvestar,

in reference to the trace, the ldap request looks fine and the phone even receives a response with several contacts.

However, the contacts have phone numbers in quite complex formats, such as "+49 (2345) 111 222", "0110-11 12 134", or "0110 - 1111 2222".

I think that the phone cannot handle it. I'd suggest you to update the phone numbers to contain only numbers, e.g. "0049123456789".

To verify, create one contact with a nice number and do an ldap search filtering only him.

Filip
Previous Topic: Analogue Needing Restart
Next Topic: SIP Trunk with placetel
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Wed Aug 23 21:31:26 CEST 2017

Total time taken to generate the page: 0.00580 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.