Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Inbox missing and re-index not fixing it
  •  
gbrown100

Messages: 175
Karma: 1
Send a private message to this user
Hi,

Have COnnect 8.1 on Centos 6.2 - a user logs into their mailbox and there is no INBOX. They cannot receive mail. If I log into the file system the folder is there. If I re-index their account from within the admin interface is says there are no problems!

Anyone know how I can fix this? Was thinking I might need to copy out his entire mailbox, delete and re-create the user and then copy it all back in again. Any easier suggestions?

Thanks

Graham
  •  
Lisa Lyons (Kerio)

Messages: 176
Karma: 8
Send a private message to this user
Have you tried logging in through webmail/Kerio Client? What is the email client that they use generally? If it's not the Kerio Client, have you tried removing and recreating their profile?

The last suggestion you have made is really a last resort.

Kerio Technical Support
Log Support Incidents here: http://www.kerio.com/support
Also, please use our KB: http://kb.kerio.com
  •  
gbrown100

Messages: 175
Karma: 1
Send a private message to this user
Sorry, forgot to mention this is Webmail and is not tied to a specific browser or version.
  •  
Vicky Tripp (Kerio)

Messages: 630

Karma: 81
Send a private message to this user
Hi Graham,

Try having a look inside the 'Inbox' in the mail store and see if there is a file called 'status.fld'. If this file is missing then your 'Inbox' will not show up. You can create a plain text file that on the first line contains the following:

T0

Then save the file as 'status.fld' and place this file inside of the 'Inbox' folder in the mail store. Ideally you should do this with the Kerio Connect stopped.

Hopefully that will help,
Vicky

Vicky Tripp
Kerio Technical Support Engineer
  •  
Pavel Dobry (Kerio)

Messages: 5163
Karma: 245
Send a private message to this user
What does the error log say?

Knowledge Base: http://kb.kerio.com/.
Technical support: http://www.kerio.com/support
------------------
Stay Connected Anytime, Anywhere. Discover Kerio Cloud!
  •  
gbrown100

Messages: 175
Karma: 1
Send a private message to this user
Hi,

Well, this problem has widened... In the error log:

For the original problem:

[16/Sep/2013 17:02:31] folder_manager.cpp: Cannot create message directory /opt/kerio/mailserver/store/mail/pmms-group.com/ian.paterson /INBOX/#msgs: (39) Unknown error 39
[16/Sep/2013 17:02:31] folder_manager.cpp: Corrupted folder data were found when trying to open and create folder '~ian.paterson<_at_>pmms-group.com/INBOX'.

And now for other users: (normally exhibiting errors saving to drafts, sent etc)

[17/Sep/2013 05:31:47] MessageStoreDb.cpp: ~Mike.Fogg<_at_>pmms-group.com: checkDeleteOldEvents - SQLite error: code 11, error SQLITE_CORRUPT[11]: database disk image is malformed
[17/Sep/2013 05:31:47] MessageStoreDb.cpp: ~Mike.Fogg<_at_>pmms-group.com: readJournalForFolder - SQLite error: code 11, error SQLITE_CORRUPT[11]: database disk image is malformed
[17/Sep/2013 05:31:49] MessageStoreDb.cpp: ~Mike.Fogg<_at_>pmms-group.com: readJournalForFolder - SQLite error: code 11, error SQLITE_CORRUPT[11]: database disk image is malformed
[17/Sep/2013 05:45:19] folder_manager.cpp: Cannot create message directory /opt/kerio/mailserver/store/mail/pmms-group.com/chris.brown/ Sent Items/#msgs: (39) Unknown error 39
[17/Sep/2013 05:45:19] folder_manager.cpp: Corrupted folder data were found when trying to open and create folder '~chris.brown<_at_>pmms-group.com/Sent Items'.
[17/Sep/2013 05:45:19] folder_manager.cpp: Cannot create message directory /opt/kerio/mailserver/store/mail/pmms-group.com/chris.brown/ Drafts/#msgs: (39) Unknown error 39
[17/Sep/2013 05:45:19] folder_manager.cpp: Corrupted folder data were found when trying to open and create folder '~chris.brown<_at_>pmms-group.com/Drafts'.

Appears to be limited to 3 or 4 people out of 70 odd

Thanks

Graham

[Updated on: Tue, 17 September 2013 15:34]

  •  
Vicky Tripp (Kerio)

Messages: 630

Karma: 81
Send a private message to this user
Hi Graham,

Did you check if the status.fld file existed in the 'Inbox'? As this can cause problems where email cannot be delivered.

In regards to you 2nd issue. the SQLITE_CORRUPT error normally indicates that the .journal.db file in the root of the users folder is corrupt. You can reset this by stopping Kerio Connect, deleting the .journal.db file and starting Kerio Connect back up (please note that .jounal.db is a hidden file so you may want to do this via Terminal unless hidden files are visible on your server).

I hope this helps,
Vicky

Vicky Tripp
Kerio Technical Support Engineer
  •  
eduardocostacruz

Messages: 5
Karma: 0
Send a private message to this user
Thanks Vicky

The status.fld file recreation solved my Inbox.
Previous Topic: Error when installing KOFF 8.4.0 on XP SP3 / Office 2007 SP3
Next Topic: Missing profile images Outlook 2013
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sun Feb 26 06:28:34 CET 2017

Total time taken to generate the page: 0.00997 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.