Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » suppress "on behalf of" (8.2.0 feature) (Is there a way to not show this when forwarding mails as delegate?)
  •  
sysopfromhell

Messages: 18
Karma: 4
Send a private message to this user
Dear all,

upgraded to 8.2.0. The new delegatinon feature adds a "on behalf of" (or the correspondent term in the local client language) to every E-Mail forwarded from a group E-mail account if you are a delegate.
We use a lot of groups and often this term is formaly totally incorrect so we do not want this line showing.

Any ways to achieve this?

Thank you and kind regards

VJP International Administration
Christoph Kral

[Updated on: Tue, 05 November 2013 16:09]

  •  
sysopfromhell

Messages: 18
Karma: 4
Send a private message to this user
I found a text string for the webclient in the /web/webmail/translation/ folder. However I can not find this string for the clients themselves. Where does Kerio store these? Greped the whole /opt/kerio, nothing.
I know Exchange allows this to be switched off and on over the dsa.msc, how does Kerio handles this (and why was this added/turned on without mentioning in the Release Notes? (8.1.3 did not do this)).

Please assist our users are killing us. This is really annoying and causing a lot of problems ("on behalf of group-email1" gawd).

  •  
sysopfromhell

Messages: 18
Karma: 4
Send a private message to this user
Hell it is even worse: when someone answers or forwards from a group/public e-mail (hooked in the user's local box e.g.) Kerio adds the group-email into the "FROM:" field and if the user does not erase this it completely ignores the sender in the Kerio options. This is completely unwanted and makes no sense whatsoever.

Please help
  •  
EdRoxter

Messages: 77
Karma: 2
Send a private message to this user
Same problem here: We have a central mailbox, info<_at_>ourcompany.com. Its Inbox and some subfolders are Shared (not delegated) with the users who are to work with these mails.
Until before KC 8.2.0, they could just open the shared mailbox in their Outlook (we use 2010 32-Bit on Win7 64-Bit), click "Reply", and the Reply would have the user's "From:" address set - which is pretty much what we wanted.

Now, when my user jane.doe@ourcompany.com replies to an e-mail that's in the subscribed info@ourcompany.com mailbox, she will have the info<_at_>.. address in her From: header, though the mail will be put in her own Sent Messages folder.

This is not what we want, too. There are scenarios where the current behavior is wanted, but PLEASE make it possible to have a configuration option like

( ) From Header is always corresponding to the user's mailbox
( ) From Header is adapted to the mailbox with the mail to which the user replies/which the user forwards

Pleaaaaaase! Smile

Edit: I have also commented on this issue in the Kerio Feedback tool: http://feedback.kerio.com/forums/29250-kerio-connect/suggest ions/492733-possibility-to-select-from-address-from-list-in- #comments

[Updated on: Wed, 06 November 2013 10:58]

  •  
EdRoxter

Messages: 77
Karma: 2
Send a private message to this user
Additional info on this: It looks like the behavior for Shared Folders is the same as for delegates.

The subscribed mailboxes address is in the From: header, whereas the user's credentials are in the Sender: header. Outlook shows this as "Jane Doe <jane.doe@ourcompany.com> on behalf of <info<_at_>ourcompany.com>". Other mail clients only obey the From: header which makes the mail look like it's sent from the subscribed mailbox, rather than from the user.

While this seems to be adequate for delegation, this is not the behavior expected with particular subscribed folders/mailboxes.
  •  
gmaoret

Messages: 49
Karma: 2
Send a private message to this user
  •  
sysopfromhell

Messages: 18
Karma: 4
Send a private message to this user
I finally found the technical reason for this:

Before 8.2.0 (8.1.3)


01.11.2013 08:34:30.28 esmtpp: started esmtpp
[...]
01.11.2013 08:34:30.40 esmtpp: Email sender <patdresden<_at_>vjp.de> allowed
01.11.2013 08:34:30.40 esmtpp: esmtp_reply: 250 <patdresden<_at_>vjp.de>... Sender ok..
[...]
01.11.2013 08:34:30.43 esmtpp: mail from: <patdresden<_at_>vjp.de>
01.11.2013 08:34:30.43 esmtpp: mail to: <somebody<_at_>somedomain.com>
[...]
01.11.2013 08:34:31.69 smtpd: FROM: patdresden<_at_>vjp.de
01.11.2013 08:34:31.69 smtpd: RCPT: somebody<_at_>somedomain.com
[...]
01.11.2013 08:34:31.69 smtpd: Header field "From:" found: ""Patdresden (Peggy Kloth)" <patdresden<_at_>vjp.de>"
01.11.2013 08:34:31.69 smtpd: sender information: ESMTP:<patdresden@vjp.de>, From:'"Patdresden (Peggy Kloth)" <patdresden<_at_>vjp.de>'
01.11.2013 08:34:31.69 smtpd: found real name 'Patdresden (Peggy Kloth)' from mail address comment


When sending with kerio Connect 8.2.0:


05.11.2013 08:22:17.39 esmtpp: started esmtpp
[...]
05.11.2013 08:22:17.50 esmtpp: Email sender <pkloth<_at_>vjp.de> allowed
[...]05.11.2013 08:22:17.50 esmtpp: esmtp_reply: 250 <pkloth<_at_>vjp.de>... Sender ok..
[...]
05.11.2013 08:22:17.52 esmtpp: mail from: <pkloth<_at_>vjp.de>
05.11.2013 08:22:17.52 esmtpp: mail to: <somebody<_at_>somedomain.com>
[...]
05.11.2013 08:22:17.70 smtpd: FROM: pkloth<_at_>vjp.de
05.11.2013 08:22:17.70 smtpd: RCPT: somebody<_at_>somedomain.com
[...]
05.11.2013 08:22:17.70 smtpd: Header field "From:" found: ""Patdresden (Peggy Kloth)" <patdresden<_at_>vjp.de>"
05.11.2013 08:22:17.70 smtpd: sender information: ESMTP:<pkloth@vjp.de>, From:'"Patdresden (Peggy Kloth)" <patdresden<_at_>vjp.de>'
05.11.2013 08:22:17.70 smtpd: Ignoring email address comment patdresden@vjp.de, because is not the sender pkloth<_at_>vjp.de

So Kerio does not set the esmt_reply field even if the client sets both fields in the client to another e-mail address. I hope this is a bug because it's a real big problem. Our security software parses this and can not relate S/mime certificates and pgp keys etc.




  •  
Sebaster

Messages: 2
Karma: 0
Send a private message to this user
Hello Sysopfromhell,


have you already found a solution for this "sent on behalf" problem? I don't know, how Kerio is imagine this: should one be able to send mails from just one account? That's far removed from actual reality. What about the concept of project related mail accounts and the need of reading and responding them by just one person? It is NOT feasible to change the outlook profile each time.
I recommended Kerio without knowing that this is not possible - simply thought this is kind of a standard for mail-server software. And know the users are complaining about that...

Grüße aus Berlin
Seb
  •  
sysopfromhell

Messages: 18
Karma: 4
Send a private message to this user
Hi everyone!

Just upgraded to 8.2.1 - Problem solved!
Thanks to everybody replying to my post and thanks to the Kerio team for the quick fix.

Best regards

[Updated on: Wed, 20 November 2013 14:16]

  •  
Sebaster

Messages: 2
Karma: 0
Send a private message to this user
Hello Sysopfromhell,
does this mean, you are now able to send from one outlook profile with two different sender adresses without "on behalf of" oder "Im Auftrag von"?? This would be very important for us...

Kind regards,
Sebastian
  •  
sysopfromhell

Messages: 18
Karma: 4
Send a private message to this user
So the status is the following:

the 8.2.1 updates fixed the wrong sender address in afforementioned fields

If you have "delegated" boxes hooked in, e.g.

you are "user1@domain.com" and you are forwarding or reply to an email from "groupaccount@domain.com" you are still getting the "on behalf of" addition AND the default email sender is the email "groupaccount<_at_>domain.com". However, you can switch to your email-adress with a click on the "FROM:" Button in Outlook now.
Still not as good as it was before 8.2.x, but somehow workable.
Personally, I still don't see the benefits or the reason for the "delegation" changes. The old system was actually pretty good.
I was planing to do a separate posting with screenshots on this topic.

Cheers,

Christoph
VJP International IT Department
  •  
EdRoxter

Messages: 77
Karma: 2
Send a private message to this user
Quote:
you are "user1@domain.com" and you are forwarding or reply to an email from "groupaccount<_at_>domain.com" you are still getting the "on behalf of" addition AND the default email sender is the email "groupaccount<_at_>domain.com".


Yup, ditto. I'd like to see the old default behavior here and have the "on behalf of" stuff as an option, if any. I plainly want to have my user's e-mail address in the From: header, regardless of the location of the e-mail he's replying to/forwarding.

Many clients other than Outlook simply disregard the Sender: header. If all e-mail clients obeyed it in Outlook's way, it would be a great feature - but they don't, thus we just need to stick to the From: header. And that should be my user@mydomain.com, not my groupaccount<_at_>mydomain.com.
Previous Topic: OD Groups missing in Connect
Next Topic: Unable to connect to Secure instant messaging
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Thu Nov 23 19:48:56 CET 2017

Total time taken to generate the page: 0.00482 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.