Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Operator » Using Operator with Flextor CTI: Weird problems
  •  
p0ddie

Messages: 242
Karma: -3
Send a private message to this user
Hi,

we are using Kerio Operator 2.1.1 build 1684 (afaik some "special build" that was sent to us because at the time Operator did not play well with the 4 ISDN ports connected).


I just installed the latest trial of Flextor CTI for Outlook integration at a client on one machine and have weird problems. All I did was use this kbase article to set up the connection, aside from country specific stuff and "dial 0 for outside line" I have not made any changes to Flextor's settings.

It worked a little for the first minutes, then apparently the entire Asterisk on Operator crashed (everybody b*tched about having no phone for a couple of minutes).

Anyway, receiving calls seems to work - Flextor shows the incoming call and I can pick up. Outgoing calls do not work, Flextor tells me the device is not present (the device being the Asterisk extension of my user).

Furthermore, when I click to dial, my phone rings until I pick up, then it starts dialing. Is it possible to have the phone dial right away on speaker? Is it a setting in Operator or in the phone? It's a Snom 320 phone.

Some logs:

Warning:


[07/Nov/2013 10:17:11] [user][u:<external number>][pkt:0x8447af0]Unknown channel: 'SIP/77-00000001'
[07/Nov/2013 10:17:11] [user][u:<internal user>][pkt:0x8447af0]Unknown channel: 'SIP/77-00000001'
[07/Nov/2013 10:17:11] [user][u:<internal user>][pkt:0x8447af0]Unknown channel: 'SIP/77-00000001'
[07/Nov/2013 10:17:11] {ami} Internal Asterisk Connection: Unknown channel: 'SIP/77-00000001'
[07/Nov/2013 10:17:11] {ami} Internal Asterisk Connection: Unknown channel: 'SIP/77-00000001'
[07/Nov/2013 10:17:17] asterisk[22660]: WARNING[22748]: translate.c:206 in framein: no samples for alawtolin
[07/Nov/2013 10:19:37] asterisk[22660]: WARNING[22791]: app_dial.c:2341 in dial_exec_full: Unable to create channel of type 'SIP' (cause 20 - Subscriber absent)
[07/Nov/2013 10:19:42] asterisk[22660]: WARNING[22793]: app_dial.c:2341 in dial_exec_full: Unable to create channel of type 'SIP' (cause 20 - Subscriber absent)


Error:


[07/Nov/2013 10:17:11] [user][u:<external number>][pkt:0x8447af0]Unknown channel: 'SIP/77-00000001'
[07/Nov/2013 10:17:11] [user][u:<external number>][pkt:0x8447af0]Unknown channel: 'SIP/77-00000001'
[07/Nov/2013 10:17:11] [user][u:<internal user>][pkt:0x8447af0]Unknown channel: 'SIP/77-00000001'
[07/Nov/2013 10:17:11] [user][u:<internal user>][pkt:0x8447af0]Unknown channel: 'SIP/77-00000001'
[07/Nov/2013 10:17:11] {ami} Internal Asterisk Connection: Unknown channel: 'SIP/77-00000001'
[07/Nov/2013 10:17:11] {ami} Internal Asterisk Connection: Unknown channel: 'SIP/77-00000001'
[07/Nov/2013 10:17:17] asterisk[22660]: WARNING[22748]: translate.c:206 in framein: no samples for alawtolin
[07/Nov/2013 10:19:37] asterisk[22660]: WARNING[22791]: app_dial.c:2341 in dial_exec_full: Unable to create channel of type 'SIP' (cause 20 - Subscriber absent)
[07/Nov/2013 10:19:42] asterisk[22660]: WARNING[22793]: app_dial.c:2341 in dial_exec_full: Unable to create channel of type 'SIP' (cause 20 - Subscriber absent)


Debug:


[07/Nov/2013 10:17:11] [user][u:<external number>][pkt:0x8447af0]Unknown channel: 'SIP/77-00000001'
[07/Nov/2013 10:17:11] [user][u:<external number>][pkt:0x8447af0]Unknown channel: 'SIP/77-00000001'
[07/Nov/2013 10:17:11] [user][u:<internal user>][pkt:0x8447af0]Unknown channel: 'SIP/77-00000001'
[07/Nov/2013 10:17:11] [user][u:<internal user>][pkt:0x8447af0]Unknown channel: 'SIP/77-00000001'
[07/Nov/2013 10:17:11] {ami} Internal Asterisk Connection: Unknown channel: 'SIP/77-00000001'
[07/Nov/2013 10:17:11] {ami} Internal Asterisk Connection: Unknown channel: 'SIP/77-00000001'
[07/Nov/2013 10:17:17] asterisk[22660]: WARNING[22748]: translate.c:206 in framein: no samples for alawtolin
[07/Nov/2013 10:19:37] asterisk[22660]: WARNING[22791]: app_dial.c:2341 in dial_exec_full: Unable to create channel of type 'SIP' (cause 20 - Subscriber absent)
[07/Nov/2013 10:19:42] asterisk[22660]: WARNING[22793]: app_dial.c:2341 in dial_exec_full: Unable to create channel of type 'SIP' (cause 20 - Subscriber absent)

I also then flushed the debug log and activated CTI logging - so far not a single entry. Shouldn't there be something logged when a cti software authenticates against Kerio Operator and when it signals a call? Because that works but it doesn't show jack.


Any ideas? Thanks!

[Updated on: Thu, 07 November 2013 10:50]

  •  
Filip Jenicek (Kerio)

Messages: 1094
Karma: 80
Send a private message to this user
Hi

How did you configure the Flextor CTI? Can you post a screenshot of your settings.

Filip
  •  
p0ddie

Messages: 242
Karma: -3
Send a private message to this user
for some strange reason, a few hours later it now works. Now I need to figure out Flextor as a software, e.g. how to get all the other extensions into the Flextor contacts list without adding them as a device under "my phones" and so on.

Thanks so far!
Previous Topic: Dial by name
Next Topic: Voicemail greeting options
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sun Oct 22 04:53:28 CEST 2017

Total time taken to generate the page: 0.00422 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.