Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » help configuring IM (please)
  •  
monkeymissile

Messages: 126
Karma: 1
Send a private message to this user
Hi there,
I need to pester again because I still can't figure out how to configure IM via Kerio.
I read the tutorials, but I find parts of it cryptic.
I only want to use IM internally so I only set up a client SRV record with our DNS registrar.

I believe I configured the record correctly because the Check Service Accessibility gets a green check whereas it didn't before.

should the record be: _xmpp-client._tcp.ourdomain.com. 18000 IN SRV 0 5 5222 mail.ourdomain.com.
or _xmpp-client._tcp.ourdomain.com. 18000 IN SRV 0 5 5222 ourdomain.com.
or _xmpp-client._tcp.ourdomain.com. 18000 IN SRV 0 5 5222 connect.ourdomain.com.

I then confirmed with SonicWall that our TZ215 by default has ports 5222 and 5223 open

Then, I configured iChat per the instructions but I get an error message saying that iChat can't communicate with the Jabber account "myname<_at_>ourdomain.com", could not connect to host mail.ourdomain.com

I'm not sure what the issue is or what I could be doing wrong and I'm not sure what I should do now. Any help would be greatly appreciated.

thank you!
  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
I recommend to check the firewall. Maybe the iChat client wants to check server availability eg. with ping.

DNS should be set to the hostname you use in your internal network for Kerio Connect server.

[Updated on: Fri, 22 November 2013 19:17]

  •  
monkeymissile

Messages: 126
Karma: 1
Send a private message to this user
ah, so if the name of our Kerio domain is "ourdomain" it shouldn't be "mail.ourdomain" in the record, just "
"ourdomain"?
  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
What hostname you put into web browser when accessing Kerio Connect client? It has nothing to do with email domain. Hostname is the name of the computer (server) in DNS.
  •  
monkeymissile

Messages: 126
Karma: 1
Send a private message to this user
mail.ourdomain.com (which is what I used in my client SRV record)

sorry, I'm obviously getting some terminology confused.....
  •  
Tomas Skoda (Kerio)

Messages: 107
Karma: 20
Send a private message to this user
Our observation is that iChat (when auto-configuring) checks DNS 'A' record existence first. iChat refuses to connect If A record does not exist. Other clients (like Adium) does not need the A record at all and should auto configure without any problem.

1. Check if you have A record for 'ourdomain.com'

2. Does iChat connect when you enter server IP address manually?
(Preferences->Accounts->Server Settings, uncheck Automatically find server and port, fill server IP and port 5222, (!) uncheck SSL)
  •  
monkeymissile

Messages: 126
Karma: 1
Send a private message to this user
Hi,
apologies for the late reply, I really appreciate your assistance.

I followed your suggestions for iChat and it seems to work! Many thanks.
I need to configure the rest of my users and will get back only if I run into any more issues. Happy New Year!
  •  
monkeymissile

Messages: 126
Karma: 1
Send a private message to this user
All seems to be working nicely, thanks again for the help!

I have (2) question however:
- I don't recall receiving this message when I set up my iChat account, but other users are. They get non-secure message when they login ([img]./fa/3268/0/[/img]). Is this an issue and can it be resolved?
- we can't see each other's user icons, we're all just lightbulbs. Any way to fix that too?

thanks again for everyone's assistance.
Justin

[Updated on: Mon, 06 January 2014 16:56]

  •  
Tomas Skoda (Kerio)

Messages: 107
Karma: 20
Send a private message to this user
Quote:
- I don't recall receiving this message when I set up my iChat account, but other users are. They get non-secure message when they login ([img]./fa/3268/0/[/img]). Is this an issue and can it be resolved?

iChat unfortunately displays this warning even so the IM connection is secured with SSL or TLS. This behavior can be disabled in iChat preferences -> Accounts -> Server Settings -> Warn before sending password insecurely.

Quote:
- we can't see each other's user icons, we're all just lightbulbs. Any way to fix that too?

The source of user photos (and also the rest of other user details) is Kerio Global Address List. Set the user photo there and it will be distributed to all clients (once the user with new photo changes its status).

Cheers,
Tomas Skoda
  •  
monkeymissile

Messages: 126
Karma: 1
Send a private message to this user
Thank you Tomas,
I'm still not clear as to where to set the user photos, we are using active Directory if that helps.

Justin
  •  
Tomas Skoda (Kerio)

Messages: 107
Karma: 20
Send a private message to this user
In your case you need to change user photos directly in AD. It could take up to one hour to distribute these changes from AD. Restart of Kerio Connect server makes it instant.

We are thinking about simplification of this process in next Kerio Connect release.
Previous Topic: Problem with Connect Account Assistant on OS X
Next Topic: Renaming inbox folder
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Thu Oct 19 23:59:25 CEST 2017

Total time taken to generate the page: 0.00511 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.