Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » KMS 5 Problem with mails sending to my own domain...
  •  
TTBob

Messages: 4
Karma: 0
Send a private message to this user
Hello,

I couldn't send emails to an address which has the same domain extension "domain.at" which I use, but the address is not in my users list and therefore KMS couldn't find it and I get the following error message.

The error message is:

550 5.1.1 Mailbox <office.***<at>domain.at> does not exist

To make it easier to understand, the problem is the following. If I have an email address from hotmail.com and I create a domain and a user for this email than I'm able to retrieve mails and send mails as long as the recipient is not in a hotmail.com domain.

In my opinion KMS thinks the if there is an user for the domain this user must be in the KMS users list. If there is no such user the mail is dropped with the above error message.

I thing there are two solutions for the problem. One is to send all emails via DNS MX records (also the internal accounts), which would be no problem. The other one is to tell KMS that this specific email address is an external address.

Thank you guys
  •  
Iassen Hristov

Messages: 54
Karma: 0
Send a private message to this user
You are not explaining very well what is the problem, but let me explain
what is that KMS does.

1. If you send an e-mail to KMS, it will accept it for delivery to a local
mailbox only if:
a) you have created such domain (in KMS)
and
b) such mailbox exists or an alias exists for it

2) It will deliver it to an external e-mail address only if:
a) the domain is NOT in the list of domains in KMS
and
b) you are allowed to send to external domains (relay). This is true if:
- you are an authorized user within KMS and authenticate yourself as suh
(typically in the SMTP server connection settings)
or
- your KMS is configured to allow relaying for certain IP range, or is an
open relay (not recommended).

In other words it seems completely natural to me that you would receive a
message "mailbox does not exist", since it really doesn't. If you want to
allow the receipt of e-mail for this address you either have to create a
user or an alias. If you want you can receive messages for all mailboxes
that have no match in a specific mailbox.

Let's say you have the following users:
user1
user2
user3

And the following groups:
sales (members are user1 and user2)
marketing (members are user1 and user3)

I think by default groups do not receive e-mail, but you can create an alias
sales -> [sales]
marketing -> [marketing]

Note that group names are enclosed in squere brakets (the admin user
interface does this for you).

In addition you could create the following alias
* -> user1

and anything that is not matched to a user or alias will be delivered to
the mailbox of user1.

Hope this clears things up.

---
Iassen Hristov

--On Monday, August 09, 2004 12:15 PM +0200 TTBob
<tingel-tangel_bob<at>gmx.at> wrote:

>
> Hello,
>
> I couldn't send emails to an address which has the same domain extension
> "domain.at" which I use, but the address is not in my users list and
> therefore KMS couldn't find it and I get the following error message.
>
> The error message is:
>
> 550 5.1.1 Mailbox <office.***<at>domain.at> does not exist
>
> To make it easier to understand, the problem is the following. If I have
> an email address from hotmail.com and I create a domain and a user for
> this email than I'm able to retrieve mails and send mails as long as the
> recipient is not in a hotmail.com domain.
>
> In my opinion KMS thinks the if there is an user for the domain this user
> must be in the KMS users list. If there is no such user the mail is
> dropped with the above error message.
>
> I thing there are two solutions for the problem. One is to send all
> emails via DNS MX records (also the internal accounts), which would be no
> problem. The other one is to tell KMS that this specific email address is
> an external address.
>
> Thank you guys



Previous Topic: URL doesn't work for Webmail..please help
Next Topic: Deleted Users and groups still show up
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Mon Nov 20 10:30:56 CET 2017

Total time taken to generate the page: 0.00428 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.