Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Unable to start XMPP "Port is Probably being used" (Ever since 8.2.1)
  •  
BLTomato

Messages: 57
Karma: 1
Send a private message to this user
When we installed Kerio 8 the XMPP service was working fine. After we upgraded to the latest it has stopped working claiming that "another application was probably using that port number."

The Kerio Mailserver is the only thing that runs on this server, and the XMPP service was working before the upgrade.
Doing a Netstat and grepping the port numbers does not show any other service listening on that port.
Doing a Port Scan on those ports gives no response

The errors in the logs are pretty bare:

Error.log
[27/Feb/2014 16:50:49] ProtocolService.cpp: Service XMPP failed to start
[27/Feb/2014 16:50:56] ProtocolService.cpp: Service XMPPS failed to start

Debug with Instant Messenger selected:
[27/Feb/2014 16:50:49][6073356288] {im} Start XMPP/XMPPS protocol service message (secure='false') has been arranged (id: C9C1F07F-DC09-4B6E-835E-F77BA7D37803).
[27/Feb/2014 16:50:49][6073356288] {im} Skipping sending C9C1F07F-DC09-4B6E-835E-F77BA7D37803 message.
[27/Feb/2014 16:50:56][6073356288] {im} Start XMPP/XMPPS protocol service message (secure='true') has been arranged (id: 28030679-03F5-480C-8DE9-386779592379).
[27/Feb/2014 16:50:56][6073356288] {im} Skipping sending 28030679-03F5-480C-8DE9-386779592379 message.

Anyone seen that? I did do some searching through the forum and did check my mail server.cfg to verify that the XMPP and S were pointed to 0.0.0.0 which they were:

<listitem>^M
<variable name="Service">XMPP</variable>^M
<variable name="IPAddress">0.0.0.0</variable>^M
<variable name="Port">5222</variable>^M
</listitem>^M
<listitem>^M
<variable name="Service">XMPPS</variable>^M
<variable name="IPAddress">0.0.0.0</variable>^M
<variable name="Port">5223</variable>^M
</listitem>^M

Any ideas in what could be hosing me up? Mac OSX 10.8.5 non-server on a mini with 16 gigs of ram. Kerio Connect is the only thing non-apple installed on here.
  •  
Tomas Skoda (Kerio)

Messages: 107
Karma: 20
Send a private message to this user
Hi

It looks like Instant Messaging must had been manually disabled before you upgraded. Check the value of variable 'Enabled' in table 'InstantMessaging' inside 'mailserver.cfg'.

Cheers,
Tomas Skoda
  •  
BLTomato

Messages: 57
Karma: 1
Send a private message to this user
We did have it turned off when we upgraded, and looking at the cfg yes the value was at 0. I set it to 1, next time I restart the mail server I'll bump this with the results.

Thanks Tomas!
Previous Topic: Compose new mail window automatically minimizing?
Next Topic: Alias works but is not in list
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Fri Oct 20 23:25:36 CEST 2017

Total time taken to generate the page: 0.00396 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.