Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Operator » Cannot Upgrade from 2.1.4 to 2.2.5 (Cannot Upgrade from 2.1.4 to 2.2.5)
  •  
SBMT

Messages: 26
Karma: 0
Send a private message to this user
The upgrade fails with the following log, and Operator reverts back to 2.1.4.

Did anybody see this? I cannot even upgrade to an interim version, the upgrade still fails.

[10/Apr/2014 10:39:20] LdapSync: Cannot connect to the Directory service. See LDAP debug log for more details.
[10/Apr/2014 11:00:57] [10-Apr-2014 11:00:57] PHP Warning: ibase_query(): violation of FOREIGN KEY constraint "PK_PROVISIONING_PHONES" on table "PROVISIONING_PHONES" Foreign key reference target does not exist in /opt/kerio/operator/www/lib/Database.inc on line 155
[10/Apr/2014 11:00:57] [10-Apr-2014 11:00:57] PHP Warning: ibase_close(): violation of FOREIGN KEY constraint "PK_PROVISIONING_PHONES" on table "PROVISIONING_PHONES" Foreign key reference target does not exist in /opt/kerio/operator/www/lib/Database.inc on line 66
[10/Apr/2014 11:00:59] [10-Apr-2014 11:00:59] PHP Warning: ibase_query(): unsuccessful metadata update CONSTRAINT FK_PH_T_GRPMEM_PH_T does not exist. in /opt/kerio/operator/www/lib/Database.inc on line 291
[10/Apr/2014 11:00:59] Failed to execute query: ALTER TABLE phone_type_group_members DROP CONSTRAINT FK_ph_t_grpmem_ph_t
[10/Apr/2014 11:00:59] Upgrade: Bad query: ALTER TABLE phone_type_group_members DROP CONSTRAINT FK_ph_t_grpmem_ph_t
[10/Apr/2014 11:00:59] Upgrade: Database error -607: unsuccessful metadata update CONSTRAINT FK_PH_T_GRPMEM_PH_T does not exist.
[10/Apr/2014 11:01:04] Upgrade error: Database schema upgrade failed.
[10/Apr/2014 11:02:00] LdapSync: Cannot connect to the Directory service. See LDAP debug log for more details.
  •  
Filip Jenicek (Kerio)

Messages: 1094
Karma: 80
Send a private message to this user
Hi Stefan,

could you please send your system backup to fjenicek<_at_>kerio.com. I will analyze it and try to help you.

Thank you,
Filip
  •  
SBMT

Messages: 26
Karma: 0
Send a private message to this user
Replied as instructed. 15MB File. If it does not get through, please let me know.

Thanks a million!
S.
  •  
Vladimir Toncar (Kerio)

Messages: 1696
Karma: 39
Send a private message to this user
If you want to upgrade because of the Heartbleed issue, you do not need to hurry. Version 2.1.4 is not influenced.
  •  
SBMT

Messages: 26
Karma: 0
Send a private message to this user
Filip as usual quickly found the problem.

I have four installations of Operator that i administer, some were affected some not. I guessed I'd rather bring them all up to the same version, and this one was the only one which failed because of a Snom M3 in the list of provisioned phones.

Well done guys for the quick and accurate responses you provide.

S.
Previous Topic: ANNOUNCEMENT: Downloads now available in Support section of website
Next Topic: Call history
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Fri Nov 24 23:18:48 CET 2017

Total time taken to generate the page: 0.00368 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.