Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Operator » SOLVED: Strange behavior with snom fkeys
  •  
Silverstar

Messages: 157
Karma: 0
Send a private message to this user
Hi folks,

we've a template override for the fkeys of our snoms:
fkey4!: blf <sip:137<_at_>10.0.0.225;user=phone>|**
fkey5!: blf <sip:138<_at_>10.0.0.225;user=phone>|**
fkey6!: blf <sip:123<_at_>10.0.0.225;user=phone>|**
fkey7!: blf <sip:176<_at_>10.0.0.225;user=phone>|**
fkey8!: blf <sip:122<_at_>10.0.0.225;user=phone>|**
fkey9!: blf <sip:111<_at_>10.0.0.225;user=phone>|**
fkey10!: blf <sip:150<_at_>10.0.0.225;user=phone>|**
fkey11!: blf <sip:103<_at_>10.0.0.225;user=phone>|**
fkey12!: blf <sip:125<_at_>10.0.0.225;user=phone>|**
fkey13!: blf <sip:124<_at_>10.0.0.225;user=phone>|**
fkey14!: blf <sip:121<_at_>10.0.0.225;user=phone>|**
fkey15!: blf <sip:101<_at_>10.0.0.225;user=phone>|**

But they are ignored by the phones Sad

every other setting in the overrides is respected only these are not working...
Any ideas?

Greetz
Silverstar

[Updated on: Wed, 16 July 2014 11:28]

  •  
Filip Jenicek (Kerio)

Messages: 1094
Karma: 80
Send a private message to this user
Hi,

the configuration options look fine.

Which snom model and firmware have you tried?

What do you exactly mean by saying that they are ignored?
- Can you see the keys configured in the phone's web interface?
- Does the button do anything when being pressed?

Have you tried to configure the buttons manually using the phone's web interface?

Filip
  •  
Silverstar

Messages: 157
Karma: 0
Send a private message to this user
Hi Filip,

we're using snom 760 with firmware 8.7.3.19.

Quote:
What do you exactly mean by saying that they are ignored?

The function keys were prevoiusly configured via TFTP html files now I wanted to get rid of these.
Any chnage made by the template override is not loaded (the old config remains).

Now I figured out, that if I hit "Reset" in the phones web interface (Advanced ยป Update) instead of "only" rebooting, the settings are loaded. But this is not "nice" because is destroys all user settings (ringtone, volume ...).

Any ideas Filip?

Thanks & kind regards
Silverstar

[Updated on: Wed, 16 July 2014 08:42]

  •  
Filip Jenicek (Kerio)

Messages: 1094
Karma: 80
Send a private message to this user
Reset usually helps Smile

I can refer you to the Flags section at < http://wiki.snom.com/Category:Auto_Provisioning:Configuratio n_Files>. Every configuration option is followed by a flag that specifies whether the option should overwrite a previously configured value.

Perhaps if you replace the exclamation mark with a dollar sign, the phone will accept new settings.
Try: fkey4$: blf <sip:137<_at_>10.0.0.225;user=phone>|**

I'm not a snom expert and it's pretty much trial and error for me too.
  •  
Silverstar

Messages: 157
Karma: 0
Send a private message to this user
Hi Filip,

you're gerat!
That did the trick Smile

Thank you!
Silverstar
Previous Topic: Best method of calling different numbers after hours
Next Topic: Problem with call forwarding to a mobile
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Mon Aug 21 23:41:48 CEST 2017

Total time taken to generate the page: 0.00470 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.