Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Cannot write to mail queue
  •  
brandonh75

Messages: 47
Karma: 0
Send a private message to this user
Over the weekend we had some users start getting the following message when trying to send email via SMTP:

{smtps} Cannot start queue inject, sent reply to MAIL: 451 4.3.2 Internal server error

Trying to resend the email after a few seconds would succeed.

Kerio's error log is showing a lot of this:

[16/Jul/2014 10:33:21] spam_reports.cpp: Cannot write to mail queue, no spam filter report sent
[16/Jul/2014 10:34:08] mail_envelope.cpp: Cannot open queue file C:\Program Files\Kerio\MailServer\store/queue/01/53c69b70-000002bf.eml for writing: (3) The system cannot find the path specified.

We ran a CHKDSK and Windows fixed some file errors, but we are still seeing these messages in the Kerio error log. This doesn't happen with every message. I'm not sure what I should look at next, or which debug log messages may be helpful.

Thanks!

Kerio Connect 8.3.1 (2843)
Windows Server 2003 Enterprise SP2, 32-bit
One user that reported this is using Thunderbird 8.0 (I will try updating that one)
We have internal programs that send email that were also seeing this error.
  •  
brandonh75

Messages: 47
Karma: 0
Send a private message to this user
I think I got it. In the error log there were always six queue folders that Kerio was trying to use. Those folders did not exist, but there were six empty files with the same names. I removed those empty files and created the six folders by hand. The errors seem to have stopped.
  •  
freakinvibe

Messages: 1507
Karma: 58
Send a private message to this user
Hmm, strange.

Do you have any Anti-Virus product on the server (not on Kerio, but on the server itself). If so, you should exclude the store folder (and sub-folders) from scanning.

Dexion AG - The Blackberry Specialists in Switzerland
https://dexionag.ch
  •  
brandonh75

Messages: 47
Karma: 0
Send a private message to this user
Yes, we run Vipre antivirus, and the store folder is excluded from scan.

Just removing the six empty files in the queue folder wasn't enough, I had to create those folders. The chkdsk I ran on the server "fixed" six files...must have been those ones.
  •  
mrgenie

Messages: 30
Karma: 0
Send a private message to this user
I have the same issue. Also missing those directories.

found it was a backup program running background, which after successful backup would check for empty directories and delete them if empty

might be a similar software at your system, checking for unused directories and delete them, while kerio relies on the existence of those directories.
  •  
Jonas Rodrigues (Kerio)

Messages: 262
Karma: 22
Send a private message to this user
Hello all,

Kerio Connect needs to have exclusive access to it's folder. No Antivirus or Backup software should be reading/writing to Kerio folder's while Kerio is working.

Otherwise you will have those problems.

All the best,

Jonas

Kerio Technical Support
Log Support Incidents here: http://www.kerio.com/support
Also, please use our KB: http://kb.kerio.com
Previous Topic: Synchronize Kerio Connect with CRM, Server-based
Next Topic: Keri Connect Mail Columns
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Mon Jul 24 16:34:45 CEST 2017

Total time taken to generate the page: 0.00473 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.