Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Apple Mail Auto complete addressee..how to stop it? (A way to prevent auto completion when composing email in Apple Mail 10.9+?)
  •  
robjfrost

Messages: 44
Karma: 0
Send a private message to this user
Hi

For the last few Apple OS's upto 10.9 apple had the auto completion set as a preference which i could switch off. Then prevent users from switching it back on by having a mail preference outside in the /Library/Preferences which would then over ride the user preference.

Apart from now removing the AddressBook from ~/Library/Application Support which then removes all details from the Contacts.

Does anyone know a way of removing the auto-completion in Apple Mail.

Im aware of previous recipients list but i need the auto completion turned off or a way of making apple mail not to talk to contacts.

too many of my users sending to the wrong recipients... Confused


Thanks Rob

[Updated on: Fri, 26 September 2014 15:56]

  •  
jelockwood

Messages: 41
Karma: 1
Send a private message to this user
It is not compulsory to define an account in the Contacts application. Therefore if you don't define or enable either a CardDAV or Exchange account it will not be able to look up contacts via Kerio Connect. It will still as you noted auto-complete from previous recipients and from local private contacts defined in the Contacts application.

Contacts will always have its own local private contact entries and this does not appear possible to turn off.

Personally I find previous recipients to be the most common cause of repeated wrong addresses.
  •  
robjfrost

Messages: 44
Karma: 0
Send a private message to this user
Thanks jelockwood that would of course be the obvious and easiest answer... unfortunately I also need the contacts to be available, so they can drag the recipient address from address book to the To: area of Apple Mail as this is what they did previously.

I have tried creating a new sym link in ~/Library/Containers/com.apple.mail/Data/Library/Application Support/Address Book and point it to a blank folder in the hope of confusing Mail similar to when there was iCloud issues earlier on in Mavericks as it stopped Mail from auto completing but i can't get this to work.

Do i need to change something else too?

Thanks

Previous Topic: block mails without subject
Next Topic: Rotating debug.log makes Kerio unresponsive
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Tue Mar 28 12:07:22 CEST 2017

Total time taken to generate the page: 0.00838 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.