Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Backup Recovery problem
  •  
dtcb2003

Messages: 13
Karma: 0
Send a private message to this user
Hello,

I am following instructions from this KB to move my Kerio Connect 7.4.0 from a W2k3 32-bit server to a Windows 2008 R2 server. I installed same version of Kerio Connect on the Win2k8 R2 server and I used Method 1: Restoring from a backup.
kb.kerio.com/product/kerio-connect/server-configuration/expo rt-and-migration/transferring-an-installation-of-kerio-conne ct-to-another-server-or-operating-system-360.html

However, when I ran kmsrecover command, I got the error message below.

Running kmsrecover will modify the Kerio Connect store directory.

Are you sure you want to continue (yes/no): yes
Recovery started at 2014-09-30 13:36:35
Inconsistency of started time '2014-09-25 12:57:50'!=''!
Error occurred during recovery process (code 6).


Please advise what I should do to be able to restore configurations and mails to the new server from my full backup.

Thanks.

  •  
Jonas Rodrigues (Kerio)

Messages: 262
Karma: 22
Send a private message to this user
Hello,

The error means that the backup is not complete. The last part of the backup (last file) should contain the .summary.txt file, which guarantees the consistency of the backup. The file has not been found, which means that the last file of the backup is probably missing.

All the best,

Jonas

Kerio Technical Support
Log Support Incidents here: http://www.kerio.com/support
Also, please use our KB: http://kb.kerio.com
  •  
dtcb2003

Messages: 13
Karma: 0
Send a private message to this user
Hi Jonas,

I got an email report that the full backup completed successfully. I also looked at the last file of the backup and confirmed that I do have the .summary.txt file.

Backup status in Kerio Admin interface also shows "successful backup".

I have tried 2 different sets of full backups and both gave me the same error.

Thanks.
  •  
Neil Whiteside (Kerio)

Messages: 318

Karma: 35
Send a private message to this user
Hello,

What platform are you trying to recover onto? It might be that the ZIP files contain data that doesn't fit with the platform (Unacceptable characters in filenames, pathnames too lengthy, etc).

Try running the ZIPs through a WinRAR to see if that reports any errors with the files.


[Updated on: Fri, 03 October 2014 12:12]


Knowledge Base: http://kb.kerio.com/.
Looking for technical support? http://www.kerio.com/support
  •  
dtcb2003

Messages: 13
Karma: 0
Send a private message to this user
Hi Neil,

Windows 2008 R2 platform. (Old server is running Windows 2003 32-bit)
I have run the zip files through WinRAR and no errors found.

Thanks.
  •  
Radek Sip (Kerio)

Messages: 1313
Karma: 48
Send a private message to this user
Is the installed Kerio Connect binary 64bit or 32bit? Where is it installed, in Program Files, or Program Files (x86)?

Stay Connected Anytime, Anywhere. Discover Kerio Cloud!
  •  
dtcb2003

Messages: 13
Karma: 0
Send a private message to this user
Hi Radek,

The Kerio Connect is 32-bit and it was installed in the Program Files (x86) folder.

Thanks.
  •  
Radek Sip (Kerio)

Messages: 1313
Karma: 48
Send a private message to this user
Probably the recover does not work because there are different paths to the mail store (Program Files vs. Program Files (x86)

I suggest try manualy define the path to the store for kmsrecover.exe
http://kb.kerio.com/1141

Or try install 64bit Kerio Connect to the "Program Files" and then try recover again.

Stay Connected Anytime, Anywhere. Discover Kerio Cloud!
  •  
dtcb2003

Messages: 13
Karma: 0
Send a private message to this user
Could you send me a link to download Kerio 7.4.0 64-bit version? I can't find it on your website.

I modified the server.cfg file and defined the path to the Store (same settings as the old server), but I still have the same error message.

Thanks.
  •  
Jonas Rodrigues (Kerio)

Messages: 262
Karma: 22
Send a private message to this user
Hello,

Kerio Connect 7.4.0 only has 32bits version.

Have you tried running your backup again, this error usually means your backup flies are corrupt.

I hope it helps.

Jonas

Kerio Technical Support
Log Support Incidents here: http://www.kerio.com/support
Also, please use our KB: http://kb.kerio.com
  •  
dtcb2003

Messages: 13
Karma: 0
Send a private message to this user
Hi Jonas,

Yes, I have. I used several different full backup sets and still have the same problem.

Thanks.
  •  
dtcb2003

Messages: 13
Karma: 0
Send a private message to this user
Since I have no luck with the restore method, I used "Method 2: Transferring the configuration and mail store directory"

http://kb.kerio.com/product/kerio-connect/server-configurati on/export-and-migration/transferring-an-installation-of-keri o-connect-to-another-server-or-operating-system-360.html

Everything came over nicely onto the new server. The old server is still up and running. Can I use a synchronization software to sync the Store folder to get all mails transferred to the new new server at the cut-over time (I will stop Kerio Connect on the old before running the sync job.)? Anything else that I should do at the cut-over?

Thanks.
Previous Topic: Warm Spare / rsync
Next Topic: Email invite from resource?
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Thu Feb 23 08:06:28 CET 2017

Total time taken to generate the page: 0.01200 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.