Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Control » Problems with NAT and Steam(valve)
  •  
tekert

Messages: 4
Karma: 0
Send a private message to this user
I cant connect to steam..
the problem its in NAT (behind winroute).

network:
PC A = Windows Server 2003 with Winroute 6. (direct inet conecction)
PC B = Windows XP. (uses NAT)

PC A = Steam works (winroute running)
PC B = Internet (web, nat etc works) but with steam no..

When i try lo log in steam, i see that a TCP (NAT rule), is created for steam but
nothing more, no bytes received or send.
(on PC A, its same but the conecction works.. bytes are transfered and i can log in).

the prof is that connecting PC B directly to internet (no winroute) the program connects and i can log..

i dont know if steam or winroute that's causing the problem.

if someone knows anything please let me know.
  •  
finbom

Messages: 31
Karma: 0
Send a private message to this user
Hello!

I have got the same problem with STEAM as you.
My network is setup just like yours and nothing happens when I try to login to steam, the logon-windows just stays there and nothing happens. (I have let the machine stay on for 12 hours...)

But I have two things that I know (that maybe more confuses things...Wink

1. It has been working just fine for me until my ISP changed their technical solution in my area forcing me to use a dynamic IP-adress instead of a fixed adress.
2. It does work on my NAT-client to create a new STEAM-account, but then my games are not there...

I have tried to create lots of different rules to specificly force the STEAM servers to forward info to my client, but nothing works.

I'm not sure, but It could be the that it worked in a previous version of Winroute. Not sure if something has been changed that could affect this.

I feel like creating a BRIDGE-rule... but as far as I know, Winroute does not support bridging.

Anyway, If someone could give a hint on what to try I would be happy... I cant find any info in the STEAM-forums. I have not been able to play Half-Life 2 for a month now, and it makes me feel abstinence.. Wink

regards, Magnus Finbom

ps. btw, I am currently using KWF 6.0.11

[Updated on: Thu, 14 July 2005 20:43]

  •  
Lumpy

Messages: 2

Karma: 0
Send a private message to this user
Hello!

i had the same problem,
i tried all the things you tried too.
then i read, i've got to set the MTU of the clients down...
i set it from 1500 to 1480 an it works very well.
i used the program "Dr.TCP" .
i hope i could help and sorry for my bad english Rolling Eyes

  •  
finbom

Messages: 31
Karma: 0
Send a private message to this user
Hi!

Wow! You are great! It worked.
I changed that MTU on the client to 1480, restarted and steam worked like a charm!

Now I can continue to protect the earth in half-life 2. Smile

Regards, Magnus Finbom

Magnus Finbom
Previous Topic: Setting up Traffic Rules...
Next Topic: Error on my Yahoo Messenger
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Fri Nov 24 02:55:37 CET 2017

Total time taken to generate the page: 0.00351 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.