Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » instant messaging
  •  
yukiomishima

Messages: 185
Karma: -2
Send a private message to this user
howdy

having issues connecting to the IM service (this is the Ist time that i have tried to set it up / connect)

here with the error log:

[11/Nov/2014 06:33:21][4470005760] {im} [external] Recv x.x.x.x:58490 <?xml version="1.0" encoding="UTF-8" ?> <stream:stream to="mail.domain.com" xmlns="jabber:client" xmlns:stream="http://etherx.jabber.org/streams" version="1.0"> (IOService.readData)

[11/Nov/2014 06:33:21][4470005760] {im} [external] Stream opened: {xmlns:stream=http://etherx.jabber.org/streams, to=mail.domain.com, xmlns=jabber:client, version=1.0} (ClientConnectionManager.xmppStreamOpened)

[11/Nov/2014 06:33:21][4470005760] {im} [external] Send x.x.x.x:58490 <?xml version='1.0'?><stream:stream xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams' id='tigase-error-tigase' from='192.168.1.103' version='1.0' xml:lang='en'><stream:error><host-unknown xmlns='urn:ietf:params:xml:ns:xmpp-streams'/></stream:error ></stream:stream> (IOService.writeData)

[11/Nov/2014 06:33:21][4470005760] {im} [external] Socket: TLS: c2s<_at_>192.168.1.103/192.168.1.103_5223_x.x.x.x_58490 Socket[addr=/x.x.x.x,port=58490,localport=5223], Force stop called... (IOService.forceStop)

[11/Nov/2014 06:33:21][4470005760] {im} [external] Calling stop on: TLS: c2s<_at_>192.168.1.103/192.168.1.103_5223_x.x.x.x_58490 Socket[addr=/x.x.x.x,port=58490,localport=5223] (IOService.forceStop)

[11/Nov/2014 06:33:21][4470005760] {im} [external] Calling stop on the listener: tigase.server.xmppclient.ClientConnectionManager<_at_>320b34b1 (IOService.forceStop)

[11/Nov/2014 06:33:21][4470005760] {im} [external] Unregistering connection x.x.x.x_58490 from keriodb://service/a81f358e-1700-40fe-b3fc-871ca2f6666cservic e x.x.x.x from 58490:{4} (ConnectionListener.disconnected)

[11/Nov/2014 06:33:21][4470005760] {im} [external] [[c2s]] Connection stopped: c2s@192.168.1.103/192.168.1.103_5223_x.x.x.x_58490, type: accept, Socket: TLS: c2s<_at_>192.168.1.103/192.168.1.103_5223_x.x.x.x_58490 Socket[unconnected] (ConnectionManager.serviceStopped)

[11/Nov/2014 06:33:21][4470005760] {im} [external] Stream closed: c2s<_at_>192.168.1.103/192.168.1.103_5223_x.x.x.x_58490 (ClientConnectionManager.xmppStreamClosed)

[11/Nov/2014 06:33:21][4470005760] {im} [external] Socket: TLS: c2s<_at_>192.168.1.103/192.168.1.103_5223_x.x.x.x_58490 Socket[unconnected], Force stop called... (IOService.forceStop)

[11/Nov/2014 06:33:21][4470005760] {im} [external] Service listener is null: TLS: c2s<_at_>192.168.1.103/192.168.1.103_5223_x.x.x.x_58490 Socket[unconnected] (IOService.forceStop)


i have opened port 5222, 5223 and 5269 (both UDP and TCP) on our firewall and point them to the internal IP address of our server

any help greatly appreciated

thanks in advance

yukioMishima
  •  
Tomas Skoda (Kerio)

Messages: 107
Karma: 20
Send a private message to this user
Hi,

you are probably using wrong credentials. Use the primary email address as username e.g. 'yukiomishima<_at_>your-domain.com'. Check that the domain you are using - in this case 'your-domain.com' - is hosted on machine with IP 192.168.1.103.

Most of im clients I've seen have a single field for username. The only exception is Pidgin which has two fields for it and expect to username and domain to be filled separately.

Cheers,
Tomas Skoda
  •  
yukiomishima

Messages: 185
Karma: -2
Send a private message to this user
thanks for the reply

when setting up the client i did in fact use the format: user<_at_>domain.com

i have tried connecting using a number of different clients... and also from outside the office (coming in via the public ip>router>internal private ip).. as well as within the office using the private ip address (ie. user<_at_>192.168.1.103).... none of which work

any additional insights greatly appreciated

thanks in advance

yukioMishima
  •  
Tomas Skoda (Kerio)

Messages: 107
Karma: 20
Send a private message to this user
Still it looks like Instant Messaging service doesn't know the domain you are trying to connect to. This could be also caused by domain synchronisation error. Check log files within 'store/xmpp/logs' for error messages saying that some domain failed to sync. If such error exist delete folder corresponding to that domain within 'store/xmpp/database' folder. Don't forget to stop Kerio Connect before.

In case you don't want to go through the log files and you haven't used Instant Messaging service ever before (so there is no risk of loosing any user data) you can delete whole 'store/xmpp/database' folder.

It this still doesn't help please contact our Technical Support or send me link to zipped logs from 'store/xmpp/logs' in PM. Please also attach screenshot of your IM client account settings.

Cheers,
Tomas

Just to clarify: user<_at_>192.168.1.103 would work only if you have configured domain with name '192.168.1.103'.
  •  
yukiomishima

Messages: 185
Karma: -2
Send a private message to this user
thanks for the reply

i will take a look at deleting the store files at a time when i can shut the server down for a few minutes

btw... we are running server version 8.2.4.... would that make any difference?

should i upgrade to 8.3.4 as a matter of course?

thanks again for all

yukioMishima
  •  
yukiomishima

Messages: 185
Karma: -2
Send a private message to this user
howdy

just received this back from tech support at the manuf of our router:

I am afraid there are no changes to the configuration of the router that will prevent this problem from occurring. The error appears to be in the authentication of the client to the server. The client believes it is authenticating to the public IP before NAT but messages from the server to the client contain the server's private IP. There is no way for the router to modify the contents of those messages to reflect the fact that NAT is taking place and so unless the server can tell the client it is authenticating to the public IP I think it will continue to fail.

does this sound like it could be causing the issue

if so... anything we can do on the server side?

huge thanks again

yukioMishima
  •  
yukiomishima

Messages: 185
Karma: -2
Send a private message to this user
anyone?

thanks in advance

yukioMishima
  •  
ksnyder

Messages: 557
Karma: 36
Send a private message to this user
Do you have the appropriate services running on Kerio Connect server? Configuration-->Services Instant Messaging and Secure Instant Messaging?

SRV records set up appropriately at your domain provider?

Do you get 4 green checkmarks across the board when you are on Configuration-->Instant Messaging-->Check Service Accessibility?

Ken Snyder
Previous Topic: error 14 when restoring
Next Topic: Spoofed identify on authenticated user having alias or multiple emails
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Thu Feb 23 05:52:39 CET 2017

Total time taken to generate the page: 0.01109 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.