Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Full text search not working
  •  
sramdeen

Messages: 14
Karma: -1
Send a private message to this user
Users are constantly complaining of "your full text index is being re-indexed". The indexing feature is enabled and the path is correct and has data in it.
I have tried disabling and re-enabling, moving the fulltext store folder aside and creating a new one, upgrading Kerio to 8.4.1, nothing has made any improvement. Here is a pastebin of the fulltext section from the debug log:

http://pastebin.com/Lt5EgJYA

An excerpt, mainly for the benefit of the search feature:

[10/Feb/2015 11:07:28][4588060672] {fulltext} [external] INFO vm.version: 20.65-b04-462 (FullTextServer.logJavaVersion)
[10/Feb/2015 11:07:28][4588060672] {fulltext} [external] INFO fulltext user database loaded, index store features: case INSENSITIVE (FullTextServer.setMessageHandler)
[10/Feb/2015 11:07:37][4600680448] {fulltext} Start processing fulltext service request: getUsers
[10/Feb/2015 11:07:41][4600680448] {fulltext} Fulltext request getUsers took 4586 ms. Sending 190 user(s).
[10/Feb/2015 11:07:43][4600680448] {fulltext} Start processing fulltext service request: getChanges
[10/Feb/2015 11:07:43][4600680448] {fulltext} Fulltext request getChanges took 0 ms. Sending 0 changes(s).
[10/Feb/2015 11:07:44][4600680448] {fulltext} Start processing fulltext service request: getChanges
[10/Feb/2015 11:07:44][4600680448] {fulltext} Sending all changes for user ssalmon<_at_>example.com (fulltext service is reindexing the user).
[10/Feb/2015 11:07:44][4600680448] {fulltext} Fulltext request getChanges took 14 ms. Sending 622 changes(s).
[10/Feb/2015 11:07:46][4600680448] {fulltext} Start processing fulltext service request: getMessages
[10/Feb/2015 11:07:46][4600680448] {fulltext} Fulltext request getMessages took 20 ms. Sending 30 message(s).

[10/Feb/2015 11:08:06][4600680448] {fulltext} Fulltext request getMessages took 17 ms. Sending 30 message(s).
[10/Feb/2015 11:08:07][4600680448] {fulltext} Start processing fulltext service request: getMessages
[10/Feb/2015 11:08:07][4600680448] {fulltext} Fulltext request getMessages took 15 ms. Sending 30 message(s).
[10/Feb/2015 11:08:08][4694478848] {fulltext} Unsupported imap search query: 1:* NOT DELETED
[10/Feb/2015 11:08:08][4694478848] {fulltext} Unsupported imap search query: UID 1:5918 UNSEEN
[10/Feb/2015 11:08:08][4694478848] {fulltext} Unsupported imap search query: UID 1:5918 DELETED
[10/Feb/2015 11:08:08][4694478848] {fulltext} Unsupported imap search query: UID 1:5918 FLAGGED
[10/Feb/2015 11:08:09][4600680448] {fulltext} Start processing fulltext service request: getMessages
[10/Feb/2015 11:08:09][4600680448] {fulltext} Fulltext request getMessages took 17 ms. Sending 30 message(s).
[10/Feb/2015 11:08:09][4694478848] {fulltext} Unsupported imap search query: UID 1:5918 ANSWERED

[10/Feb/2015 11:08:24][4529852416] {fulltext} Unsupported imap search query: 1:* UNSEEN UNDELETED
[10/Feb/2015 11:08:24][4529852416] {fulltext} Unsupported imap search query: 1:* DELETED
[10/Feb/2015 11:08:25][4600680448] {fulltext} Start processing fulltext service request: getChanges
[10/Feb/2015 11:08:25][4600680448] {fulltext} Fulltext request getChanges took 0 ms. Sending 0 changes(s).
[10/Feb/2015 11:08:26][4600680448] {fulltext} Start processing fulltext service request: getMessages
[10/Feb/2015 11:08:26][4600680448] {fulltext} Fulltext request getMessages took 23 ms. Sending 30 message(s).
[10/Feb/2015 11:08:26][4588060672] {fulltext} [external] INFO Memory usage info, used: 25212088, total: 85000192 (FullTextServer$2.run)
[10/Feb/2015 11:08:27][4600680448] {fulltext} Start processing fulltext service request: getMessages
[10/Feb/2015 11:08:27][4600680448] {fulltext} Fulltext request getMessages took 27 ms. Sending 30 message(s).
[10/Feb/2015 11:08:28][4600680448] {fulltext} Start processing fulltext service request: getMessages
[10/Feb/2015 11:08:28][4600680448] {fulltext} Fulltext request getMessages took 22 ms. Sending 30 message(s).
[10/Feb/2015 11:08:29][4600680448] {fulltext} Start processing fulltext service request: getMessages
[10/Feb/2015 11:08:29][4600680448] {fulltext} Fulltext request getMessages took 29 ms. Sending 30 message(s).
[10/Feb/2015 11:08:30][4600680448] {fulltext} Start processing fulltext service request: getMessages
[10/Feb/2015 11:08:30][4600680448] {fulltext} Fulltext request getMessages took 17 ms. Sending 30 message(s).
[10/Feb/2015 11:08:32][4600680448] {fulltext} Start processing fulltext service request: getMessages
[10/Feb/2015 11:08:32][4600680448] {fulltext} Fulltext request getMessages took 56 ms. Sending 30 message(s).
[10/Feb/2015 11:08:33][4600680448] {fulltext} Start processing fulltext service request: getMessages
[10/Feb/2015 11:08:33][4600680448] {fulltext} Fulltext request getMessages took 25 ms. Sending 30 message(s).
[10/Feb/2015 11:08:34][4600680448] {fulltext} Start processing fulltext service request: getMessages
[10/Feb/2015 11:08:34][4600680448] {fulltext} Fulltext request getMessages took 43 ms. Sending 30 message(s).
[10/Feb/2015 11:08:35][4600680448] {fulltext} Start processing fulltext service request: getChanges
[10/Feb/2015 11:08:35][4600680448] {fulltext} Fulltext request getChanges took 1 ms. Sending 0 changes(s).
[10/Feb/2015 11:08:36][4600680448] {fulltext} Start processing fulltext service request: getMessages
[10/Feb/2015 11:08:36][4600680448] {fulltext} Fulltext request getMessages took 24 ms. Sending 30 message(s).


Users are unable to search for any messages. Even if I turn full text searching off and attempt to search only for subject, sender or recipient, I receive an error telling me that the full text server is not running.

It was yesterday that I started receiving lots of support calls about this. Nothing that I know of has changed on the server (Mac 10.6.Cool. Could it be something related to Java? Crashplan is still working fine so I know Java is functional.

Thanks
  •  
JJJCR

Messages: 110
Karma: -6
Send a private message to this user
have you tried to stop and start kerio service?

service has still space?
  •  
sramdeen

Messages: 14
Karma: -1
Send a private message to this user
  •  
Tomas Skoda (Kerio)

Messages: 107
Karma: 20
Send a private message to this user
Please contact our Technical Support at http://www.kerio. com/support/technical-support. They will tell you which logs / files we need to see to be able to help you.

Thank you,
Tomas Skoda
  •  
star7591

Messages: 5
Karma: 0
Send a private message to this user
I step into this discussion because I have the same (except not moved ore updated to 8.4/8.5 yet).
I run 8.3.4 on a 10.6.8 plenty of RAM (3 of 12GB used), diskspace (800GB of 3.6TB used).

AND: no message in the logs!
What shall I do.
  •  
EdRoxter

Messages: 67
Karma: 2
Send a private message to this user
Same problem here since yesterday, with KC 8.5.1 on a Debian Linux. I have already opened a support ticket, answer pending. If I get a response that includes information on how to resolve this, I will post it here!
  •  
star7591

Messages: 5
Karma: 0
Send a private message to this user
I openened a support ticket as well (yesterday 18:00 UTC) no repsonse yet. For the time beeing I changed my debug log to see what the fulltest search is doing. It shows
[10/Jul/2015 06:21:21][4573392896] {fulltext} Fulltext request getMessages took 11 ms. Sending 30 message(s).
[10/Jul/2015 06:21:21][4490080256] {search} Folder checker thread opening folder ~aaa<_at_>bbb.cc/mymailinfo-0
[10/Jul/2015 06:21:22][4539912192] {fulltext} [external] INFO Memory usage info, used: 81654984, total: 129957888 (FullTextServer$2.run)
[10/Jul/2015 06:21:22][4573392896] {fulltext} Start processing fulltext service request: getMessages
[10/Jul/2015 06:21:22][4573392896] {fulltext} Fulltext request getMessages took 11 ms. Sending 30 message(s).
[10/Jul/2015 06:21:22][4490080256] {search} Folder checker thread opening folder ~t.horat<_at_>mathis-meier.ch/2012-11 EFH Bäbler, Naasstrasse/ausgang/4.5 unternehmer/282 wandbeläge
[10/Jul/2015 06:21:23][4490080256] {search} Folder checker thread opening folder ~aaa<_at_>bbb.cc/mymailinfo
[10/Jul/2015 06:21:23][4573392896] {fulltext} Start processing fulltext service request: getMessages
[10/Jul/2015 06:21:23][4573392896] {fulltext} Fulltext request getMessages took 8 ms. Sending 30 message(s).

It's running (after de- and reactivation) for almoust 48hours but no significant effect.
  •  
EdRoxter

Messages: 67
Karma: 2
Send a private message to this user
I know this is old, but what kind of solved it for me was migrating from KC 32-bit edition (Debian Linux) to KC 64-bit edition.
After that, the indexing process finished in a few hours. Of course I'm not exactly sure if it was the switch, or if it had only taken these few hours anyway, but I have the feeling that the overall performance on 64-bit is waaaaay better, so this may likely be connected.
Previous Topic: Items Clean-Out not working?
Next Topic: EWS - FindAppointments Issue
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Thu Dec 08 08:47:46 CET 2016

Total time taken to generate the page: 0.02371 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.