Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Cant upgrade in Linux from 7.4.2 build 7694 to latest version
  •  
Wicky

Messages: 6
Karma: -4
Send a private message to this user
I am running centos linux 5.11 (final) want to upgrade to latest today Smile)

I downloaded the .rpm and when i want to install this i get the error below:

tmp]# rpm -i kerio-connect-8.4.1-3789-linux-x86_64.rpm
error: Failed dependencies:
sysstat is needed by kerio-connect-8.4.1.3789-1.x86_64
libc.so.6(GLIBC_2.7)(64bit) is needed by kerio-connect-8.4.1.3789-1.x86_64
libc.so.6(GLIBC_2.9)(64bit) is needed by kerio-connect-8.4.1.3789-1.x86_64
libstdc++.so.6(GLIBCXX_3.4.11)(64bit) is needed by kerio-connect-8.4.1.3789-1.x86_64
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) is needed by kerio-connect-8.4.1.3789-1.x86_64

Tried to find the missing thinks but seem to have a problem getting it ???

I do remember that i quoted a year ago because of the same fact. it is only fallback, but stil want to run it whiith updated kerio

regards William

  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
For 64-bit version of Kerio Connect you need CentOS 6 and higher. See the system requirements on Kerio website.
  •  
Wicky

Messages: 6
Karma: -4
Send a private message to this user
What am i running now on my server than. i do have 7.4.2 build 7694

and when i run uname -a -m -p i get :


Linux mail2.elcanet.nl 2.6.18-398.el5 #1 SMP Tue Sep 16 20:50:52 EDT 2014 x86_64 x86_64 x86_64 GNU/Linux


So from version 64 bit 7 to version 64 bit 8 i have to change os ??


That is nice Sad(



  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
Version 7.4.2 is not 64-bit. If you upgrade to 32-bit version of Kerio Connect, you would be fine. But you tried to install 64-bit version and it is not supported on CentOS 5.
  •  
Wicky

Messages: 6
Karma: -4
Send a private message to this user
that makes my day, so gust keep it 32bit for the time being...Smile)



  •  
Wicky

Messages: 6
Karma: -4
Send a private message to this user
is there a big divergence in using 32 or 64 bit kerio software ??

  •  
Wicky

Messages: 6
Karma: -4
Send a private message to this user
still have a smaal problem

[root<_at_>mail2 tmp]# rpm -i kerio-connect-8.4.1-3789-linux-i386.rpm
error: Failed dependencies:
sysstat is needed by kerio-connect-8.4.1.3789-1.i386
[root@mail2 tmp]#
  •  
Wicky

Messages: 6
Karma: -4
Send a private message to this user
Then i read the forum and saw that i can use Yum..

so i did:

sudo yum install kerio-connect-8.4.1-3789-linux-i386.rpm
Failed to set locale, defaulting to C
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: centos.mirror.transip.nl
* extras: mirrors.supportex.net
* updates: mirrors.supportex.net
etc etc etc

then i get :

Total size: 439 M
Total download size: 189 k
Is this ok [y/N]: y
Downloading Packages:
sysstat-7.0.2-13.el5.x86_64.rpm | 189 kB 00:00


Package kerio-connect-8.4.1-3789-linux-i386.rpm is not signed

How do i Sign a Package ????

regards
  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
Wicky wrote on Thu, 26 February 2015 16:47
still have a smaal problem

[root<_at_>mail2 tmp]# rpm -i kerio-connect-8.4.1-3789-linux-i386.rpm
error: Failed dependencies:
sysstat is needed by kerio-connect-8.4.1.3789-1.i386
[root@mail2 tmp]#


Problem? It is a standard RPM dependency. Please make yourself more familiar with CentOS.

sudo yum install sysstat
sudo rpm -i kerio-connect-8.4.1-3789-linux-i386.rpm 

[Updated on: Thu, 26 February 2015 20:53]

Previous Topic: pop3 download process problem
Next Topic: KOFF autoupdate feature
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Tue Jun 27 16:01:43 CEST 2017

Total time taken to generate the page: 0.00432 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.