Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Wrong IP address
  •  
addihetja

Messages: 9
Karma: 0
Send a private message to this user
I have a Kerio Connect (8.4.3) server running on Linux with two IP addresses on the same MAC address. The SMTP service is bound to one of the interfaces,IP1, and not to the other,IP2.

Now I'm getting mails bouncing because the IP doesn't match the HELO on the server...because Kerio keeps using IP2 to send emails.

Is there any way to stop this behavior witout resorting to iptables?
  •  
addihetja

Messages: 9
Karma: 0
Send a private message to this user
I've tried changing mailserver.cfg to use IP2 as the BindIP, to no avail.
  •  
ksnyder

Messages: 557
Karma: 36
Send a private message to this user
Have you made the necessary modification to your Domain to bind it to the desired IP address?

http://forums.kerio.com/mv/msg/27440/114093/#msg_114093

Ken Snyder
  •  
addihetja

Messages: 9
Karma: 0
Send a private message to this user
I changed the bind address for all domains and mail is now routed via the correct interface.

But I can't log in to the admin interface anymore. Neither appending <_at_>"example.com" to the username or resetting the password via the method described in http://kb.kerio.com/product/kerio-connect/troubleshooting/ho w-do-i-reset-the-password-for-a-user-if-i-ve-lost-access-to- the-webadmin-of-kerio-connect-448.html seems to work.
  •  
ksnyder

Messages: 557
Karma: 36
Send a private message to this user
This is puzzling. I can't think of any reason why this would happen. Are you attempting to log in as the true "Admin" user or as yourself (with admin privileges)?

Ken Snyder
  •  
Brian Carmichael (Kerio)

Messages: 624
Karma: 63
Send a private message to this user
You can look at the security log file directly from the file system (/store_path/logs/). It should append some detailed message regarding your failed login so that we may have a better idea as to why your login doesn't work.

Brian Carmichael
Senior Technical Marketing Engineer | Kerio
Stay Connected Anytime, Anywhere. Discover Kerio Cloud!
  •  
addihetja

Messages: 9
Karma: 0
Send a private message to this user
When I log in as "admin" I get this in the security.log:

[24/Apr/2015 18:39:08] HTTP/WebAdmin: User admin<_at_>secondarydomain doesn't exist. Attempt from IP address 192.168.1.20.

When I log in as admin<_at_>maindomain (where maindomain is the domain admin belongs to in the users.cfg
[24/Apr/2015 18:39:15] HTTP/WebAdmin: Invalid password for user admin<_at_>primarydomain. Attempt from IP address 192.168.1.20.
  •  
Brian Carmichael (Kerio)

Messages: 624
Karma: 63
Send a private message to this user
Once you get back in, make sure to create an admin account under the remote administration section. To get back in, KB 448 should have helped. Did you make sure to stop the mail server before updating the file? Otherwise, if you can login as another user, you can elevate them to an admin through the configuration file. Set the "rights" variable in the users.cfg file to the value of "3" to specify admin rights. Remember to first stop the mail server before updating the file.

Brian Carmichael
Senior Technical Marketing Engineer | Kerio
Stay Connected Anytime, Anywhere. Discover Kerio Cloud!
Previous Topic: OFR102_104
Next Topic: Conversation Cleanup
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Wed Mar 29 13:11:08 CEST 2017

Total time taken to generate the page: 0.01223 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.