Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Connect Client crash when forward from search
  •  
Grabsteinschubser

Messages: 64
Karma: 4
Send a private message to this user
Hi,

sometimes the Connect Client crashes when I (or my users) try to forward an email from the search results.

That is how I reproduced the error:

- Email is not in /INBOX (or subfolder) - e.g. it is in /public folder/xyz or /test-folder
- Search email (all folders)
- Choose forward to the found email.

This is what the crash report says:
Quote:
Product name: Kerio Connect
Version: 8.5.0.4416
Module: Kerio Connect Client
UserAgent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.81 Safari/537.36
Platform: Win32
ServerOs: CentOS release 6.6 (Final), x86
Language: default
Resolution: 1920x1200
Zoom: unknown
DetectedBrowser: Chrome 43
ErrorMessage: TypeError: Cannot read property 'get' of null
Url: /webmail/webmail2.js?v=806a5cedddc5062221775eddff94db98
Line: 85083
ActiveDialogId: forward
NavigationItemId: mail
WindowSize: 1920x1075
RunTime: 494
DeveloperToolActive: Yes
BrowserSpeed: unknown
PreviousWidgetId: mail
CallStack: TypeError: Cannot read property 'get' of null
at Ext.define._getFromAddr (/webmail/webmail2.js:85083:30)
at Ext.define.setForwardDataToForm (/webmail/webmail2.js:85114:20)
at kerio.wm.store.GlobalFolderStore.load.callback (/webmail/webmail2.js:86566:24)
at Ext.define._onAllFoldersLoaded (/webmail/webmail2.js:55571:28)
at /webmail/webmail2.js:69:20
Custom data:{"reportsCount":4,"isMultiServer":false,"activePanel ":"Ext.Component"}
  •  
Vicky Tripp (Kerio)

Messages: 656

Karma: 81
Send a private message to this user
Hi Arne,

Are you uploading these reports to Kerio? I assume the crash you are seeing is a Kerio crash window right? If yes and you have been uploading the crash reports please let me know what time this has been done and what version you are using and I can try and find the crash report.

All the best,
Vicky

Vicky Tripp
Kerio Technical Support Engineer
  •  
Grabsteinschubser

Messages: 64
Karma: 4
Send a private message to this user
Hi Vicky,

yes, I did upload the reports. It was today between 10:15 and 12:15 (CEST). Version: 8.5.0.4416

Thank you!
  •  
Vicky Tripp (Kerio)

Messages: 656

Karma: 81
Send a private message to this user
Hi Arne,

I cannot find the files unfortunately, maybe they didn't reach our servers or the connection dropped. What you might find more useful is to create a support ticket with us as we can track future crash report uploads more easily that way. If you wish to do that please use the link below:

https://support.kerio.com/kerio_api/incident_wizard/submit_n ew_incident.php?language=en

All the best,
Vicky

Vicky Tripp
Kerio Technical Support Engineer
  •  
Grabsteinschubser

Messages: 64
Karma: 4
Send a private message to this user
How does Kerio Connect communicate with your server to send crash reports? Maybe my firewall is blocking the communication. But I see no problems in the firewall logs :-/
  •  
  •  
Grabsteinschubser

Messages: 64
Karma: 4
Send a private message to this user
Ok, so it has to work independent of how the server is secured. I just sent you a crash report from my home pc (no security appliance that can break communication)
  •  
Vicky Tripp (Kerio)

Messages: 656

Karma: 81
Send a private message to this user
Hi Arne,

I think I found your report but it appears to not have completed the upload. Can you send another report but put your email address in the email field and your username in the notes field so I can track the report down. Also what system are you running Kerio Connect on?

All the best,
Vicky

Vicky Tripp
Kerio Technical Support Engineer
  •  
Vicky Tripp (Kerio)

Messages: 656

Karma: 81
Send a private message to this user
Hi Arne,

My colleague believes to have found the report and it is with the web developers currently. If you wish to follow up further on this please create a support ticket so that we can open up proper line for communicating with yourself and the developers to get more information on this.

All the best,
Vicky

Vicky Tripp
Kerio Technical Support Engineer
  •  
Grabsteinschubser

Messages: 64
Karma: 4
Send a private message to this user
Thank you! It's ok, I will wait for what's coming Wink It doesn't happen that often that a user forwards a mail from search results that is not in his inbox or not in his inbox-subfolders. So it is not mission critical. I guess there will be a patch in the future that fixes this bug.

Edit says: It also happens if I try to answer one of those mails. The old webmailer is certainly not affected (I was not able reproduce it in the old webmailer).

[Updated on: Thu, 11 June 2015 13:17]

Previous Topic: Missing old sent emails from Kerio Connect
Next Topic: Free/Busy Issue
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sat May 27 04:25:00 CEST 2017

Total time taken to generate the page: 0.01155 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.