Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect Multi-Server » Testing Kerio Connect Multi-Server (A short recap of my findings so far)
  •  
JeroenKeerl

Messages: 9
Karma: 0
Send a private message to this user
I've spent the last few days (nights) with KCMS and I came to a verdict this morning.

1) Installation routine: Not fit for purpose: As soon as the appliance starts it moves on the the role definition, assuming that a DHCP server is in place. Unfortunately this leads to roles being installed with these DHCP address being written in config files. This led to massive troubles afterwards, when I -of course- gave every server his own fixed address. Especially the front-end server was quite stubborn there. Workaround: Implement DHCP reservations for those IPs you are planning to use.

2) Unstable installation: After 3 attempts of installing all 4 different roles I can conclude: None of these ran without error. First try: backend server couldn't start XINETD. Second try: Frontend buggy, second backend server could not connect, never showed up. Third try: Puppet master buggy, stranded at adding the directory server

3) A complete lack of proper documentation!
If something is going down the drain, a KB would be nice. More than "take a look at your logfiles in the admin interface" is about all you get. No hints about config files for puppet, nginx and the like, you're completely left by yourself.

4) By the looks of it, KCMS is NOT suitable for hosted environments. I was able to connect my "old" KCS with the new KCMS (Lack of proper documentation for the editing of the LDAP component too. Took me quite a while until I found out where the actual changes need to be made).
I was not able to migrate the mailboxes of my users though.
Neither was I able to connect / migrate any of the users in hosted (non-primary) domains.

So all in all: KCMS is not even near the state of "stable, ready to use".
There's still an extreme lot of work to do!

PS:
Yes, VMware is big. But why are you making such a fuzz about providing us simple VHD(X) disk images?
  •  
Stepan Potys (Kerio)

Messages: 86
Karma: 2
Send a private message to this user
Hi Jeroen,

thank you for your comments and suggestions. You've apparently met with many difficulties when deploying Kerio Connect Multi-server. Your feedback is very helpful to us and I appreciate the effort you put into it. There definitely are many things to work on as yet as it's the very first version of the "product". All the points make a very good sense.
As for VMware ... it was just our first choice as we already had VMware images for classic installations. We're collecting requests to decide on other types of images.

Thank you

Stepan Potys
Connect Core team leader
Kerio Technologies
  •  
JeroenKeerl

Messages: 9
Karma: 0
Send a private message to this user
Stepan,

thank you very much for your feedback.

Despite the many set backs I experienced, I am sure that Kerio MultiServer will grow better and better.
You are very welcome to get in touch with us, should you need any further -in depth- information, including a way to actually get the Virtual Appliance running under Hyper-V without much effort.

Kind regards
Jeroen
Previous Topic: Multi Server install on windows?
Next Topic: changing IPs in KCMS
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Mon May 29 09:47:15 CEST 2017

Total time taken to generate the page: 0.02127 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.