Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Control » Run website on a different port then 80.
  •  
claudio.maras

Messages: 3
Karma: 0
Send a private message to this user
Hi,

I've seen simmilar post to my problems but very short descriptions and no solutions.

My problem is basically I want to run a website that the user types the port number in the browser like:

http//www.website.com:8888

to connect. This worked with no problems on the old Winroute Pro versions, basically all that was required in the PAT was

Listen Port: 8888
IP Address: Internal IP of WWW Server (192.168.0.10)
Internal Port: 8888

but in the new version of Winroute this is not possible anymore, I'm running:

Winroute Firewall 6.0.4.

I have tried the following rules:

Source: WAN
Destination: Firewall
Service: TCP:8888
Translation: 192.168.0.10:8888

With the above rule it doesnt work, so I tried just adding the HTTP service:

Source: WAN
Destination: Firewall
Service: HTTP
Translation: 192.168.0.10:8888

Well now if port is not specified in the broswer like:

http//www.website.com

it works just fine, so the Translation part works. So I thought ok I have to make my own "Definition", so I created a copy of the HTTP definition but changed "Destination Port" to 8888. Please not that this is the ONLY differance between the two definitions (Check out the picture).

So I apply the following rule:

Source: WAN
Destination: Firewall
Service: HTTP_8888
Translation: 192.168.0.10:8888

and agian website is not accessible using the link:

http//www.website.com:8888

or (of course)

http//www.website.com

I find this very strange why Winroute works wityh the HTTP definition on port 80 but not if you change it to a different port?

I have attached the 3 settings in a .gif which might help... Smile

http://forums.kerio.com/index.php?t=getfile&id=249

Anybody have any idea?

I would greatly appriciate it.

Regards,
Claudio






  •  
claudio.maras

Messages: 3
Karma: 0
Send a private message to this user
OK,

I guess I have to appologise for being a moron.

You see to test the my settings I used Remote Desktop to access another PC outside my LAN.

What I was not awear of was that the Firewall on this PC's LAN does not allow outgoing traffic on port 8888.

Just tried from a second location and it work no problem.

I used the HTTP_8888 definition and no worries at all, I also suspect that using TCP:8888 under Service works too.

Ohhh well thanks for reading I hope you enjoyed it Rolling Eyes

Regards,
Claudio
  •  
ewieldra

Messages: 32

Karma: 0
Send a private message to this user
well explained... i read the whole story and i thought.. nothing wrong... and ... yes.... yes.... you gave the answer yourself... no moron ... it happens sometimes...
Laughing

Thnx and Greetings...

Emiel Wieldraaijer
The Netherlands
Previous Topic: denial page not shown in win XP
Next Topic: Future Function Wish List
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Thu Nov 23 06:36:05 CET 2017

Total time taken to generate the page: 0.00362 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.