Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » KOFF performance Issue (Trouble shooting)
  •  
Bud Durland

Messages: 370
Karma: 39
Send a private message to this user
One of ou sites is having signigicant issues since we have move them from local Exchange to Kerio Connect. They connect to the server over a VPN. The symptom is that sometimes performance is OK, but most often the users have to wait while Outlook is in a 'not responding' state. We've been checking all the typical things -- message counts, etc. My gut feeling is that it's something with either the set up of the PC's, or the remote network/lan.

We captured a log file from one user. This is a sample entry. I can upload more if needed, but this one seems the most relevant. Can anyone shed any additional light?

[19/08/2015 09:18:12.596](5804){err}{communication} In SCProvider\Communicator.cpp:268 (Communicator::checkAndLogResult)
[#3] (E655) Exception of class HResultException: SCProvider\HttpConnection.cpp(144), HttpConnection::checkStatus:
0x80042013 KOFF_E_REQUEST_FAILED (Request info: Download message store=xxxxx<_at_>yyyy.com folderId=ff77c8f1-<snip>-85ffc80e9478 uid=000044a5 messageType=normal mask=0) (Response info: status = 404 Not found) 
  •  
Pavel Dostal (Kerio)

Messages: 181
Karma: 5
Send a private message to this user
This log entry is probably innocent. Such log occurs (in most cases) Kerio Outlook Connector tries to get information about some message deleted in Kerio Connect just a moment before.

Pavel Dostal
Kerio Technologies
  •  
Bud Durland

Messages: 370
Karma: 39
Send a private message to this user
This user only uses OutLook and her iPhone, so the Kerio Connect client is not in play here. We captured the debug log from this user's system. I did not look at errors that occurred immediately after OutLook started, on the theory that messages deleted via the iPhone will generate some type of 'message not found' situation when OutLook tries to sync.

However, I see a couple instances well after startup of this message appearing literally hundreds of times in the span of a minute. Because OutLook goes into a 'Not Responding' state, it feels to me like some kind of timeout problem either going back to the server, or on the local cache. We've check the VPN bandwidth logs, and there's no indication of saturation there.

So I'm looking to see if there's some other debugging we can enable, or some other trick to at least give us some direction to start looking for the problem. I'm tempted to shutdown the server and remove the users __keriomapi__Store folder. That has resolved other weirdness for us in the past.
  •  
Pavel Dostal (Kerio)

Messages: 181
Karma: 5
Send a private message to this user
Those "Not Found" logs can be caused by deletion in the Outlook itself, it depends on the order of responses from Connect. It shouldn't affect work with Outlook unless you deletes hundreds of messages every other minute. It could be an issue just if such deletion is not synchronized successfully and same operation is performed again and again. However there is a simple way to find out if it is such issue. Every "Not Found" log contains message id (contains of folderId and uid). Just check if same message id occurs repeatedly in the log.

Most communication between Kerio Outlook Connector and Connect server is asynchronous (from Outlook's point of view), so the capacity of the line shouldn't cause any lags in Outlook. It's not true just in the situation when it takes tens of seconds to check state of the connection to Connect server. Nevertheless it doesn't takes tens of second to connect to Connect server successfully, it is mostly caused by some conditions that prevent connection to server (like some type of DNS issue) and such condition should be logged in Kerio Outlook Connector debug.log.

Your issue is most likely caused by the local cache. If you have bigger mailbox, some operations can take a long time (search typically or grouping mails in conversation) and even the rest can be slow if the harddrive with Kerio Outlook Connector local cache is used by some other process intensively.


Pavel Dostal
Kerio Technologies
Previous Topic: X-faches wiederholen von Termineinladungen ├╝ber das iPhone
Next Topic: Outlook 2011 Sync problem
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Tue Mar 28 17:54:35 CEST 2017

Total time taken to generate the page: 0.00878 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.