Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Recipient's mailbox busy
  •  
r1sh

Messages: 91
Karma: -3
Send a private message to this user
Hello!

I'm getting this error when someone write to our users.

I've disabled backups and restarted after that Kerio Connect, it helped for some hours, but later this problem occured again. And Kerio increases disk usage up to 100%.

https://www.dropbox.com/s/maxa68f64vttxyg/kerio%20disk%20usa ge%201.jpg?dl=0
https://www.dropbox.com/s/pexpnqlplwskfj2/kerio%20disk%20usa ge%202.jpg?dl=0

Is there any solution?
  •  
r1sh

Messages: 91
Karma: -3
Send a private message to this user
I've turned off backups, but mailboxes are still get busy in 3 days after restart.

It's a disaster!!!!!
Help me!!!
  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
Any chance that the users use iPhone or iPad with iOS 9 and IMAP account there? We've found that iOS 9 mail client with IMAP can cause very high load in user mailbox.
  •  
r1sh

Messages: 91
Karma: -3
Send a private message to this user
Pavel Dobry (Kerio) wrote on Thu, 01 October 2015 13:57
Any chance that the users use iPhone or iPad with iOS 9 and IMAP account there? We've found that iOS 9 mail client with IMAP can cause very high load in user mailbox.


YEEEEAH!!! I thought that the problem is on user's side.

I have 3 users on Apple Macbook Air using Mail software. And their mailboxes were always busy.

iOS 10.10.5
  •  
j.a.duke

Messages: 351
Karma: 11
Send a private message to this user
r1sh wrote on Thu, 01 October 2015 08:46
Pavel Dobry (Kerio) wrote on Thu, 01 October 2015 13:57
Any chance that the users use iPhone or iPad with iOS 9 and IMAP account there? We've found that iOS 9 mail client with IMAP can cause very high load in user mailbox.


YEEEEAH!!! I thought that the problem is on user's side.

I have 3 users on Apple Macbook Air using Mail software. And their mailboxes were always busy.

iOS 10.10.5

That's not iOS 9...that's Mac OS X (or just Mac OS).

Are you seeing "Status: 4.3.0 Recipient's mailbox busy" in the mail log?

I'm running KC8.5.2 and seeing those errors in the mail log due to write performance on our mail data disk. The data disk is a RAID 5 array, but that's changing in a week or so to a RAID 10 array and eventually I'm installing new hardware with a faster disk system.

It isn't a client issue but a mail server hardware issue.

Cheers,
Jon
  •  
ordway9841

Messages: 14
Karma: 0
Send a private message to this user
I am getting the same "Status: 4.3.0 Recipient's mailbox busy" and have talked to tech support. They are blaming it on the number of messages the users have in their INBOX. Tech support says they should have less than 5,000 messages in the INBOX. Not sure why this problem has not surfaced before if that is the case. I have many users over 5K and some users over 100K messages in their INBOX.

I hadn't thought about disk speed. I'll have to test that. Right now I have a RAID 5 connected via Thunderbolt but maybe there is some issue. Going to check disk speed this weekend.

This same problem is also reported at http://forums.kerio.com/t/29515//

[Updated on: Fri, 02 October 2015 23:46]

  •  
j.a.duke

Messages: 351
Karma: 11
Send a private message to this user
ordway9841 wrote on Fri, 02 October 2015 17:40
I am getting the same "Status: 4.3.0 Recipient's mailbox busy" and have talked to tech support. They are blaming it on the number of messages the users have in their INBOX. Tech support says they should have less than 5,000 messages in the INBOX. Not sure why this problem has not surfaced before if that is the case. I have many users over 5K and some users over 100K messages in their INBOX.

I hadn't thought about disk speed. I'll have to test that. Right now I have a RAID 5 connected via Thunderbolt but maybe there is some issue. Going to check disk speed this weekend.

This same problem is also reported at http://forums.kerio.com/t/29515//

That's the thread I started...

I moved our server mail store from an old xServe with a small, slow mirror to what I thought would be a faster Thunderbolt RAID 5 array, but it turns out to be slower in practice.

I'm hopefully moving to a RAID 10 array in the next week or so and that, again, in theory, fix the problem. Longer-term, I'm moving to CentOS, also with RAID 10 which has a better handle on large numbers of files (similar numbers to yours). I just have to be more comfortable with CLI for system management.

If there's anything I can do to help you out, PM me and I'll share what I've learned.

Cheers,
Jon
  •  
r1sh

Messages: 91
Karma: -3
Send a private message to this user
Guys, our mail server runs on RAID 10 SAS 10k disks in Hyper-V VM.

I never had any troubles with peformance.

The point is that according to ProcessMonitor Kerio access files round and round. It can do all day and it doesn't depend on number of files.

Second point is that at one time only one mailbox is busy. So one day one user has problems, second day another user has problems.

Third point is that I can copy user's mailbox in 10 minutes. So 10 minutes - is actual time for reading all messages in mailbox. Not 30 minutes, not hour as does Kerio.

5000 letters? Do they think that people who use Kerio work in company for 6 month?

For example, I work in my company for 1,5 years and I already have 6749 letters. If could sort all letters in one window and delete them - it would be ok. But with their interface I need to scroll ~2000 pages. God, help me)))


j.a.duke wrote on Sat, 03 October 2015 05:16

I'm hopefully moving to a RAID 10 array in the next week or so and that, again, in theory, fix the problem. Longer-term, I'm moving to CentOS, also with RAID 10 which has a better handle on large numbers of files (similar numbers to yours). I just have to be more comfortable with CLI for system management.


CLI for Kerio?

Quote:


If there's anything I can do to help you out, PM me and I'll share what I've learned.

Cheers,
Jon


Thank you, I appriciate your help !

[Updated on: Mon, 05 October 2015 09:46]

  •  
j.a.duke

Messages: 351
Karma: 11
Send a private message to this user
r1sh wrote on Mon, 05 October 2015 03:44
j.a.duke wrote on Sat, 03 October 2015 05:16

I'm hopefully moving to a RAID 10 array in the next week or so and that, again, in theory, fix the problem. Longer-term, I'm moving to CentOS, also with RAID 10 which has a better handle on large numbers of files (similar numbers to yours). I just have to be more comfortable with CLI for system management.


CLI for Kerio?



No, CLI for CentOS. I'm so used to a GUI, but I really should learn command line regardless of which OS on which we run Kerio.

I know I can install a GUI on CentOS, but that's just uneeded and wasted cycles.

Cheers,
Jon
  •  
r1sh

Messages: 91
Karma: -3
Send a private message to this user
could you please tell me how could it be helpfull for kerio administration?

I noticed that when I receive "Mailbox busy" message, in Resmon I see System pid 4, when I use Process Monitor it shows mailserver.exe pid 3156.

How can it be explained?

https://www.dropbox.com/s/jfs7u1prukn5zrd/kerio%20disk%20usa ge%201.jpg?dl=0
https://www.dropbox.com/s/pb6a3aphqi3wp0d/kerio%20disk%20usa ge%202.jpg?dl=0
  •  
willxhunting

Messages: 6
Karma: 0
Send a private message to this user
we have started having this issue after downgrading to 8.5.0. This issue did not occur prior to the 8.5.x updates. Has anyone gotten any resolution to the mailbox being busy? It freezes the user's account from receiving or sending email for an unknown instance of time which is not acceptable.
  •  
r1sh

Messages: 91
Karma: -3
Send a private message to this user
it's strange but I noticed that when users access mailox from outdise the office, this problem doesn't occure...

I guess that Kerio Version doesn't metter because I've downgraded to 8.4.3 and it didn't help.

I'll try to downgrade more, maybe it helps and look deeper in Macos' client config.

[Updated on: Wed, 04 November 2015 22:44]

  •  
ordway9841

Messages: 14
Karma: 0
Send a private message to this user
Since upgrading to 8.5.3 I have not seen the "Mailbox busy" message.
r1sh

Messages: 91
Karma: -3
Send a private message to this user
It seems like doing full sync on Mail to syncronize all folders solved problems on 3 macbooks
Previous Topic: Send to email with IP address instead of domain
Next Topic: Issue with booking a resource with a repeating event
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Tue Aug 22 15:00:45 CEST 2017

Total time taken to generate the page: 0.00539 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.