Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » SOLUTION- Logs not working, adm console crashing.
  •  
RF-Ent

Messages: 8
Karma: 0
Send a private message to this user
Just figured it out...

1. Stop KMS.
2. Make a backup copy of the "mailserver.cfg" file.
3. Edit the "mailserver.cfg" file as follows...
3a. Almost at the end of the file, find "table name="LogGlobal".
3b. Correct all the wrong-direction slashes and the path.
3c. Save the file.
4. Re-start KMS and your logs are working.

Don't miss the wrong-direction slash at the end of the path string.

Enjoy! :)
  •  
santo

Messages: 16
Karma: 0
Send a private message to this user
Great, logs are working now !

I have to make one remark though:
Just correcting the wrong-direction slashes was not enough for me,
because the variable pointed to the initial log path (d:\software\kerio_mailserver\mailserver/store/logs/) that doesn't exist, because I told KMS to use another folder for the log files.

Putting in the correct path (E:\serverdata\kerio_mailserver\logs\) was enough to make it work.

So, this is what it looked like before:
<table name="LogGlobal">
  <variable name="RelativePathsRoot">d:\software\kerio_mailserver\mailserver/store/logs/</variable>
</table>

and this is how it looks now:
<table name="LogGlobal">
  <variable name="RelativePathsRoot">E:\serverdata\kerio_mailserver\logs\</variable>
</table>

  •  
pwhodges

Messages: 144
Karma: 0
Send a private message to this user
Thanks - that fixed it for me, too.

Paul
  •  
pwhodges

Messages: 144
Karma: 0
Send a private message to this user
I went to look at the logs, and they have vanished again. Looking at the cfg file, I see some of the slashes are the wrong way again - what has changed them?

(using v6.0.2)

Paul Hodges

(edit - later)

Hmm - I see that if I change the slashes with Kerio not running, and then start it, the slashes are then changed to the wrong ones.

Why?

Paul

[Updated on: Mon, 27 September 2004 12:43]

Previous Topic: upgrading to 6.0.2, but always same problem...
Next Topic: Watch Dog
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sat Nov 18 16:28:08 CET 2017

Total time taken to generate the page: 0.00474 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.