Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Android 6.0 nexus 5 device problems - Exchange Activesync
  •  
walterzanella

Messages: 18

Karma: 1
Send a private message to this user
1) Problem with exchange activesync in error.log see this (i don't know if is a kerio o android problem) only one way sync server->device it seems to work, the other way don't (device->server):
[19/Oct/2015 10:36:19] ASyncAirSyncHelpers.cpp: Unable to parse request from mobile device. Invalid element: Type: 1, Tag: 0x0016. [User: x<_at_>x.it, Device: (android2792150100, Android, Android/6.0-EAS-2.0), IP address: x.x.x.x]
2) Other strange thing is the android features "smartlock" is disabled by administrator and can't be used. This after I add account. Anyway to use it ? With lollipop 5.1.1 no problem.
I hope this can help. Thanks.
  •  
radio_r

Messages: 3
Karma: 0
Send a private message to this user
I mentioned the patternlock issue here:
h*tp://forums.kerio.com/t/30014//

But there's no answer for that problem. Perhaps you cannot configure that in Kerio Connect.
  •  
Pavel Dobry (Kerio)

Messages: 5143
Karma: 241
Send a private message to this user
Currently we have no details about this Android 6.0 issue. Kerio Connect does not force PIN or password protection in EAS security policy. So if Android 6.0 disables some security option based on EAS account creation, it could be a feature of Android 6.0 or some misinterpretation in its EAS client.

Knowledge Base: http://kb.kerio.com/.
Technical support: http://www.kerio.com/support
------------------
Stay Connected Anytime, Anywhere. Discover Kerio Cloud!
  •  
walterzanella

Messages: 18

Karma: 1
Send a private message to this user
No Message Body

[Updated on: Fri, 30 October 2015 16:23]

  •  
walterzanella

Messages: 18

Karma: 1
Send a private message to this user
I have test with last versione of Kerio Connect 9.0 RC 2 (157).
If delete the account and re-create in mobile device (nexus 5 with android 6.0, Google Playservice 8.3) for a few hours all ok.
After this, probably when I reply to a message, the device account sync (exchange activesync) say there is a problem in syncronization and in kerio connect console log "error" appear message like this:

[28/Oct/2015 02:12:06] ASyncAirSyncHelpers.cpp: Unable to parse request from mobile device. Unknown element: Type: 0, Tag: 0x0008. [User: w???<_at_>d???.it, Device: (android27921????, Android, Android/6.0-EAS-2.0), IP address: 5.90.44.??]
[28/Oct/2015 02:12:41] ASyncAirSyncHelpers.cpp: Unable to parse request from mobile device. Unknown element: Type: 0, Tag: 0x0008. [User: w???<_at_>d???.it, Device: (android27921????, Android, Android/6.0-EAS-2.0), IP address: 5.90.44.??]
[28/Oct/2015 08:57:24] ASyncAirSyncHelpers.cpp: Unable to parse request from mobile device. Unknown element: Type: 0, Tag: 0x0008. [User: w???<_at_>d???.it, Device: (android27921????, Android, Android/6.0-EAS-2.0), IP address: 192.168.254.254]

After this the only to make sync works is delete and add account again in mobile device.
I wish this can help. Thanks.
  •  
modezeroltd

Messages: 13
Karma: 0
Send a private message to this user
I've got similar problems for one of my users with a Nexus 5 and Android 6.

[07/Nov/2015 11:57:46] ASyncAirSyncHelpers.cpp: Unable to parse request from mobile device. Invalid element: Type: 1, Tag: 0x0016. [User: *****<_at_>*****.***, Device: (android1417272625519, Android, Android/6.0-EAS-2.0), IP address: 188.29.164.229]
  •  
DuaM0Syh

Messages: 8
Karma: 0
Send a private message to this user
We have a similar problem with a user who has a nexus 6 / Android 6.0. Problem showed up after OTA update to new android version, so I believe this is specific to the 6.0 release.

ASyncAirSyncHelpers.cpp: Unable to parse request from mobile device. Unknown element: Type: 0, Tag: 0x0008. [User: USER<_at_>DOMAIN, Device: (androidNUMBERS, Android, Android/6.0-EAS-2.0), IP address: IPADDRESS]

Same issue as modez, after this occurs the only way to fix it is to delete and re-add account in phone. It then only lasts for a few hours. If you need further information, let me know.
  •  
Petr Silar (Kerio)

Messages: 107
Karma: 6
Send a private message to this user
Hi,
I'm not able to reproduce the issue with "Unknown/invalid element". Since it's clear it's some bug either on Connect's or Android's side, please open ticket w/ our Support department. They will ask you for Connect's debug log from the same moment the issue appeared in your error log. Therefore it's necessary you enable ActiveSync and HTTP messages for debug log in Admin console and then reproduce the issue.
Thank you

The pattern lock issue is fixed already and the fix will appear in some future service release.
  •  
modezeroltd

Messages: 13
Karma: 0
Send a private message to this user
Can you confirm which boxes I need to tick in the Debug log -> Messages... setup?

HTTP Server Modules -> ActiveSync Synchronization

and..?

Thanks.
  •  
lelsrud

Messages: 13
Karma: 0
Send a private message to this user
We have the same problem with windows (outlook16)
ASyncAirSyncHelpers.cpp: Unable to parse request from mobile device. Invalid element: Type: 1, Tag: 0x0016. [User: xxx<_at_>xxx.no, Device: (847BBBD560314BA689DA788B5BD4B43C, WindowsOutlook15, Outlook/16.0 (16.0.4288.1000; MSI; x64)), IP address: x.x.x.xx]


And also from iOs.
So this is not just a android problem.

When this happens in outlook, we have to create a whole new profile.
  •  
Petr Silar (Kerio)

Messages: 107
Karma: 6
Send a private message to this user
@modezeroltd

Services->HTTP Server
and
HTTP Server Modules->ActiveSync Synchronization

Thank you
  •  
modezeroltd

Messages: 13
Karma: 0
Send a private message to this user
Have PM'd with debug trace of the error.
  •  
walterzanella

Messages: 18

Karma: 1
Send a private message to this user
same error here with last kerio connect 9.0 after reply to a message:

[19/Nov/2015 17:19:51] SyncCommandHelpers.cpp: Unable to parse request from mobile device. Invalid element: Type: 1, Tag: 0x0016. [User: w???<_at_>?????.it, Device: (android2792??????, Android, Android/6.0-EAS-2.0), IP address: 192.168.254.254]
  •  
Petr Silar (Kerio)

Messages: 107
Karma: 6
Send a private message to this user
The issue with error log entries is finally fixed as well. It will be in the next Service Release of Connect.
DuaM0Syh

Messages: 8
Karma: 0
Send a private message to this user
Can you confirm if this will fix both the " Invalid element: Type: 1, Tag: 0x0016." and the " Unknown element: Type: 0, Tag: 0x0008. " errors seen on android 6.0 devices (usually after attempting to send a message)? We're affected by the latter while it appears several people are affected by the former.
Previous Topic: Cant see how to share an employees mail folder
Next Topic: Export Public Folders / Calendars to an .ics - file
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Tue Dec 06 18:52:16 CET 2016

Total time taken to generate the page: 0.01301 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.