Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect Multi-Server » We're testing multi-server (Here are some observations)
  •  
Bud Durland

Messages: 358
Karma: 38
Send a private message to this user
This past couple weeks, I've been able to dedicate more time to setting up a test environment with Kerio Connect Multi-Server. We had trouble getting started with KC/MS becuase of a bad NTP configuration on our VMWare server. Once we had that resolved, installation of the various component servers went as expected. I've created the puppetmaster, directory, a front-end, and two back end servers. We do not plan to deploy the IM server, and we already have a zabbix server on site. A couple days testing and playing around and now I'm familiar with how it works, which has generated some observations and questions:


  • Is there a document that explains the differences, from a functionality perspective, between using multi-server and a distributed domain?
  • Having to configure DHCP for each host before powering it up is not all that difficult but I still think the installer for Multi-Server should be smart enough to prompt me for IP configuration data when it runs.
  • Since at least 2 CPUs and 4GB of memory are required by all roles, the OVF template should have those set as the baseline.
  • When prompted for the host name during install, do not enter the fully qualified name. Use 'puppetmaster', not 'puppetmaster.mydomain.local'. I think this is more of a Linux thing than an installer issue.
  • The command 'puppet agent -t' will be your friend if something goes wrong.
  • When I migrated a user from one back-end server to the other 'backend-1' to 'backend-2', On the primary backed server, the user's 'Home Server' displays as 'backend-2', but in the admin console for the backend-2 server, the user's home server displays as 'mail2.mydomain.com' (public facing host name configured when the puppetmaster was installed).
  • In General, migrating users is apparently a very hit-or-miss process. Most of the time, trying to migrate a user from one server to another results in failure, with a message in the debug log 'finished with result: Failed (Error initializing MigrationDownloader)'
  • The Backend server configuration allows you to change the directory service assigned to your primary domain. This confuses me, since I thought that the multi-server directory server was *always* the authoritative source for users. On that note, I discovered that is you change this from "Custom LDAP Server' to anything else and apply the changes, "Custom LDAP Server" never appears again as a choice. I suspect that you can use "Apple OpenLDAP", provided you can remember the settings. Still it would be clearer is the choice was "Kerio Multi-Server Directory Server (server name)", with the values already prefilled.
  • If only 1 backend server is configured, when creating a new user, the "home Server" option is visible, and displays the GUID of the server, not the server name. When the user's data is edited, the "home server" choice does not display at all (as expected). This is a minor cosmetic issue.

[Updated on: Sun, 15 November 2015 21:53]

Previous Topic: Creating a new Domain
Next Topic: Import users
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Tue Jan 24 04:00:23 CET 2017

Total time taken to generate the page: 0.00614 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.