Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Operator » Problem Operator integration with Kerio Connect (Integration stopped working)
  •  
PPG

Messages: 68
Karma: 3
Send a private message to this user
I noticed that voicemails are no longer being forwarded to email adresses when using the integration with Kerio Connect option.
Configuration of the integration completes succesfully.

Using the non integrated mail option: voicemail does get forwarded.

Have tried to disable and enable the integration several times, restarted Kerio Operator, nothing seems to help,

Any ideas?
  •  
Vladimir Toncar (Kerio)

Messages: 1696
Karma: 39
Send a private message to this user
Hi,

The voicemail/e-mail integration uses IMAP to insert the voice messages to inboxes. This bypasses the filters.

Vladimir
  •  
PPG

Messages: 68
Karma: 3
Send a private message to this user
Hello Vladimir,

IMAP and Secure IMAP are both enabled on Connect.
Any thoughts on this?

  • Attachment: IMAP.JPG
    (Size: 17.09KB, Downloaded 143 times)
  •  
Vladimir Toncar (Kerio)

Messages: 1696
Karma: 39
Send a private message to this user
Hi,

Let me repeat that IMAP bypasses the e-mail filters on Kerio Connect. That's how it behaves.

Vladimir
  •  
PPG

Messages: 68
Karma: 3
Send a private message to this user
Ok, you mentioned that twice now. But how does your remark help me solve the problem that voicemail messages are no longer being delivered to email users when using the integration option and do get deliverd when usen the non-integrated option (mailserver adres)?

  •  
Vladimir Toncar (Kerio)

Messages: 1696
Karma: 39
Send a private message to this user
You used the word "forwarded" in your first post. Do you rely on e-mail forwarding to deliver the voicemail to the final destination?

Or do you want to say that messages do not appear in the users' inboxes at all?
  •  
PPG

Messages: 68
Karma: 3
Send a private message to this user
Vladimir Toncar (Kerio) wrote on Fri, 04 December 2015 11:46
You used the word "forwarded" in your first post. Do you rely on e-mail forwarding to deliver the voicemail to the final destination?

Or do you want to say that messages do not appear in the users' inboxes at all?


Ok, so thats where the confusion comes from. We do not rely on forwarding, the Operator instance and the Connect instance reside on the same fysical machine. The problem is that voicemail messages will no longer be delivered in users mailboxes when using the integration option. On the other hand, they do seem to be delivered and show up when using the SMTP delivery option.
  •  
Vladimir Toncar (Kerio)

Messages: 1696
Karma: 39
Send a private message to this user
Ok, is there anything interesting in either Operator's or Connect's error/warning logs?

You can also enable "Kerio Connect Integration" messages in Operator's debug log.

Let me know if you discover anything.
  •  
PPG

Messages: 68
Karma: 3
Send a private message to this user
Vladimir Toncar (Kerio) wrote on Fri, 04 December 2015 14:18
Ok, is there anything interesting in either Operator's or Connect's error/warning logs?

You can also enable "Kerio Connect Integration" messages in Operator's debug log.

Let me know if you discover anything.


This is what I did:
1. cleared the debug log in KO
2. Activated "Kerio Connect Integration"messages
3. Disabled all other debug log messages
4. activated the Kerio Connect integration
5. made a call to extension 90, belongs to User 'kantoor,
6. downloaded the log.

I'm not sure what to look for in KO's debug log so i have uploaded it with this post.

KC shows no strange behavior in any of the logs.

  • Attachment: debug.log.txt
    (Size: 121.67KB, Downloaded 56 times)
  •  
PPG

Messages: 68
Karma: 3
Send a private message to this user
Vladimir Toncar (Kerio) wrote on Fri, 04 December 2015 14:18
Ok, is there anything interesting in either Operator's or Connect's error/warning logs?

You can also enable "Kerio Connect Integration" messages in Operator's debug log.

Let me know if you discover anything.


Today after another effort in making the integration work I noticed something in th KO Errorlog:
[07/Dec/2015 16:37:06] CnfGenVoicemail::generateSymlinks - /var/spool/asterisk/voicemail/sip-locals/90 is not a symlink, ignoring...
[07/Dec/2015 16:37:06] CnfGenVoicemail::generateSymlinks - Failed to create symlink /var/spool/asterisk/voicemail/sip-locals/90 => /var/operator/running/voimapfs-mnt/kantoor.

Could this be of any help?
  •  
Vladimir Toncar (Kerio)

Messages: 1696
Karma: 39
Send a private message to this user
Did the Operator server have any power outages recently? Or if it is a virtual machine, did you force-stop it recently?

Can you download the support information file from the System Health screen in your Operator's administration interface and send it to me at vtoncar at kerio dot com?
Previous Topic: 1 extension, 2 registrations in one queue
Next Topic: connect Kerio Operator to AVM FritzBox
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sun Jan 22 13:17:44 CET 2017

Total time taken to generate the page: 0.01541 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.